在线检测未来函数

根据缠论“中枢确认”公式写一个选股公式

来源:Internet,编辑:股旁网,2012-03-15

编写要求:

股旁网解答:

 网友求助:

趋势:ZIG(3,5);
向上:=CROSS(趋势,REF(趋势,1));
向下:=CROSS(REF(趋势,1),趋势);
上1周期:=SUMBARS(向上,1);
上2周期:=SUMBARS(向上,2);
上3周期:=SUMBARS(向上,3);
下1周期:=SUMBARS(向下,1);
下2周期:=SUMBARS(向下,2);
下3周期:=SUMBARS(向下,3);

A1:=REF(趋势,下1周期);
A2:=REF(趋势,下2周期);
高点重叠:=MIN(A1,A2);
低点重叠:=MAX(REF(趋势,上1周期),REF(趋势,上2周期));

高点:=(趋势=高点重叠);
连线1:=BARSLAST(高点)>上1周期 OR BARSLAST(高点)>下1周期;
连线2:=BARSLAST(高点)<上2周期 OR BARSLAST(高点)<下2周期;

低点:=(趋势=低点重叠);
高1:=SUMBARS(高点,1);
高2:=SUMBARS(高点,2);
低1:=SUMBARS(低点,1);
低2:=SUMBARS(低点,2);


DRAWTEXT(C,高点重叠,'_____');
DRAWTEXT(C,低点重叠,'_____');
 

 
解答如下:
趋势:=ZIG(3,5);
CROSS(EVERY(趋势>REF(趋势,1),2),0.5);
 

 

相关文章