在线检测未来函数

通达信四档红绿灯指标公式

来源:Internet,编辑:股旁网,2012-04-01

C15:=C;
A15:=MAX(MA(C15,4),MA(C15,8));
B15:=MIN(MA(C15,4),MA(C15,8));
绿灯行15:C15>A15,COLORGREEN;
红灯停15:C15<B15,COLORRED;
黄灯观望15:A15>=C15 AND C15>=B15,COLORYELLOW ;
STICKLINE(C15>A15,17,20,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C15<B15,17,20,8,0),COLORRED,LINETHICK2;
STICKLINE(A15>=C15 AND C15>=B15,17,20,8,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,19,'【15日线】'),COLORBLUE;
C30:=C;
A30:=MAX(MA(C30,8),MA(C30,15));
B30:=MIN(MA(C30,8),MA(C30,15));
绿灯行30:C30>A30,COLORGREEN;
红灯停30:C30<B30,COLORRED;
黄灯观望30:A30>=C30 AND C30>=B30,COLORYELLOW ;
STICKLINE(C30>A30,12,15,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C30<B30,12,15,8,0),COLORRED,LINETHICK2;
STICKLINE(A30>=C30 AND C30>=B30,12,15,8,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,14,'【30日线】'),COLORBLUE;
C60:=C;
A60:=MAX(MA(C60,15),MA(C60,30));
B60:=MIN(MA(C60,15),MA(C60,30));
绿灯行60:C60>A60,COLORGREEN;
红灯停60:C60<B60,COLORRED;
黄灯观望60:A60>=C60 AND C60>=B60,COLORYELLOW ;
STICKLINE(C60>A60,7,10,8,0),COLORGREEN,LINETHICK2; {www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(C60<B60,7,10,8,0),COLORRED,LINETHICK2;
STICKLINE(A60>=C60 AND C60>=B60,7,10,8,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,9,'【60日线】'),COLORBLUE;
CC:=C;
A:=MAX(MA(CC,60),MA(CC,120));
B:=MIN(MA(CC,60),MA(CC,120));
绿灯行:C>A,COLORGREEN;
绿灯停:C<B,COLORRED;
黄灯观望:A>=C AND C>=B,COLORYELLOW ;
STICKLINE(C>A,2,5,8,0),COLORGREEN,LINETHICK2;
STICKLINE(C<B,2,5,8,0),COLORRED,LINETHICK2;
STICKLINE(A>=C AND C>=B,2,5,8,0),COLORYELLOW,LINETHICK2;
DRAWTEXT(C=C AND CURRBARSCOUNT=100,4,'【120日线】'),COLORBLUE;

通达信四档红绿灯指标公式

 

相关文章