在线检测未来函数

通达信金山指标公式

来源:Internet,编辑:股旁网,2012-04-02

N:=120;M:=89;
HLM1:=MA(HHV(H,500),13);
HLM2:=MA(HHV(H,250),13);
HLM3:=MA(HHV(H,89),13);
HLM4:=MA(LLV(L,500),13);
HLM5:=MA(LLV(L,250),13);
HLM6:=MA(LLV(L,89),13);
HLM7:=MA((HLM1*0.558+HLM2*0.558+HLM3*0.558+HLM4*0.96+HLM5*0.96+HLM6*0.96)/6,17);
HLM8:=MA((HLM1*0.55+HLM2*0.55+HLM3*0.65+HLM4*1.25+HLM5*1.23+HLM6*1.2)/6,17);
HLM9:=MA((HLM1*0.68+HLM2*0.68+HLM3*0.68+HLM4*1.3+HLM5*1.3+HLM6*1.3)/6,17);
HLM10:=MA((HLM7*3+HLM8*2+HLM9)/6*1.738,17);
HLM11:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
HLM12:=MA(IF(C*1.35<=HLM10,HLM11*10,HLM11/10),3);
HLMH:=HHV(HLM12,30);
关注:MA(IF(L<=LLV(L,13),(HLMH+HLM11*2)/2,0),3)/200,COLORFF00FF;
DRAWBAND(关注,RGB(255,255,50),0,RGB(0,100,50));
遵:IF(关注>=0,关注,DRAWNULL),COLORRED;
守:IF(0>=关注,0,DRAWNULL),COLORFF9900;
纪:IF(关注>=0,0,DRAWNULL),COLOR00FFFF;
律:IF(0>=关注,关注,DRAWNULL),COLOR00FF00;
STICKLINE(CROSS(关注,3.8),0,关注,3,0),COLORFF00FF;
DRAWTEXT(CROSS(关注,3.8),关注+2,'买底'),COLORFF00FF;
DRAWICON(CROSS(关注,10),关注,23);
DRAWTEXT(CROSS(关注,10),关注+2,'金山'),COLORFF00FF;
STICKLINE(CROSS(关注,62),0,关注,3,0),COLOR0000FF;
DRAWTEXT(CROSS(关注,62),关注,'倾买'),COLOR0000FF;
{www.gupang.com 股旁网_通达信股票指标公式}
A1:=PPART(M)*100,COLORFF00FF;{M日前那部分成本占总成本的比例}
B1:=MA(A1,N),COLOR0000FF;
AA1:=CROSS(5,A1);
AA2:=CROSS(0,A1);
AA3:=CROSS(-50,A1);
AA5:=CROSS(-100,A1);
AA4:=CROSS(-150,A1);
AA6:=CROSS(-200,A1);
AA7:=CROSS(50,A1);
TJ:=AA1 OR AA1 OR AA3 OR AA4 OR AA5 OR AA6 OR AA7;
TJ1:=CROSS(B1,A1);
STICKLINE(TJ,0,10,4,1),COLOR00FFFF;
STICKLINE(TJ1,0,10,4,1),COLOR0000FF;
STICKLINE(TJ1,0,10,0.3,0),COLOR00FFFF;
DRAWTEXT(TJ1,10,'主升'),COLOR0000FF;

通达信金山指标公式

 

相关文章