在线检测未来函数

大智慧黑马摇篮指标公式

来源:Internet,编辑:股旁网,2012-04-03

N:=5;
Va6:=(2*CLOSE+HIGH+LOW)/4;
Va8:=LLV(LOW,34);
VarB:=HHV(HIGH,34);
VarC:=EMA((Va6-Va8)/(VarB-Va8)*100,13);
VarD:=EMA(0.667*REF(VarC,1)+0.333*VarC,2);
生命线:EMA(VarD,N), colorff00ff,linethick2;
var1:=hhv(high,9)-llv(low,9);
var2:=hhv(high,9)-close;
var3:=close-llv(low,9);
var4:=((var2)/(var1))*(100)-70;
var5:=((close-llv(low,60))/(hhv(high,60)-llv(low,60)))*(100);
var6:=((2)*(close)+high+low)/(4);
var7:=sma(((var3)/(var1))*(100),3,1);
var8:=llv(low,34);
var9:=sma(var7,3,1)-sma(var4,9,1);
var10:=if((var9>100),var9-100,0);
var11:=hhv(high,34);
b1:=ema(((var6-var8)/(var11-var8))*(100),8);
b2:=ema(b1,5);
stickline(b1-b2>0,b1,b2,4,0),colorffffff;
stickline(b1-b2<0,b1,b2,4,0),colorFFFF52;
ss1:=(LOW+HIGH+CLOSE*2)/4;
ss2:= MA(ss1,4);
ss3:=HHV(ss2,10);
ss4:=ma(ss3,3);
ss5:=1.25*ss4-0.25*ss3;
xkkj:=if(ss5>ss3,ss3,ss5);
ff1:=LLV(ss2,10);
ff2:=ma(ff1,3);
ff3:=1.25*ff2-0.25*ff1;
dkkj:=if(ff3<ff1,ff1,ff3);
ma13:=ma(c,13);
zdhm:=cross(c,dkkj) and cross(c,ma13) and cross(c,xkkj);
zhm:=cross(c,ma13) and cross(c,xkkj);
{www.gupang.com 股旁网_大智慧股票指标公式}
黑马:if(zdhm or zhm,50,0),coloryellow,pointdot;
a:=(3*CLOSE+LOW+OPEN+HIGH)/6;
D1:=(20*a+19*REF(a,1)+18*REF(a,2)+17*REF(a,3)+16*REF(a,4)+15*REF(a,5)+14*REF(a,6) +13*REF(a,7)+12*REF(a,8)+11*REF(a,9)+10*REF(a,10)+9*REF(a,11)+8*REF(a,12) +7*REF(a,13)+6*REF(a,14)+5*REF(a,15)+4*REF(a,16)+3*REF(a,17)+2*REF(a,18)+ REF(a,20))/211;
D2:=EMA(D1,2); D3:=EMA(D2,2); K1:=EMA(D3,2);
小黑马:IF(CROSS(D1,K1),45,0),COLORFFCC66,POINTDOT;
stickline(大黑马>0,0,大黑马*1.1,1,0),colorwhite;
stickline(大黑马>0 and 大黑马<52,30,大黑马,1,0),colorred;
stickline(大黑马>0,0,大黑马*0.8,4,0),colorred; stickline(大黑马>0,0,大黑马*0.4,8,0),colorred;
stickline(大黑马>0,0,大黑马*0.2,10,0),coloryellow; stickline(大黑马>0,0,大黑马*0.1,10,0),colorffcc66;
stickline(小黑马>0,0,小黑马*1.1,1,0),colorwhite; stickline(小黑马>0 and 小黑马<52,30,小黑马,1,0),colorffcc66;
stickline(小黑马>0,0,小黑马*0.8,4,0),colorffcc66; stickline(小黑马>0,0,小黑马*0.4,8,0),colorffcc66;

大智慧黑马摇篮指标公式

 

相关文章