在线检测未来函数

飞狐寻庄KDJ指标公式

来源:Internet,编辑:股旁网,2012-04-04

N:=5;P:=12;
均价:=(2*C+(H-L)/2+L+o)/4;
价差:=SUM(均价-REF(均价,1),2)/2;
实价0:=(均价+价差);
实价:=(实价0+均价)/2;
VAR54:=IF(实价>0,(((均价+实价)/2)-LLV(均价,N))/(HHV(实价,N)-LLV(均价,N))*100,(((均价+实价)/2)-LLV(实价,N))/(HHV(均价,N)-LLV(实价,N))*100);
K:=sMA(VAR54,9,2),COLORMAGENTA;
D:=sMA(K,5,2),COLORFF8800,LINETHICK1;
j:3*k-2*D,COLORWHITE,LINETHICK1;
JJ:=ma(J,2),COLORMAGENTA;
VAR36:=if(实价>0,(HHV(实价,n/p)-((均价+实价)/2))/(HHV(实价,N/p)-LLV(均价,N/p))*100,(HHV(均价,n/p)-((均价+实价)/2))/(HHV(均价,N/p)-LLV(实价,N/p))*100);
KW:=sMA(VAR36,9,2),COLORMAGENTA;
{www.gupang.com 股旁网_飞狐股票指标公式}
DW:=sMA(KW,5,2),COLORFF8800,LINETHICK1;
jW:3*kW-2*DW,COLORGREEN,LINETHICK1;
JJW:=ma(JW,2),COLORGREEN;
KK:=SMA(VAR54,7,1),LINETHICK1,COLORYELLOW;
DD:=SMA(KK,5,1);
趋势:IF(CROSS(KK,DD) AND CROSS(MA(实价,5),MA(实价,13) AND KK>50) ,DD*2,DD),COLORRED;
PARTLINE(趋势>REF(趋势,1),趋势),COLORRED,LINETHICK2;
PARTLINE(趋势<REF(趋势,1),趋势),COLOR00bb00,LINETHICK2;
DRAWTEXT(CROSS(趋势,KK) ,趋势,'止赢!!'),color0000ff,ALIGN0;
DRAWTEXT(CROSS(KK,趋势) ,KK,'买'),color00ffff,ALIGN0;
波段高低点:ref(KK,BARSLAST(cross(ref(KK,3),KK))+1),POINTDOT,colorD3A9FF,LINETHICK3;
0,COLORAAAA00;20,COLORCYAN;50,COLORWHITE;80,COLORRED;

飞狐寻庄KDJ指标公式

 

相关文章