在线检测未来函数

飞狐米芳图主图指标公式

来源:Internet,编辑:股旁网,2012-04-06

M:=1;N:=1;F:=1;
YB:=SYSPARAM(2);
a:=SYSPARAM(3);
P0:=(a - YB);
S4:=SYSPARAM(4);
S5:=SYSPARAM(5);
HH:=HHVBARS(HIGH,(P0 + 1));
LL:=LLVBARS(LOW,(P0 + 1));
z:=(BARPOS = (a - HH[a]));
Y:=(BARPOS = (a - LL[a]));
K:=((S4 - S5) / (a - YB));
黄:=SYSPARAM(3);
金:=((黄 - SYSPARAM(2)) + 1);
分:=HHV(HIGH,金);
割:=LLV(LOW,金);
最高:分[黄],LINETHICK2,colorFF;
最低:割[黄],LINETHICK2,colorFF00;
分一:(最高- 最高*n*0.01),colorFF00FF;
分二:(分一-最高*n*0.01),colorFF00FF;
分三:(分二-最高*0.01*n),colorFF00FF;
分四:(分三-最高*0.01*n),colorFF00FF;
分五:(分四-最高*0.01*n),colorFF00FF;
分六:(分五-最高*0.01*n),colorff00ff;
分七:(分六-最高*0.01*n),colorff00ff;
分八:(分七-最高*0.01*n),colorff00ff;
分九:(分八-最高*0.01*n),colorff00ff;
分十:(分九-最高*0.01*n),colorff00ff;
分十一:(分十-最高*0.01*n),colorff00ff;
分十二:(分十一-最高*0.01*n),colorff00ff;
分十三:(分十二-最高*0.01*n),colorFF00FF;
分十四:(分十三-最高*0.01*n),colorFF00FF;
分十五:(分十四-最高*0.01*n),colorFF00FF;
分十六:(分十五-最高*0.01*n),colorff00ff;
分十七:(分十六-最高*0.01*n),colorff00ff;
分十八:(分十七-最高*0.01*n),colorff00ff;
分十九:(分十八-最高*0.01*n),colorff00ff;
DIFF:=(0 - LOG(MINDIFF));
{www.gupang.com 股旁网_飞狐股票指标公式}
DRAWTEXT((BARPOS = SYSPARAM(2)),最高,('最高' + NUMTOSTR(最高,DIFF))),colorFF00;
DRAWTEXT((BARPOS = SYSPARAM(2)),最低,('最低' + NUMTOSTR(最低,DIFF))),colorFF00;
t1:=FILTER(h=SYSPARAM(4),m);VERTLINE(t1),colorffffff;
t2:=REF(t1,m);VERTLINE(t2),colorffffff;
t3:=ref(t2,m);vertline(t3),colorffffff;
t4:=ref(t3,m);vertline(t4),colorffffff;
t5:=ref(t4,m);VERTLINE(t5),colorffffff;
t6:=ref(t5,m);VERTLINE(t6),colorffffff;
t7:=ref(t6,m);vertline(t7),colorffffff;
t8:=ref(t7,m);vertline(t8),colorffffff;
t9:=ref(t8,m);VERTLINE(t9),colorffffff;
t10:=ref(t9,m);VERTLINE(t10),colorffffff;
t11:=ref(t10,m);VERTLINE(t11),colorffffff;
t12:=REF(t11,m);VERTLINE(t12),colorffffff;
t13:=ref(t12,m);vertline(t13),colorffffff;
t14:=ref(t13,m);vertline(t14),colorffffff;
t15:=ref(t14,m);VERTLINE(t15),colorffffff;
t16:=ref(t15,m);VERTLINE(t16),colorffffff;
t17:=ref(t16,m);vertline(t17),colorffffff;
t18:=ref(t17,m);vertline(t18),colorffffff;
t19:=ref(t18,m);VERTLINE(t19),colorffffff;
t20:=ref(t19,m);VERTLINE(t20),colorffffff;
t21:=ref(t20,m);VERTLINE(t21),colorffffff;
t22:=REF(t21,m);VERTLINE(t22),colorffffff;
t23:=ref(t22,m);vertline(t23),colorffffff;
t24:=ref(t23,m);vertline(t24),colorffffff;
t25:=ref(t24,m);VERTLINE(t25),colorffffff;
t26:=ref(t25,m);VERTLINE(t26),colorffffff;
t27:=ref(t26,m);vertline(t27),colorffffff;
t28:=ref(t27,m);vertline(t28),colorffffff;
t29:=ref(t28,m);VERTLINE(t29),colorffffff;
t30:=ref(t29,m);VERTLINE(t30),colorffffff;
t31:=ref(t30,m);VERTLINE(t31),colorffffff;
DRAWSL(z,HIGH*(1+0.04*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1+0.03*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1+0.02*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1+0.01*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH,(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.01*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.02*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.03*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.04*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.05*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.06*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.07*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.08*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.09*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.1*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.11*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.12*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.13*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.14*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.15*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.16*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.17*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.18*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.19*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.2*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.21*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.22*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.23*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.24*f),(0 - ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.01*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.02*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.03*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.04*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.05*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.06*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.07*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.08*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.09*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.1*f),(0 +((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.11*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.12*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.13*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.14*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.15*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.16*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.17*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.18*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.19*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.2*f),(0 +((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.21*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.22*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.23*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;
DRAWSL(z,HIGH*(1-0.24*f),(0 + ((45 * K) / 60)),0,0),POINTDOT,colorFFFF00;

飞狐米芳图主图指标公式

 

相关文章