在线检测未来函数

大智慧多空支撑压力主图指标公式

来源:Internet,编辑:股旁网,2012-04-06

N:=10;
var1:=(SMA(HIGH,20,2) * 1.05);
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,9,0),colorFF5B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,8,0),colorFF6C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,7,0),colorFF7B00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,6,0),colorFF9C00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,5,0),colorFFBE00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,3.5,0),colorFFCC00;
STICKLINE((OPEN >= CLOSE),CLOSE,OPEN,1.5,0),colorFFFF00;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,9,0),color070084;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,8,0),color0000A3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,7,0),color0000B7;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,6,0),color0000CD;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,5,0),color0000E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,3,0),color0754E9;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1.5,0),color076EF3;
STICKLINE((CLOSE >= OPEN),CLOSE,OPEN,1,0),color077BF3;
STICKLINE((CLOSE > OPEN),OPEN,LOW,1,0),color0726CA;
STICKLINE((CLOSE > OPEN),CLOSE,HIGH,1,0),color0726CA;
STICKLINE((OPEN > CLOSE),CLOSE,LOW,1,0),colorDE9100;
STICKLINE((OPEN > CLOSE),OPEN,HIGH,1,0),colorDE9100;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,9,0),color0090FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,8,0),color009FFF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,4,0),color00B5FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,OPEN,2,0),color00E4FF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),OPEN,LOW,0.7,0),color00FFFF;
STICKLINE(((((CLOSE / OPEN) > 1.04) AND (CLOSE < var1)) AND ((CLOSE - REF(CLOSE,1)) > 0)),CLOSE,HIGH,0.7,0),color00FFFF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),OPEN,LOW,0.7,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,HIGH,0.7,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,9,0),colorFF00FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,6,0),colorFF62FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,4,0),colorFF76FF;
STICKLINE(((((CLOSE < REF(CLOSE,1)) AND (CLOSE < REF(CLOSE,1))) AND (HIGH > var1)) AND (CLOSE < var1)),CLOSE,OPEN,2,0),colorFFA8FF;
STICKLINE(l>ref(h,1),l,ref(h,1),50,1),COLORRED;
STICKLINE(h<ref(l,1),h,ref(l,1),50,1),colorgreen;
HLC:=REF(MA((HIGH+LOW+CLOSE)/3,N),1);
HV:=EMA(HHV(HIGH,N),3);
LV:=EMA(LLV(LOW,N),3);
STOR:EMA(2*HV-LV,3),linethick0;
MIDR:EMA(HLC+HV-LV,3),linethick1;
WEKR:EMA(HLC*2-LV,3),linethick1;
WEKS:EMA(HLC*2-HV,3),linethick1;
MIDS:EMA(HLC-HV+LV,3),linethick1;
STOS:EMA(2*LV-HV,3),linethick0;
nnl:=DISPSTATUS=2;
{DRAWTEXT(nnl,STOR,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLORddaa00;}
DRAWTEXT(nnl,MIDR,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLORddaa00;
DRAWTEXT(nnl,WEKR,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLOR0000ff;
DRAWTEXT(nnl,HLC,' ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLOR00ffff;
DRAWTEXT(nnl,WEKS,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLOR00ff00;
DRAWTEXT(nnl,MIDS,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLORddaa00;
{DRAWTEXT(nnl,STOS,' ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄ ̄'),ALIGN1,COLORddaa00;};
DRAWTEXT(nnl,MIDR,NUMTOSTRN(MIDR,2)),ALIGN2,VALIGN2,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,WEKR,NUMTOSTRN(WEKR,2)),ALIGN2,VALIGN2,Color0047FF,LINETHICK1;
DRAWTEXT(nnl,HLC,NUMTOSTRN(HLC,2)),ALIGN2,VALIGN2,Color00FFff,LINETHICK1;
DRAWTEXT(nnl,WEKS,NUMTOSTRN(WEKS,2)),ALIGN2,VALIGN2,COLOR00ff00,LINETHICK1;
DRAWTEXT(nnl,MIDS,NUMTOSTRN(MIDS,2)),ALIGN2,VALIGN2,Color00FFff,LINETHICK1;
BBI:=(2*C+H+L+O/2)/4.5;
var2:EMA(((SLOPE(BBI,18)*27)+BBI),45),COLOR00FFff,LINETHICK0;
PARTLINE(var2,var2>ref(var2,1),rgb(255,0,0)),LINETHICK0,LAYER0;
{www.gupang.com 股旁网_大智慧股票指标公式}
var3:(8*BBI+7*REF(BBI,1)+6*REF(BBI,2)+5*REF(BBI,3)+4*REF(BBI,4)+3*REF(BBI,5)+2*REF(BBI,6)
+1*REF(BBI,7))/36,COLORff00FF,LINETHICK0;
PARTLINE(var3,var3<ref(var3,1),rgb(0,255,0)),LINETHICK0,LAYER0;
DRAWGBK(var2>ref(var2,1),STRIP(RGB(0,0,255),RGB(120,0,80),0)),LAYER0;
重心:=(H+L+O+C*3)/6;
NX:=(3*CLOSE+LOW+OPEN+HIGH)/6;
牛线:=(20*NX+19*REF(NX,1)+18*REF(NX,2)+17*REF(NX,3)+16*REF(NX,4)
+15*REF(NX,5)+14*REF(NX,6)+13*REF(NX,7)+12*REF(NX,8)+11*REF(NX,9)
+10*REF(NX,10)+9*REF(NX,11)+8*REF(NX,12)+7*REF(NX,13)+6*REF(NX,14)
+5*REF(NX,15)+4*REF(NX,16)+3*REF(NX,17)
+2*REF(NX,18)+REF(NX,20))/210;
牛熊线:=MA(牛线,4);
partline(牛熊线,牛熊线<=牛线,rgb(255,0,0),牛熊线>牛线,rgb(0,255,0)),linethick2;

大智慧多空支撑压力主图指标公式

 

相关文章