在线检测未来函数

通达信小邪四区主图指标公式

来源:Internet,编辑:股旁网,2012-04-09

M:=120;
大盘指数:INDEXC,NODRAW,COLORLIMAGENTA ;
大盘指数涨跌:(大盘指数-REF(大盘指数,1)),NODRAW;
涨家数:INDEXADV,NODRAW,COLORLIMAGENTA ;
跌家数:INDEXDEC,NODRAW,COLORGREEN;
T:=120;{设置天数}
K:=BARSLAST(CURRBARSCOUNT=T);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));
KJ:=GD-DD;
GD4:=IF(CURRBARSCOUNT<=T/2,GD,DRAWNULL);
DRAWBAND(GD4,RGB(0,0,250),DD+KJ/2,RGB(0,0,0));{该行设置背景色}
平衡:IF(CURRBARSCOUNT<=T,DD+KJ/2,DRAWNULL),COLOR00FFFF,NODRAW;
压力:IF(CURRBARSCOUNT<=T,GD-KJ*0.191,DRAWNULL),COLORFF00FF,NODRAW;
支撑:IF(CURRBARSCOUNT<=T,DD+KJ*0.191,DRAWNULL),COLOR00FF00,NODRAW;
天:BARSLAST(L=DD),COLOR00FFFF,NODRAW;
高:IF(CURRBARSCOUNT<=T,GD,DRAWNULL),COLORGREEN,POINTDOT;
低:IF(CURRBARSCOUNT<=T,DD,DRAWNULL),COLORRED,POINTDOT;
STICKLINE(CURRBARSCOUNT=T,GD,DD,0,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=T/2,GD,DD,0,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,-1),COLORGREEN;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(CURRBARSCOUNT<=T,平衡,平衡,3,-1),COLORWHITE;
STICKLINE(CURRBARSCOUNT<=T/2,压力,压力,3,-1),COLORRED;
STICKLINE(CURRBARSCOUNT<=T/2,支撑,支撑,3,-1),COLORGREEN;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
DRAWTEXT(CURRBARSCOUNT=1,压力,'0.809'),COLOR0000FF;
DRAWTEXT(CURRBARSCOUNT=1,平衡,'0.500'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=1,支撑,'0.191'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=T/2+9,GD-KJ/12,'★强势区域--急拉减仓!'),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=T/2+9,GD-KJ/3,'●震荡整理--寻机低吸!'),COLOR00FF00;
DRAWTEXT(CURRBARSCOUNT=T/2+9,DD+KJ/3,'◆反弹中轨--逢高休息!'),COLORFFFFFF;
DRAWTEXT(CURRBARSCOUNT=T/2+9,DD+KJ/10,'■弱势区域--暂不参与!'),COLORFFFF00;
DRAWTEXT_FIX(1,0.00,0,0,'■ 目前K线天数:')COLORWHITE;
DRAWTEXT_FIX(1,0.12,0,0,'120天!')COLORWHITE;
DRAWTEXT_FIX(1,0.00,0.04,0,'■ 建议查阅K线:')COLORWHITE;
DRAWTEXT_FIX(1,0.12,0.04,0,'短线30天,中长线120天!')COLORWHITE;
VC:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100+(CLOSE-MA (CLOSE,32))/MA(CLOSE,32)*100)/3;
S2:=IF(VC>20 AND FILTER(VC< REF(VC,1),5),H+0.02,DRAWNULL),CIRCLEDOT,LINETHICK3,COLORGREEN;
A0:=(L+H+C*2)/4;
A1:EMA(A0,14),NODRAW;
A2:=EMA(A0,25),NODRAW;
A1X:=(A1-REF(A1,1))/REF(A1,1)*100,NODRAW;
A2X:=(A2-REF(A2,1))/REF(A2,1)*100,NODRAW;
买入持股:IF(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL),COLORMAGENTA,LINETHICK2;
卖出空仓:IF(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL),COLORCYAN,LINETHICK2;
做多:IF(A1X>=0,A1,DRAWNULL)COLORRED,LINETHICK2;
看空:IF(A1X<0 AND A2X<0,A1,DRAWNULL)COLORGREEN,LINETHICK2;
{STICKLINE(C<O,LOW,HIGH,0,1),COLOR00FF00;}{绿色上下影线}
STICKLINE(C<O,O,C,3,0),COLOR007700;{绿色}
STICKLINE(C<O,O,C,2,0),COLOR00AA00;
STICKLINE(C<O,O,C,1.2,0),COLOR00DD00;
STICKLINE(C<O,O,C,0.2,0),COLOR00FF00;
STICKLINE(C>O,O,C,3,0),COLOR000099;{红色}
STICKLINE(C>O,O,C,2,0),COLOR0000BB;
STICKLINE(C>O,O,C,1.3,0),COLOR0000DD;
STICKLINE(C>O,O,C,0.3,0),COLOR0000FF;
VAR1:=MA(CLOSE,5);
BOLL:MA(C,26),COLORYELLOW,POINTDOT;
UB:BOLL+2*STD(VAR1,26),COLORGREEN,CROSSDOT;
LB:BOLL-2*STD(VAR1,26),COLORRED,CROSSDOT;

通达信小邪四区主图指标公式

 

相关文章