在线检测未来函数

通达信叧类MACD指标公式

来源:Internet,编辑:股旁网,2012-04-10

X03:=(C+L)>(REF((C+L),1)+REF((C+L),2))/2;
VAR1:=(20*X03+19*REF(X03,1)+18*REF(X03,2)+17*REF(X03,3)+16*REF(X03,4)+15*REF(X03,5)+14*REF(X03,6)+13*REF(X03,7)+12*REF(X03,8)+11*REF(X03,9)+10*REF(X03,10)+9*REF(X03,11)+8*REF(X03,12)+7*REF(X03,13)+6*REF(X03,14)+5*REF(X03,15)+4*REF(X03,16)+3*REF(X03,17)+2*REF(X03,18)+REF(X03,20))/210;
VAR2:=ATAN((VAR1/REF(VAR1,1)-1)*100)*180/3.1416;
VAR3:=(POW(EMA(VAR2,2),3)/POW(10,8));
DIF:EMA(VAR3,2),COLORMAGENTA;
DEA:EMA(DIF,5),COLORYELLOW;
MACD:(DIF-DEA)*1,COLORSTICK;

通达信叧类MACD指标公式

 

相关文章