在线检测未来函数

通达信变色提示主图指标公式

来源:Internet,编辑:股旁网,2012-04-10

{上穿均线}
MA5:=MA(C,5);
MA20:MA(C,20),COLORYELLOW;
MA60:MA(C,60),COLORGREEN,LINETHICK2;
DRAWICON(CROSS(MA5,MA20),L*0.98,1);
DRAWTEXT(CROSS(MA5,MA20),L*0.95,'进');
DRAWICON(CROSS(MA60,C),H*1.05,2);
DRAWTEXT(CROSS(MA60,C),H*1.1,'逃!');
STICKLINE(C>MA20,C,O,2,0),COLOR0000CC;
STICKLINE(C<MA20,C,O,3,0),COLORFF6600;
STICKLINE(C>MA60,H,L,2,0),COLORRED;
{全线开花部分}
{MACD部分}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);DEA:=EMA(DIF,9);MACD1:=(DIF-DEA)*2;
{KDJ部分}
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;K:=SMA(RSV,3,1);D:=SMA(K,3,1);J:=3*K-2*D;
{DMI部分}
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
PDI:=DMP*100/MTR;
MDI:=DMM*100/MTR;
{www.gupang.com 股旁网_通达信股票指标公式}
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
ADXR:=EXPMEMA(ADX,6);
{DMI部分}
ROC:=100*(CLOSE-REF(CLOSE,12))/REF(CLOSE,12);MAROC:=MA(ROC,6);
AA:=ROC>MAROC AND PDI>ADXR AND PDI>ADX AND PDI>MDI AND K>D AND DIF>DEA AND C>REF(C,1) AND REF(H,1)>REF(C,2);
STICKLINE(AA,C,O,2,0),COLORYELLOW;
DRAWTEXT(AA AND CROSS(MA5,MA20),L*0.9,'开花'),COLORRED;

大智慧变色提示主图指标公式

 

相关文章