在线检测未来函数

通达信轨道整合主图指标公式

来源:Internet,编辑:股旁网,2012-04-10

KLC:=REF(C,1);
KRSI:=SMA(MAX(C-KLC,0),6,1)/SMA(ABS(C-KLC),6,1)*100;
KRSV1:=MA(100*EMA((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)),2),2);
KRSV2:=(C-LLV(L,25))/(HHV(H,25)-LLV(L,25))*100;
K0:=EMA(SLOPE(C,5)*20+C,34);
K1:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K2:=SMA(K1,3,1);
K3:=100*((EMA((H+L)/2,3)-LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-
EMA(L,20)))/(LLV(EMA((H+L)/2,5),30)-(EMA(H,20)-EMA(L,20))));
K4:=IF(EMA(C,2)>K0 AND K3>0,EMA(C,3),LLV(EMA((H+L)/2,5),30));
K5:=IF(EMA(C,2)>K0 AND K3>0,LLV(EMA((H+L)/2,5),30),EMA(C,5));
K6:=SMA(C,6.5,1);
K7:=SMA(C,14.5,1);
K8:=SMA(C,3,1);
K9:=SMA(C,8,1);
KA:=(2*C+H+L)/4;
KB:=MA(KA,5);
KC:=LLV((C+L)/2,21);
KC1:=LLV((C+L)/2,0);
KD:=HHV(KA,30)*1.01;
KE:=KB>=REF(KB,1);
KF:=MAX(MAX(K6,K9),K7);
KG:=MIN(MIN(K6,K9),K7);
KH:=EMA((KA-KC)/(KD-KC)*100,7);
KJ:=EMA(0.667*REF(KH,1)+0.333*KH,5);
KK:=1000*KB/K7<=1015 AND 1000*KB/K7>=975;
KL:=1000*K9/K7<=1020 AND K9/K7>=980;
KM:=1000*K6/K7<=1015 AND K6/K7>=985;
KN:=MA(C,89)-MA(C,10)/3;
KP:=SMA(KRSV2,3,1);
KQ:=SMA(KP,3,1);
KR:=3*KP-2*KQ;
KS:=(2*C+H+L)/3;
KT:=EMA(EMA(EMA(KS,4),4),4);
KU:=(KT-REF(KT,1))/REF(KT,1)*100;
KV:=MA(KU,3)+0.03;
KW:=MA(KU,1);
KX:=(C>O AND KF<C AND O<KG AND KE AND L>KC AND K8>K7 AND KR<90 AND CROSS(K8,KB)) OR
(C>O AND K6>K9 AND K9>K7 AND C>MA(C,K7) AND KB>=REF(C,KB) AND CROSS(K8,KB) AND
L>KC AND KR<90);
KY:=(CROSS(K8,KB) AND K8<K7 AND K8<K9 AND K8<K6 AND C>KC) OR
(IF(C<KN AND VOL/240>MA(VOL,5)/240 AND C>REF(C,1)*1.08
AND C<MA(C,13)*1.3,1,0));
KZ:=(CROSS(K8,KB) AND KK AND KL AND KM) OR
(CROSS(K8,K6) AND K8>KB) OR (CROSS(KW,KV)) OR
(IF(COUNT(C<REF(C,1),13)/13>6/10 AND COUNT(KH>KJ,6) AND
REF(L,5)=LLV(L,120) AND REF(C>=O,4) AND REF(C>O,3) AND REF(C>O,2) AND
REF(O>C,1) AND O>REF(C,1),1,0));
KI:=(COUNT(KD=REF(KD,1),3)=3 AND H>KD) OR
(REF(KD,2)<REF(KD,1) AND REF(KD,1)=KD AND REF(H,1)>KD);
KO:=(CROSS(82,KRSI) AND C<K8) OR (CROSS(KV,KW) AND KR>65) OR KI;
K20:=V*(O+C+H+L)/4;
K21:=IF(V>0,K20/V,(O+C+H+L)/4);
K22:=(K21-LLV(K21,3))/(HHV(K21,3)-LLV(K21,3));
K23:=SMA(K22,13,1);
K24:=SMA(K23,13,1);
K25:=3*K23-2*K24;
K26:=2*K25-0.5;
K27:=K21*(1-(K26-K24)/40);
K28:=CROSS(K21,K27) AND C/REF(C,1)<1.03 AND DYNAINFO(23)>=3000;
K29:=FILTER(K28,10);
K2A:=MA(C,80)-MA(C,13)/3;
K2B:=MA((C-K2A)/K2A,2);
K2C:=MA(K2B,2);
K2D:=REF(K2B,2)=LLV(K2B,20) AND REF(K2B,2)<0.071 AND REF(K2B,2)<REF(K2B,1) AND
NOT(REF(L,1)>REF(H,2) AND L>REF(H,1)) AND C>REF(C,1);
K2E:=CROSS(K2B,K2C) AND K2B<0.5;
K2F:=KRSV1>REF(KRSV1,1);
K2G:=KRSV1<=REF(KRSV1,1);
K2H:=C>O AND KB>K6 AND K6>K9 AND K9>K7 AND CROSS(K8,KB) AND L>KC AND KR<90;
K2I:=EMA(V*KA,21)/EMA(V,21);
K2J:=K2I-1.5*STD(K2I,34);
K2K:=K2I+2.0*STD(K2I,34);
K2L:=IF(C>=K2K OR H>=K2K,K2I+2*STD(K2I,55),DRAWNULL);
K2M:=COUNT(C<=K2J OR L<=K2J,3)>=2;
K2N:=C>=K2K OR H>=K2K OR ((C>K2L OR K2K>K2L) AND NOT(K2L=DRAWNULL));
箱顶:MA(KD,1),COLOR00FFFF;
箱底:MA(KC,1),COLOR22FF22;
黄金线:(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4,COLOREAEAAE;
中轨2:=EMA(C,250);
上轨2:中轨2+ 2*STD(C,250), COLORGREEN,DOTLINE;
下轨2:=中轨2- 2*STD(C,250) COLORRED, LINETHICK2;
中轨:=EMA(C,120);
上轨:中轨+ 2*STD(C,120),COLORRED,DOTLINE;
下轨:=中轨- 2*STD(C,120) COLORGREEN, LINETHICK2;
MA6:EXPMEMA(CLOSE,34),COLORFF1CAE;
平线:COST(50),COLORRED,LINETHICK2;
平上轨:COST(50)*1.18,COLORMAGENTA,LINETHICK2;
AMV0:=VOL*(O+C+H+L)/4;
势:=EMA(AMV0,21)/EMA(VOL,21);
压:=6*HHV(势,2)-5*势;
托:2*势-压,COLORMAGENTA;
MA5:EMA(C,5),COLORWHITE;
上沿:MA((HIGH * 1.124),60),DOTLINE,COLOR7FFF00;
下沿:MA((LOW * 0.88),60),LINETHICK2,COLOR808080;
成本:(MA(CLOSE,60)+MA(CLOSE,70)+MA(CLOSE,90)+MA(CLOSE,108))/4,,COLORRED,LINETHICK2;
N1LL:=13;
VAR2A:=CLOSE*VOL;
VAR3A:=EMA((EXPMA(VAR2A,3)/EXPMA(VOL,3)+EXPMA(VAR2A,6)/EXPMA(VOL,6)+EXPMA(VAR2A,12)/EXPMA(VOL,12)+EXPMA(VAR2A,24)/EXPMA(VOL,24))/4,N1LL);
SUP:=1.06*VAR3A,COLORWHITE,DOTLINE;
SDN:VAR3A*0.94,COLORFF2400,DOTLINE;
V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
V2:=(1-7/100)*(DMA(CLOSE,V1));
V3:=(1+7/100)*(DMA(CLOSE,V1));
V5:=MA((LOW+HIGH+CLOSE)/3,5);
支撑:REFDATE(V2,DATE),POINTDOT,LINETHICK4,COLORCC66FF;
阻力:REFDATE(V3,DATE),POINTDOT,LINETHICK4,COLORFF0033;
AJ1:=(COST(85)+COST(15))/2;AJ2:=(COST(75)+COST(25))/2;AJ3:=(COST(65)+COST(35))/2;AJ4:=(COST(55)+COST(45))/2;AJ5:=(COST(95)+COST(5))/2;AJ6:=(COST(99.99)-COST(0.01)*0.5)/2;
AJ:=(AJ1+AJ2+AJ3+AJ4+AJ5+AJ6)/6;
BJ1:=(COST(90)+COST(10))/2;BJ2:=(COST(80)+COST(20))/2;BJ3:=(COST(70)+COST(30))/2;BJ4:=(COST(60)+COST(40))/2;BJ5:=(COST(50));BJ6:=(COST(99.99)+COST(0.01)*0.5)/2;
BJ:=(BJ1+BJ2+BJ3+BJ4+BJ5+BJ6)/6;
成本1:EMA((AJ+BJ)/2,1),COLORWHITE,COLORFFC0FF,LINETHICK2;
B11:=MA(C,1);
B12:=SMA(SMA(SMA(B11,2,1),2,1),2,1);
箱顶2:HHV(MA(B12,2),58),COLOR00AAFF,LINETHICK2;
TJ3:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
{DRAWTEXT(TJ3,LOW*0.986,'↖高量柱'),COLORYELLOW;}
STICKLINE(TJ3,OPEN,CLOSE,1.5,0),COLORYELLOW;
K11:=SUMBARS(TJ3,1);
STICKLINE(K11,REF(C,K11-1),REF(C,K11-1),10,0),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.065,0.01,1,DYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR ,0.065,0.01,0,HYBLOCK),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.20,1,'主营利润率:');
DRAWNUMBER_FIX(ISLASTBAR,0.065,0.20,0,FINANCE(21)/FINANCE(20)*100);
DRAWTEXT_FIX(ISLASTBAR,0.24,0.08,1,'每股净资产:');
DRAWNUMBER_FIX(ISLASTBAR,0.24,0.08,0,FINANCE(34));
DRAWTEXT_FIX(ISLASTBAR,0.24,0.14,1,'每股收益/年:');
DRAWNUMBER_FIX(ISLASTBAR,0.24,0.14,0,FINANCE(33));
DRAWTEXT_FIX(ISLASTBAR,0.24,0.2,1,'每股未分配利润:');
DRAWNUMBER_FIX(ISLASTBAR,0.24,0.2,0,FINANCE(32));
P1:=5;
PH:=TROUGHBARS(2,P1,1);
LL:=HHV(H,PH);
TJ11:= LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ11,2);
TJ2:=PEAKBARS(2,P1,1)=1 AND TS>=PH;
PL:=BARSLAST(TJ2);
___支撑:=IF(BARSLAST(TJ11),
REF(LOW,BARSLAST(TJ11)),DRAWNULL),COLOREA91B5;
___压力:IF(BARSLAST(TJ2),REF(HIGH,PL),DRAWNULL),COLOR7FFF00;
{www.gupang.com 股旁网_通达信股票指标公式}
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA:=(DIF-DEA)*2*60;
起爆:=CROSS(AAA-REF(AAA,1),15),COLORRED,LINETHICK2;
DRAWTEXT(起爆,L*0.99,'↖暴涨'),COLORYELLOW,LINETHICK2;

通达信轨道整合主图指标公式

 

相关文章