在线检测未来函数

大智慧斐波拉及数值与多空线主图指标公式

来源:Internet,编辑:股旁网,2012-04-10

N:=10;M:=1.5;
var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3))
or ref(c,1)=hhv(c,4) and close>=ref(c,2)
or ref(c,2)=hhv(c,4) and ref(c,3)=llv(c,4) and c>=ref(c,1)
or ref(c,3)=hhv(c,4) and c>=ref(c,1) and c>=ref(c,2);
红持:var9Q,color0000ff,LINETHICK0;
varaQ:=c=hhv(c,4) and ref(c,1)=llv(c,4);
粉变:varaQ,colorff99ff,LINETHICK0;
varbQ:=c=llv(c,4) and (ref(c,1)<ref(c,2) or ref(c,1)<ref(c,3))
or ref(c,1)=llv(c,4) and c<ref(c,2)
or ref(c,2)=llv(c,4) and ref(c,1)<>hhv(c,4) and c<ref(c,1)
or ref(c,3)=llv(c,4) and c<ref(c,1) and c<ref(c,2);
灰跌:varbQ,color888888,LINETHICK0;
varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4)
and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);
绿买:varcQ,color00ff00,LINETHICK0;
vardQ:=ref(c,1)=hhv(c,4) and c<ref(c,2)
or (ref(c,2)=hhv(c,4) and ref(c,1)>ref(c,3)
or ref(c,3)=hhv(c,4) and ref(c,1)>ref(c,2))
and ref(c,2)>=ref(c,4) and c<ref(c,1);
蓝抛:vardQ,colorff9900,LINETHICK0;
if DATATYPE>1 then begin;
END;
STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;
STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff7700;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORff9900;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffbb00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffcc00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffdd00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffee00;
STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORffFF00;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000bb;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000dd;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;
stickline(var9Q,c,(o+c)/2,7,0),color000077;
stickline(var9Q,c,(o+c)/2,6,0),color000088;
stickline(var9Q,c,(o+c)/2,5,0),color0000aa;
stickline(var9Q,c,(o+c)/2,4,0),color0000cc;
stickline(var9Q,c,(o+c)/2,2,0),color0000ff;
stickline(var9Q,c,(o+c)/2,0,0),COLORffffff;
stickline(varaQ,c,(o+c)/2,7,0),colorff11ff;
stickline(varaQ,c,(o+c)/2,6,0),colorff33ff;
stickline(varaQ,c,(o+c)/2,5,0),colorff55ff;
stickline(varaQ,c,(o+c)/2,4,0),colorff77ff;
stickline(varaQ,c,(o+c)/2,3,0),colorff99ff;
stickline(varaQ,c,(o+c)/2,2,0),colorffbbff;
stickline(varaQ,c,(o+c)/2,1,0),colorffddff;
stickline(varbQ,c,(o+c)/2,7,0),color333333;
stickline(varbQ,c,(o+c)/2,6,0),color555555;
stickline(varbQ,c,(o+c)/2,5,0),color777777;
stickline(varbQ,c,(o+c)/2,4,0),color999999;
stickline(varbQ,c,(o+c)/2,3,0),colorbbbbbb;
stickline(varbQ,c,(o+c)/2,2,0),colordddddd;
stickline(varbQ,c,(o+c)/2,1,0),colorffffff;
stickline(varcQ,o,(o+c)/2,7,0),color003300;
stickline(varcQ,o,(o+c)/2,6,0),color005500;
stickline(varcQ,o,(o+c)/2,5,0),color007700;
stickline(varcQ,o,(o+c)/2,4,0),color009900;
stickline(varcQ,o,(o+c)/2,3,0),color00bb00;
stickline(varcQ,o,(o+c)/2,2,0),color00dd00;
stickline(varcQ,o,(o+c)/2,1,0),color00ff00;
stickline(vardQ,o,(o+c)/2,7,0),colorff1100;
stickline(vardQ,o,(o+c)/2,6,0),colorff3300;
stickline(vardQ,o,(o+c)/2,5,0),colorff5500;
stickline(vardQ,o,(o+c)/2,4,0),colorff7700;
stickline(vardQ,o,(o+c)/2,3,0),colorff9900;
stickline(vardQ,o,(o+c)/2,2,0),colorffbb00;
stickline(vardQ,o,(o+c)/2,1,0),colorffdd00;
ZL:=EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3);
F11:=ZIG(3,15);
FXx:=IF((F11> REF(F11,1)),5,105);
转向:=CROSS(ZL,FXx);
高点:=CROSS(fxx,ZL);
VARZT:=BARSLAST(转向);
STICKLINE(VARZT=2,L*0.97,L*0.98,8,0),COLOR0000FF;
DRAWTEXT(VARZT=2,L*0.95,'3'),COLORYELLOW;
STICKLINE(VARZT=4,H*1.03,H*1.02,8,0),COLOR9966FF;
DRAWTEXT(VARZT=4,H*1.06,'5'),COLORYELLOW;
STICKLINE(VARZT=7,L*0.97,L*0.98,8,0),COLOR00FFFF;
DRAWTEXT(VARZT=7,L*0.95,'8'),COLORYELLOW;
STICKLINE(VARZT=12,H*1.03,H*1.02,8,0),COLORFF33FF;
DRAWTEXT(VARZT=12,H*1.06,'13'),COLORYELLOW;
STICKLINE(VARZT=20,L*0.97,L*0.98,8,0),COLOR0066FF;
DRAWTEXT(VARZT=20,L*0.95,'21'),COLORYELLOW;
STICKLINE(VARZT=33,H*1.03,H*1.02,8,0),COLOR9932CD;
DRAWTEXT(VARZT=33,H*1.06,'34'),COLORYELLOW;
STICKLINE(VARZT=54,L*0.97,L*0.98,8,0),COLOR006600;
DRAWTEXT(VARZT=54,L*0.95,'55'),COLORYELLOW;
STICKLINE(VARZT=88,H*1.03,H*1.02,8,0),COLOR00FF00;
DRAWTEXT(VARZT=88,H*1.06,'89'),COLORYELLOW;
STICKLINE(VARZT=143,L*0.97,L*0.98,8,0),COLORCCFFFF;
DRAWTEXT(VARZT=143,L*0.95,'144'),COLORYELLOW;
STICKLINE(VARZT=232 ,H*1.03,H*1.02,8,0),COLORFF0033;
DRAWTEXT(VARZT=232,H*1.06,'233'),COLORYELLOW;
DRAWTEXT(VARZT=377,H*1.06,'377'),COLORYELLOW;
STICKLINE(VARZT=377,L*0.97,L*0.98,8,0),COLORFF9966;
DRAWTEXT(VARZT=610,H*1.06,'610'),COLORYELLOW;
STICKLINE(VARZT=610,L*0.97,L*0.98,8,0),Color6B4226;
{www.gupang.com 股旁网_大智慧股票指标公式}
TR1:=MAX(MAX((HIGH-LOW),ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
ATR:=MA(TR1,10);
median:= (high + low) / 2;
x:=20;
MID :=MA(c,x);
hh:=median + atr * M;
ll:=median - atr * M;
w:=barslast((hh>=hhv(hh,n)))-barslast((llv(ll,n)>=ll));
BBX:=llv(hh,barslast(w<0));
SSX:=hhv(ll,barslast(w>0));
ww:=IF(w>0,bbX,IF(w<0,ssX,c));
PARTLINE(ww,w<0,RGB(255,0,255),w>0,RGB(0,0,255),0),linethick1;

大智慧斐波拉及数值与多空线主图指标公式

 

相关文章