在线检测未来函数

通达信精确找牛指标公式

来源:Internet,编辑:股旁网,2012-04-13

N:=7;M:=8;N8:=22;P1:=2.8;P2:=3.2;P3:=3.5;
VAR01:=EMA(EMA(CLOSE,9),9);
控盘:=(VAR01-REF(VAR01,1))/REF(VAR01,1)*10000;
STICKLINE(控盘<0,控盘,0,2,0),COLORWHITE;
AA1:=CROSS(控盘,0);
轻度控盘:STICKLINE(控盘<0 AND 0.9*控盘>REF(控盘,1),控盘,0,2,0),COLOR0099FF;
轻度出货:STICKLINE(控盘<0 AND 1.1*控盘<REF(控盘,1),控盘,0,3,0),COLORFF6633;无庄控盘:=IF(控盘<0,控盘,0),COLORGREEN,LINETHICK2;
开始控盘:=IF(AA1,5,0),LINETHICK1,COLORYELLOW;
{STICKLINE(控盘>REF(控盘,1) AND 控盘>0,控盘,0,2,0),COLORRED;}
有庄控盘:=IF(控盘>REF(控盘,1) AND 控盘>0,控盘,0),COLORYELLOW,LINETHICK2;
V1:=AMOUNT/VOL/100;
V2:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
V3:=SUM(AMOUNT,7)/V1/100;
V4:=DMA(V2,VOL/V3);
V5:=(CLOSE-V4)/V4*100;
V6:=MA(V5,20)+STD(V5,20);
BIAS21:=(CLOSE-MA(CLOSE,21))/MA(CLOSE,21)*100;
STICKLINE(REF(BIAS21,1)>=5 AND CROSS(V6,V5) AND REF("KDJ.J"(34,3,3),1)>80 AND REF("KDJ.J"(9,3,3),1)>80,100,5,1,0),COLORWHITE;
DDIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DDEA:=EMA(DDIFF,9);
MACD:=500*(DDIFF-DDEA);
STICKLINE(MACD<0,MACD,0,3,0),COLORBLUE;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR006600;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4 ,0 ),COLOR0000AA;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3.3 ,0 ),COLOR0011BB;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2.2,0 ),COLOR0022CC;
0,COLORWHITE;
VAR1:=((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*1000+(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*1000+(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*1000)/3;
持币区域:VAR1,COLORGREEN,LINETHICK3;
持股区域:IF(VAR1>0,VAR1,0),COLORFF00FF,LINETHICK3;
短顶:VAR1>9 AND FILTER(VAR1<REF(VAR1,1),5),COLORGREEN;
大顶:VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),COLOR00FF00;
VAR2:=HHV(VAR1>20,10);
危险: VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+20*STD(CLOSE,20));
注意止损:VAR2 AND FILTER(VAR1< REF(VAR1,1),6)
AND CROSS(MA(CLOSE,5),MA(CLOSE,2));
短底:=VAR1<-9 AND VAR1> REF(VAR1,1),COLORRED;
大底:VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),COLORYELLOW;
买入准备:=VAR1<-9 AND VAR1>REF(VAR1,1),COLORWHITE;
DRAWTEXT(VAR1>9 AND FILTER(VAR1<REF(VAR1,1),5),VAR1+20,'高'),COLORWHITE;
DRAWTEXT(VAR1>20 AND FILTER(VAR1<REF(VAR1,1),5),VAR1+30,'顶'),COLORFFFF00;
DRAWTEXT(VAR2 AND CROSS((REF(HIGH,1)+REF(LOW,1))/2,MA(CLOSE,20)+2*STD(CLOSE,20)),VAR1+45,'危险'),COLOR00FFFF;
DRAWTEXT(VAR2 AND FILTER(VAR1< REF(VAR1,1),6) AND CROSS(MA(CLOSE,5),MA(CLOSE,2)),VAR1+40,'注意止损'),COLORFF00FF;
DRAWTEXT(VAR1<-20 AND FILTER(VAR1> REF(VAR1,1),5),VAR1-5,''); 主力追踪:=3*SMA((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*100,5,1)-2*SMA(SMA((C-LLV(L,13))/(HHV(H,13)-LLV(L,13))*100,5,1),3,1)COLORCYAN,LINETHICK2;
主力拉高出逃:IF(主力追踪>=90,70,100),COLORWHITE;
VAR100:4*SMA((CLOSE-LLV(LOW,N8))/(HHV(HIGH,N8)-LLV(LOW,N8))*100,5,1)-
3*SMA(SMA((CLOSE-LLV(LOW,N8))/(HHV(HIGH,N8)-LLV(LOW,N8))*100,5,1),3.2,1),COLORWHITE,LINETHICK2;
VARO5:=LLV(LOW,27);
VARO6:=HHV(HIGH,34);
VARO7:=EMA((CLOSE-VARO5)/(VARO6-VARO5)*4,4)*25;
IF(VAR100>REF(VAR100,1),VAR100,DRAWNULL),COLORRED,LINETHICK4;
IF(VAR100<REF(VAR100,1),VAR100,DRAWNULL),COLORGREEN,LINETHICK2;VAR010:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*80;
B:=SMA(VAR010,N,1);
VAR020:=SMA(B,M,1);
VAR1F:=((CLOSE-LLV(LOW,20))/(HHV(HIGH,20)-LLV(LOW,20)))*(100);
VAR21:=SMA(VAR1F,3,1);
CCD:=SMA(VAR21,3,1),COLOR0000FF,LINETHICK2;
CCC:=SMA(CCD,3,1),COLORYELLOW,LINETHICK2;
FALCON:=IF(CROSS(CCD,CCC) AND (CCD<30),20,0),COLOR0000FF,LINETHICK2;
黑马:IF(CROSS(B,VAR020) AND B<65 AND CLOSE>OPEN AND FALCON AND (C/REF(C,1))>0.5,50,0)STICK,LINETHICK3,COLORYELLOW;{www.gupang.com 股旁网_通达信股票指标公式}
VAR001:=1; VAR002:=LLV(LOW,10); VAR003:=HHV(HIGH,25);
警戒线:= P1*VAR001;
减仓线:= P2*VAR001;
卖出线:= P3*VAR001;
动力线:= EMA((CLOSE-VAR002)/(VAR003-VAR002)*4,4)*VAR001;
DRAWTEXT(CROSS(动力线,警戒线),120,'警惕'),COLORWHITE;
DRAWTEXT(CROSS(动力线,卖出线),180,'出局'); DRAWTEXT(CROSS(动力线,减仓线),150,'◤逢高减磅')COLORGREEN;
MACD1:=2*(DDIFF-DDEA)*300,COLORRED,LINETHICK1; MACD2:=MA(MACD1,3);
MACDL:=HHV(MACD2,13);
STICKLINE(MACDL<MACD1,MACD1,MACD2,3,0),COLORYELLOW;
LCAA:=REF(CLOSE,1);
RSIA:=((SMA(MAX((CLOSE - LCAA),0),3,1) / SMA(ABS((CLOSE - LCAA)),3,1)) * 100);
LC6:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC6,0),6,1)/SMA(ABS(CLOSE-LC6),6,1)*100;
DRAWTEXT(CROSS(84,RSI) , HIGH*6,'◤逃顶')COLORGREEN; DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIFF,8);
A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));
B12:=REF(C,A1+1)>C AND REF(DIFF,A1+1)<DIFF AND CROSS(DIFF,DEA);
DRAWTEXT((H-C)/REF(C,1)>0.03 AND H=HHV(H,21),H*5,'◤快跑')COLORCYAN;个股:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3),COLOR1010FF;短线反弹:IF(CROSS(个股,9),50,0),STICK,LINETHICK3,COLORRED;
DRAWTEXT(CROSS(个股,9),50,'反弹'),COLORYELLOW;

通达信精确找牛指标公式

 

相关文章