在线检测未来函数

通达信混沌操作法主图指标公式

来源:Internet,编辑:股旁网,2012-04-16

VAR1:=(H+L)/2;
AO:=SMA(VAR1,5,1)-SMA(VAR1,34,1),COLOR6699CC;
AC:=SMA((AO-SMA(AO,5,1)),5,1),COLOR6699CC;
X1:=AO>REF(AO,1) AND AC>REF(AC,1);
X2:=AO<REF(AO,1) AND AC<REF(AC,1);
Y:=(H+L)/2;
RED:=SMA(Y,8,1);
R2:=REF(RED,5);
KU1:=IF(H=HHV(H,3),1,0);
KD1:=IF(L=LLV(L,3),1,0);
UL:=IF(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0,REF(H,2),REF(H,2+BARSLAST(REF(KU1,2)=1 AND REF(KU1,1)=0 AND KU1=0)));
DL:=IF(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0,REF(L,2),REF(L,2+BARSLAST(REF(KD1,2)=1 AND REF(KD1,1)=0 AND KD1=0)));
蓝:SMA(Y,13,1),COLORBLUE;
红:SMA(Y,5,1),COLORRED;
绿:SMA(Y,3,1),COLORGREEN;
上张:=蓝>=REF(蓝,1) AND 红>=REF(红,1) AND 绿>=REF(绿,1);
下张:=蓝<REF(蓝,1) AND 红<REF(红,1) AND 绿<REF(绿,1);
上碎:=IF(H>=R2,UL,REF(UL,BARSLAST(H>R2)));
下碎:=IF(L<=R2,DL,REF(DL,BARSLAST(L<=R2)));
STICKLINE(BARSLAST(ABS(上碎-REF(上碎,1)))<BARSLAST(C>上碎 AND REF(C,1)<REF(上碎,1)),上碎,上碎,3,1),COLORMAGENTA;
STICKLINE(BARSLAST(ABS(下碎-REF(下碎,1)))<BARSLAST(C<下碎 AND REF(C,1)>REF(下碎,1)),下碎,下碎,3,1),COLORCYAN;
LC := REF(C,4);
RMI:=SMA(MAX(C-LC,0),7,1)/SMA(ABS(C-LC),7,1)*100;
QS:= HHV(MA(RMI,3),13),COLOR00ADFF;
RMIMA:= SMA(RMI,3,1),COLOR009C00;
DRAWTEXT(C>上碎&&ISLASTBAR=1,H+0,'向上突破有效上碎型'),COLOR0000FF;
DRAWTEXT(C<下碎&&ISLASTBAR=1,L-0,'向下有效碎型被突破'),COLORFFFF00;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(X1>0&&ISLASTBAR=1,H+0.3,'AO与AC为多方趋势'),COLORFF00FF;
DRAWTEXT(X2>0&&ISLASTBAR=1,L-0.3,'AO与AC为空方趋势'),COLOR00FF00;
DRAWTEXT(上张&&ISLASTBAR=1,H+0.6,'鳄鱼向上张嘴'),COLOR999999;
DRAWTEXT(下张&&ISLASTBAR=1,L-0.6,'鳄鱼向下张嘴'),COLOR999999;
DRAWTEXT(上张&&X1>0&&ISLASTBAR=1,H+0.8,'怀疑中期多头'),COLORFF00FF;
DRAWTEXT(下张&&X2>0&&ISLASTBAR=1,L-0.8,'怀疑中期空头'),COLOR00FF00;
DRAWTEXT((RMI>RMIMA&&RMI<QS)&&ISLASTBAR=1,H+1,'小心做多'),COLOR00FFFF;
DRAWTEXT((RMI>RMIMA&&RMI>QS)&&ISLASTBAR=1,H+1,'坚决做多'),COLOR0000FF;
DRAWTEXT((RMI<RMIMA&&RMI>20)&&ISLASTBAR=1,L-1,'坚决做空'),COLORFF0000;
DRAWTEXT((RMI<RMIMA&&RMI<20)&&ISLASTBAR=1,L-1,'小心做空'),COLORFF00FF;

通达信混沌操作法主图指标公式

 

相关文章