在线检测未来函数

通达信黑马决策指标公式

来源:Internet,编辑:股旁网,2012-04-19

A1:=1;
A2:=(5);
A3:=(((2*CLOSE)+HIGH)+LOW)/4;
A4:=LLV(LOW,34);
A5:=HHV(HIGH,34);
A6:=EMA((((A3-A4)/(A5-A4))*100),13);
A7:=(EMA(((0.667*(REF(A6,1)))+(0.333*A6)),2))*A1;
决策线:(EMA(A7,A2))*A1,COLORRED;
A8:=(HHV(HIGH,9))-(LLV(LOW,9));
A9:=(HHV(HIGH,9))-CLOSE;
A10:=CLOSE-(LLV(LOW,9));
A11:=((A9/A8)*100)-70;
A12:=((CLOSE-(LLV(LOW,60)))/((HHV(HIGH,60))-(LLV(LOW,60))))*100;
A13:=SMA(((A10/A8)*100),3,1);
A14:=(SMA(A13,3,1))-(SMA(A11,9,1));
A15:=IF((A14>100),(A14-100),0);
A16:=(EMA((((A3-A4)/(A5-A4))*100),8))*A1;
A17:=(EMA(A16,5))*A1;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(((A16-A17)>0),A16,A17,3,1),COLORFFAA18;
STICKLINE(((A16-A17)<0),A16,A17,3,0),COLORGREEN;
A18:=(EMA(CLOSE,2))*A1;
A19:=(EMA((((SLOPE(CLOSE,21))*20)+CLOSE),42))*A1;
A20:=(HHV((MA(HIGH,13)),13))*A1;
A21:=(LLV((MA(HIGH,13)),1))*A1;
A22:=(EMA(CLOSE,4))*A1;
A23:=((((A18>=A19) AND (A21=A20)) AND (A18>A22)) AND (CLOSE>A21)) AND ((REF(A21,1))<(REF(A20,1)));
A24:=BARSLAST(A23)+1;
A25:=(LLV(LOW,A24))*1.3;
A26:=(LLV(LOW,20))*1.418;
A27:=(((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.07)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26);
A28:A27 AND (FILTER(A27,A24));
{A29:=(STRFIND(STKNAME,'ST',1)) > 0;}
A30:=((((((A18>=A19) AND (A21=A20)) AND ((CLOSE/(REF(CLOSE,1)))>=1.035)) AND (A24<=30)) AND (CLOSE<=A25)) AND (CLOSE<=A26)) ;
A31:A30 AND (FILTER(A30,20));
DRAWICON((A28 OR A31),决策线,1);
DRAWTEXT((A28 OR A31),决策线,'←黑马'),COLORRED;

通达信黑马决策指标公式

 

相关文章