在线检测未来函数

大智慧利多方舟主图指标公式

来源:Internet,编辑:股旁网,2012-04-17

if DISPSTATUS=2 then aaa:=BARPOS;
if DISPSTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
if DISPSTATUS=2 then aaa:=BARPOS;
if DISPSTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
hh:=hhv(h,ddd);;
ll:=llv(l,ddd);
e:=(hh-ll)/100;
DRAWTEXT(BARSTATUS=2,hh-3*e,STKLABEL+' '+STKNAME+' '),Colorred,align2;
换手率:=100*v/capital;
RH:=H-L;
R:=DYNAINFO(13)*100;
DRAWTEXT (BARSTATUS=2,hh-3*e,'当日振幅:'+NUMTOSTRN(R,2)+'% '+NUMTOSTRN(RH,2)+'元 '+' 当前换手率:'+NUMTOSTRN(换手率,2)+'% '+' '),Colorblue,align2;
DRAWTEXT(BARSTATUS=2,hh-11*e,' 机构评级:'+selfstring('评级')+ ' '),colorred,align2;
年:MA(CLOSE,26),colorred,linethick2;
反压线:HHV(FORCAST(C,10),18),coloree8fff,linethick1;
M5:MA(C,5),ColorFFFfff,linethick1;
M10:MA(C,10),Color00Ffff,linethick1;
M60:MA(C,60),Color208fff,linethick1;
M90:MA(C,90),Color00ff00,linethick0;
M125:MA(C,125),Color00Ffff,linethick0;
M250:MA(C,250),Color00ff00,linethick0;
指导线: EMA((EMA(C,4)+EMA(C,6)+EMA(C,12)+EMA(C,24))/4,2),linethick0,ColorFFffFF;界: MA(CLOSE,21),linethick0,Color00FFFF;
上限: 界+3*STD(C,20),linethick0,Color00FFFF;
卖: 界+2*STD(C,20),linethick0,ColorFF00FF;
买: 界-2*STD(C,20),linethick0,ColorF0FF00;
下限: 界-2.9*STD(close,20),linethick0,Color00FF00;
DRAWTEXT(((c>界 and 指导线>界 and cross(界,l))),l,'▲'),Color0000ff,ALIGN1,VALIGN0;
DRAWTEXT(((c>界 and 指导线>界 and cross(界,l))),l*0.997,'↑'),Color0000ff,ALIGN1,VALIGN0;
DRAWTEXT(((c>界 and 指导线>界 and cross(指导线,界))),l,'买点'),ALIGN1,VALIGN0,Color00578C;
{www.gupang.com 股旁网_大智慧股票指标公式}
DRAWTEXT(((c>界 and 指导线>界 and cross(指导线,界))),l,'?'),ALIGN1,VALIGN0,Colorffffff;
DRAWICON(cross(H,上限),h,10),ALIGN1,VALIGN2;
DRAWICON(cross(上限,H),h,9),ALIGN1,VALIGN2;
DRAWTEXT(h>上限 and cross(h,上限),h,'●'),ALIGN1,VALIGN2,Color0000ff;
DRAWTEXT(cross(H,上限),H,'_'),linethick2,ALIGN1,VALIGN2,Color00ffff;
DRAWTEXT(h>卖 and cross(上限,H),h,'▼'),ALIGN1,VALIGN2,Color00ff00;
DRAWTEXT(cross(上限,H),H,'_'),linethick2,ALIGN1,VALIGN2,Colorff00ff;
DRAWTEXT(cross(下限,L),l,'限'),ALIGN1,VALIGN0,Color00ff00;
DRAWTEXT(cross(下限,L),l,' ̄'),ALIGN1,VALIGN0,Color00ff00;
DRAWTEXT(cross(买,L),l,'△'),ALIGN1,VALIGN0,ColorFFFFFF;
DRAWTEXT(cross(买,L),l,' ̄'),ALIGN1,VALIGN0,ColorFFFFFF;
DRAWTEXT(cross(买,C),L,'▲'),ALIGN1,VALIGN0,Colorffff00;
DRAWTEXT(cross(买,C),L,' ̄'),ALIGN1,VALIGN0,Colorffff00;
STICKLINE(C>=年 AND C>=O,C,O,7,0),COLORRED;
STICKLINE(C>=年 AND C>=O,H,L,0,0),COLORRED;
STICKLINE(C>=年 AND C<O,C,O,7,1),COLORRED;
STICKLINE(C>=年 AND C<O,O,H,0,0),COLORRED;
STICKLINE(C>=年 AND C<O,C,L,0,0),COLORRED;
STICKLINE(C<年 AND C>O,C,O,7,1),COLORffff00;
STICKLINE(C<年 AND C<=O,C,O,7,1),COLORffff00;
STICKLINE(C<年 AND C<=O,H,L,0,1),COLORffff00;
STICKLINE(C<年 AND C>O,C,H,0,1),COLORffff00;
STICKLINE(C<年 AND C>O,O,L,0,1),COLORffff00;
gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);
明日阻力:=l+(gj-l)+(c-l);
明日支撑:=l+(c-gj);
今日阻力:=REF(明日阻力 , 1);
今日支撑:=REF(明日支撑 , 1);
STICKLINE(BARSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,30,0),Color0000FF;
STICKLINE(BARSTATUS=2 and c<今日阻力,今日阻力,今日阻力,30,0),Color00FF00;
STICKLINE(BARSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,30,0),ColorFF00FF;
STICKLINE(BARSTATUS=2 and c<今日支撑,今日支撑,今日支撑,30,0),ColorFF8800;
DRAWTEXT(BARSTATUS=2 ,hh,'---------------------------------- '),ColorFFFFFF,align2;
DRAWTEXT(BARSTATUS=2 and c>=今日支撑,hh-3*e,' 今日支撑=:'+NUMTOSTRN(今日支撑 ,2 )+' '),ColorFF00FF,align2;
DRAWTEXT(BARSTATUS=2 and c<今日支撑,hh-3*e,' 今日支撑=:'+NUMTOSTRN(今日支撑 ,2 )+' '),ColorFF8800,align2;
DRAWTEXT(BARSTATUS=2 and c>=今日阻力,hh-7*e,' 今日阻力=:'+NUMTOSTRN(今日阻力 ,2 )+' '),Color0000FF,align2;
DRAWTEXT(BARSTATUS=2 and c<今日阻力,hh-7*e,' 今日阻力=:'+NUMTOSTRN(今日阻力 ,2 )+' '),Color00FF00,align2;
DRAWTEXT(BARSTATUS=2 ,hh-3*e,' 明日阻力=:'+NUMTOSTRN(明日阻力 ,2 )+' '),Colorblue,align2;
DRAWTEXT(BARSTATUS=2 ,hh-7*e,' 明日支撑=:'+NUMTOSTRN(明日支撑 ,2 )+' '),Colorblue,align2;
DRAWTEXT(BARSTATUS=2 ,hh-10*e,'---------------------------------- '),ColorFFFFFF,align2;
DRAWTEXT(BARSTATUS=2 and v>ref(v,1) and ma(v,5)>ref(ma(v,5),1),hh-13*e,'今日成交量大于昨日,且有继续增大趋势'+' '),Color8285FF,align2;
DRAWTEXT(BARSTATUS=2 and v<ref(v,1) and ma(v,5)>ref(ma(v,5),1),hh-13*e,'今日成交量小于昨日,但有放大迹象'+' '),Color8285FF,align2;
DRAWTEXT(BARSTATUS=2 and v>ref(v,1)and ma(v,5)<ref(ma(v,5),1),hh-13*e,'今日成交量大于昨日, 但有缩小迹象'+' '),Color8285FF,align2;
DRAWTEXT(BARSTATUS=2 and v<ref(v,1)and ma(v,5)<ref(ma(v,5),1),hh-13*e,'今日成交量小于昨日,且有缩小迹象'+' '),Color8285FF,align2;
if DISPSTATUS=2 then begin;
var100:='所属板块:';
if inblock('电力')=1 then var100:=var100+' 电力';
if inblock('电脑')=1 then var100:=var100+' 电脑';
if inblock('电器')=1 then var100:=var100+' 电器';
if inblock('电子信息')=1 then var100:=var100+' 电子信息';
if inblock('房地产')=1 then var100:=var100+' 房地产';
if inblock('纺织服装')=1 then var100:=var100+' 纺织服装';
if inblock('钢铁')=1 then var100:=var100+' 钢铁';
if inblock('工程建筑')=1 then var100:=var100+' 工程建筑';
if inblock('供水供气')=1 then var100:=var100+' 供水供气';
if inblock('化工')=1 then var100:=var100+' 化工';
if inblock('化纤')=1 then var100:=var100+' 化纤';
if inblock('机械')=1 then var100:=var100+' 机械';
if inblock('建材')=1 then var100:=var100+' 建材';
if inblock('交通工具')=1 then var100:=var100+' 交通工具';
if inblock('交通设施')=1 then var100:=var100+' 交通设施';
if inblock('教育传媒')=1 then var100:=var100+' 教育传媒';
if inblock('金融')=1 then var100:=var100+' 金融';
if inblock('旅游酒店')=1 then var100:=var100+' 旅游酒店';
if inblock('煤炭石油')=1 then var100:=var100+' 煤炭石油';
if inblock('酿酒食品')=1 then var100:=var100+' 酿酒食品';
if inblock('农林牧渔')=1 then var100:=var100+' 农林牧渔';
if inblock('其他行业')=1 then var100:=var100+' 其他行业';
if inblock('汽车')=1 then var100:=var100+' 汽车';
if inblock('汽配')=1 then var100:=var100+' 汽配';
if inblock('商业连锁')=1 then var100:=var100+' 商业连锁';
if inblock('石化')=1 then var100:=var100+' 石化';
if inblock('通信')=1 then var100:=var100+' 通信';
if inblock('外贸')=1 then var100:=var100+' 外贸';
if inblock('医药')=1 then var100:=var100+' 医药';
if inblock('仪电仪表')=1 then var100:=var100+' 仪电仪表';
if inblock('有色金属')=1 then var100:=var100+' 有色金属';
if inblock('运输物流')=1 then var100:=var100+' 运输物流';
if inblock('造纸印刷')=1 then var100:=var100+' 造纸印刷';
if inblock('安徽')=1 then var100:=var100+' 安徽';
if inblock('北京')=1 then var100:=var100+' 北京';
if inblock('福建')=1 then var100:=var100+' 福建';
if inblock('甘肃')=1 then var100:=var100+' 甘肃';
if inblock('广东')=1 then var100:=var100+' 广东';
if inblock('广西')=1 then var100:=var100+' 广西';
if inblock('贵州')=1 then var100:=var100+' 贵州';
if inblock('海南')=1 then var100:=var100+' 海南';
if inblock('河北')=1 then var100:=var100+' 河北';
if inblock('河南')=1 then var100:=var100+' 河南';
if inblock('黑龙江')=1 then var100:=var100+' 黑龙江';
if inblock('湖北')=1 then var100:=var100+' 湖北';
if inblock('湖南')=1 then var100:=var100+' 湖南';
if inblock('吉林')=1 then var100:=var100+' 吉林';
if inblock('江苏')=1 then var100:=var100+' 江苏';
if inblock('江西')=1 then var100:=var100+' 江西';
if inblock('辽宁')=1 then var100:=var100+' 辽宁';
if inblock('内蒙古')=1 then var100:=var100+' 内蒙古';
if inblock('宁夏')=1 then var100:=var100+' 宁夏';
if inblock('青海')=1 then var100:=var100+' 青海';
if inblock('山东')=1 then var100:=var100+' 山东';
if inblock('山西')=1 then var100:=var100+' 山西';
if inblock('陕西')=1 then var100:=var100+' 陕西';
if inblock('上海')=1 then var100:=var100+' 上海';
if inblock('深圳')=1 then var100:=var100+' 深圳';
if inblock('四川')=1 then var100:=var100+' 四川';
if inblock('天津')=1 then var100:=var100+' 天津';
if inblock('***')=1 then var100:=var100+' ***';
if inblock('新疆')=1 then var100:=var100+' 新疆';
if inblock('云南')=1 then var100:=var100+' 云南';
if inblock('浙江')=1 then var100:=var100+' 浙江';
if inblock('重庆')=1 then var100:=var100+' 重庆';
if inblock('3G')=1 then var100:=var100+' 3G';
if inblock('H股')=1 then var100:=var100+' H股';
if inblock('QFII持股')=1 then var100:=var100+' QFII持股';
if inblock('ST')=1 then var100:=var100+' ST';
if inblock('奥运')=1 then var100:=var100+' 奥运';
if inblock('创投')=1 then var100:=var100+' 创投';
if inblock('次新股')=1 then var100:=var100+' 次新股';
if inblock('大盘')=1 then var100:=var100+' 大盘';
if inblock('股权改革')=1 then var100:=var100+' 股权改革';
if inblock('股权投资')=1 then var100:=var100+' 股权投资';
end;
DRAWTEXT(BARSTATUS=2,hh-15*e,var100+' '),COLORblue,align2;
DD:=( 1);
SS:=( 7);
FF:=(18);
GG:=(33);
zz:=(53);
JJ:=(40);
MM:=JJ/SS;
TH:=DYNAINFO(39);
DRAWTEXT (BARSTATUS=2,hh-7*e,'总股本:'+NUMTOSTRN(DD,0)+'万股' +' 流通A股:'+NUMTOSTRN(SS,0)+'万股'+' 市盈率:'+NUMTOSTRN(HH,2)+'%'+' 每股收益:'+NUMTOSTRN(GG,3)+ ' '),COLORblue,align2;
DRAWTEXT(BARSTATUS=2,hh-19*e,' 2006基金一季持股:'+SELFDATA('2006基金一季持股')+' 2006基金二季持股:'+SELFDATA('基金2006二季持股明细')+' 2006中期户均持股数:'+SELFDATA('2006中期户均持股数')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-24*e,' 2006基金一季持股增减量:'+SELFDATA('2006基金一季持股增减量')+' 基金2006二季持股比率明细:'+SELFDATA('基金2006二季持股比率明细')+' 2006中期户均持股变动率:'+SELFDATA('2006中期户均持股变动率')+' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-29*e,' 2006基金一季持股比例:'+SELFDATA('2006基金一季持股比例')+' QFII2006二季度持股量:'+SELFDATA('QFII2006二季度持股量')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-34*e,' 盘口主力日增减:'+SELFDATA('盘口主力日增减量')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-39*e,' 龙虎榜主力三日增减:'+SELFDATA('龙虎榜主力三日增减')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-44*e,' 龙虎榜主力五日增减:'+SELFDATA('龙虎榜主力五日增减')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-49*e,' 龙虎榜主力十日增减:'+SELFDATA('龙虎榜主力十日增减')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-54*e,' 龙虎榜主力二十日增减:'+SELFDATA('龙虎榜主力二十日增减')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-59*e,' RSP(125天):'+SELFDATA('RSP(125天)')+' 主力持仓成本(60天):'+SELFDATA('主力持仓成本(60天)')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-64*e,' 2006一季户均持股:'+SELFDATA('2006一季户均持股')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-69*e,' 2006一季户均持股增幅:'+SELFDATA('2006一季户均持股增幅')+' 主力上上周增仓率精算:'+SELFDATA('主力上上周增仓率精算')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-74*e,' 主力均额五天增幅:'+SELFDATA('主力均额五天增幅')+' 主力总增仓占流通率精算:'+SELFDATA('主力总增仓占流通率精算')+' 主力上周增仓率精算:'+SELFDATA('主力上周增仓率精算')+' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-79*e,' 主力均额十天增幅:'+SELFDATA('主力均额十天增幅')+' 主力上上周增仓率:'+SELFDATA('主力上上周增仓率')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-84*e,' 主力均额二十天增幅:'+SELFDATA('主力均额二十天增幅')+' 05主力持股率:'+SELFDATA('05主力持股率')+' 主力总增仓占流通率:'+SELFDATA('主力总增仓占流通率')+' 主力上周增仓率:'+SELFDATA('主力上周增仓率')+' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-89*e,' 2006三季户均持股变动率:'+SELFDATA('2006三季户均持股变动率')+' 2006三季基金持股率:'+SELFDATA('2006三季基金持股率')+ ' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-94*e,' 2006基金三季持股:'+SELFDATA('2006基金三季持股数')+' 2006三季户均持股:'+SELFDATA('2006三季户均持股')+' 未来12个月股票收益率:'+ SELFDATA('未来12个月股票收益率')+' '),colorred,align2;
DRAWTEXT(BARSTATUS=2,hh-99*e,' 主力第四周成交比率:'+SELFDATA('主力第四周成交比率')+' 主力第四周成交增幅:'+SELFDATA('主力第四周成交增幅')+' 价值评估体系排序定位:'+SELFDATA('价值评估体系排序定位')+' '),colorred,align2;

大智慧利多方舟主图指标公式

 

相关文章