在线检测未来函数

通达信动态黄金分割+成交量+压力支撑位主图指标公式

来源:Internet,编辑:股旁网,2012-04-17

N:=5;
E:=(HIGH+LOW+OPEN+2*CLOSE)/5;
AAA:=2*E-LOW,NODRAW;
AB:=2*E-HIGH,NODRAW;
ACC:=E+(HIGH-LOW),NODRAW;
ADD:=E-(HIGH-LOW),NODRAW;
今阻力:REF(AAA,1),COLORWHITE,NODRAW;
支撑:REF(AB,1),COLORYELLOW,NODRAW;
明阻力:AAA,COLORCYAN,NODRAW;
明支撑:AB,COLORMAGENTA,NODRAW;
明突破:ACC,COLORGREEN,NODRAW;
明反转:ADD,COLORLICYAN,NODRAW;
{动态黄金分割}
{N 1 1000 120}
指导线:MA(CLOSE,5);
VAR1:=LLV(LOW,N);
VAR2:=HHV(HIGH,N);
VAR3:=VAR2-VAR1;
H191: VAR3*0.191+VAR1,DOTLINE;
H382: VAR3*0.382+VAR1,DOTLINE;
H050: VAR3*0.5+VAR1,DOTLINE;
H618: VAR3*0.618+VAR1,DOTLINE;
H809: VAR3*0.809+VAR1,DOTLINE;
低点: VAR1,DOTLINE;
高点: VAR2,DOTLINE;
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;
DRAWTEXT(FF1,(LOW* 0.96),'短进'),COLOR00FFFF;
{成交量}
MAXV:=CONST(HHV(VOL,21));
MAXS:=CONST(HHV(HIGH,21));
BS:=MAXV/MAXS;
VOLUME:=VOL/BS*0.10;
{www.gupang.com 股旁网_通达信股票指标公式}
ORIGIN:=CONST(LLV(LOW,0))-CONST(0.5*HHV(VOLUME,0)),;
STICKLINE(CLOSE>=OPEN,ORIGIN,ORIGIN+VOLUME,0.2,0),COLORRED;
STICKLINE(CLOSE<OPEN,ORIGIN,ORIGIN+VOLUME,0.2,0),COLORGREEN;
{压力+支撑}
压力:MA(REF(HHV(C,30),1),2),COLORRED;
支撑:MA(REF(LLV(C,30),1),2),COLORRED;
{千股千评}
DRAWTEXT_FIX(1,0,0.01,0,STRCAT('千股千评: ',EXTERNSTR(0,1))),COLOR0000FF;

通达信动态黄金分割+成交量+压力支撑位主图指标公式

 

相关文章