在线检测未来函数

通达信大肚线主图指标公式

来源:Internet,编辑:股旁网,2012-04-22

DIFF:=(EMA(C,26)-EMA(C,52));
DEA:=EMA(DIFF,52);
MACD:=(2*(DIFF-DEA));
DIF:=(EMA(C,26)-EMA(C,52));
ESS:=EMA(C,26);
EGG:=EMA(C,52);
大肚线:(((((((((52-1)*(26+1))*EGG)*1)-((((52+1)*(26-1))*ESS)*1))+(((26+1)*(52+1))*DIF))*1)/((2*52)-(2*26)))*1);
DRAWTEXT(大肚线>=REF(大肚线,1),大肚线,'*'),COLORRED,LINETHICK2;
DRAWTEXT(大肚线<REF(大肚线,1),大肚线,'*'),COLORGREEN,LINETHICK2;
VARA1:=(((CLOSE - MA(CLOSE,6)) / MA(CLOSE,6)) * 100);
VARA2:=(((CLOSE - MA(CLOSE,12)) / MA(CLOSE,12)) * 100);
VARA3:=(((CLOSE - MA(CLOSE,24)) / MA(CLOSE,24)) * 100);
VARA4:=(((VARA1 + (2 * VARA2)) + (3 * VARA3)) / 6);
VARA5:=MA(VARA4,3);
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
VARA6:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VARA7:=SMA(VARA6,3,1);
VARA8:=SMA(VARA7,3,1);
VARA9:=(VARA8/2+40)*1.1;
VARA10:=SMA(VARA9,3,1);
VARA11:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
VARA12:=EMA(VARA11,9);
VARA13:=(VARA11-VARA12)*2*60;
VARA14:=10;
VARA15:=VARA13-REF(VARA13,1);
DIF2:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA2:=EMA(DIF2,9);
AAA:=(DIF2-DEA2)*2*60;
买:=CROSS(VARA15,VARA14),NODRAW;
买1:=IF(买,1,0);
买2:=CROSS(AAA-REF(AAA,1),15);
大肚买:买1 AND 买2,NODRAW;
{www.gupang.com 股旁网_通达信股票指标公式}
逃顶1:=IF(CROSS(VARA10,RSI),50,0),STICK,COLORMAGENTA;
逃顶2:=IF(CROSS(80,RSI),-50,0),STICK,COLORGREEN;
逃顶3:=CROSS(80,RSI)*35;
大肚逃:=逃顶1 AND 逃顶2 AND 逃顶3;
STICKLINE(大肚逃,REF(CLOSE,1),REF(CLOSE,2),3.2,0),COLORFF3300;
STICKLINE(大肚逃,REF(CLOSE,1),REF(CLOSE,2),2.7,0),COLORFF5500;
STICKLINE(大肚逃,REF(CLOSE,1),REF(CLOSE,2),2.1,0),COLORFF7700;
STICKLINE(大肚逃,REF(CLOSE,1),REF(CLOSE,2),1.5,0),COLORFF9900;
STICKLINE(大肚逃,REF(CLOSE,1),REF(CLOSE,2),0.9,0),COLORFFBB00;
STICKLINE(大肚逃,REF(CLOSE,1),REF(CLOSE,2),0.3,0),COLORFFDD00;
DRAWTEXT(FILTER(大肚买=1,5),LOW,' 买进'),COLORFF00FF;
DRAWICON(FILTER(大肚买=1,5),LOW,9);
DRAWTEXT(FILTER(大肚逃=1,5),HIGH,' 逃顶'),COLOR00FF00;
DRAWICON(FILTER(大肚逃=1,5),HIGH,15);{大肚线};

通达信大肚线主图指标公式

 

相关文章