在线检测未来函数

通达信胡子MACD指标公式

来源:Internet,编辑:股旁网,2012-04-22

AA:=SMA(ABS(L-REF(L,1)),30,1)/SMA(MAX(L-REF(L,1),0),30,1);
底部动态:EMA(IF(L<=LLV(L,30),AA,0),3)/10,COLORRED,LINETHICK2;
DIFF:EMA(CLOSE,12) - EMA(CLOSE,26),COLORWHITE,LINETHICK1;
DEA:EMA(DIFF,9),COLORYELLOW,LINETHICK1;
MACD:2*(DIFF-DEA), COLORSTICK;
MACD1:MA(MACD,1),COLORRED;
MACD2:MA(MACD,2),COLORCYAN;
STICKLINE(MACD1>MACD2 AND MACD1>0,0,MACD1,2,0),COLORRED;
STICKLINE(MACD1>MACD2 AND MACD1<0,0,MACD1,2,0),COLORYELLOW;
STICKLINE(MACD1<MACD2,0,MACD1,1,0),COLORCYAN;
波谷:=TROUGHBARS(3,15,1)<10; 底部:=IF(波谷=1,50,0); 初选:=底部>REF(底部,3);
{www.gupang.com 股旁网_通达信股票指标公式}
M_X1:=MA(HHV(H,485),17); M_X2:=MA(HHV(H,222),17); M_X3:=MA(HHV(H,96),17);
M_X4:=MA(LLV(L,485),17); M_X5:=MA(LLV(L,222),17); M_X6:=MA(LLV(L,96),17);
M_XA:=MA((M_X1*0.558+M_X2*0.558+M_X2*0.558+M_X4*0.96+M_X5*0.96+M_X6*0.96)/6,17);
M_XB:=MA((M_X1*0.55+M_X2*0.55+M_X2*0.65+M_X4*1.25+M_X5*1.23+M_X6*1.2)/6,17);
M_XC:=MA((M_X1*0.68+M_X2*0.68+M_X2*0.68+M_X4*1.3+M_X5*1.3+M_X6*1.3)/6,17);
A_A:=MA((M_XA*3+M_XB*2+M_XC)/6*1.738,17);
B_B:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1)*100;
C_C:=MA(IF(C*1.35<=A_A,B_B*10,B_B/10),3);
D_D:=MA(IF(L<=LLV(L,13),(HHV(C_C,30)+B_B*2)/2,0),3);
C_D1:=(3*C+2*O+L+H)/7;
WMAC_D1_5:=(5*C_D1+4*REF(C_D1,1)+3*REF(C_D1,2)+2*REF(C_D1,3)+1*REF(C_D1,4))/(5+4+3+2+1);
C_D2:=REVERSE(C_D1)+2*WMAC_D1_5; C_D3:=3*C_D2-2*SMA(C_D2,2,1); C_D4:=CROSS(C,C_D3) AND D_D;
选:=C_D4 AND 初选;
选1:选*0.6;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
顶部雷达:CROSS(80,RSI)*0.3,LINETHICK2 ,COLORGREEN;
DRAWTEXT(CROSS(80,RSI),0.3,'见顶 '),COLORGREEN;
VARB:=SMA(MAX(CLOSE-LC,0),7,1)/SMA(ABS(CLOSE-LC),7,1)*100;
VARC:=SMA(MAX(CLOSE-LC,0),13,1)/SMA(ABS(CLOSE-LC),13,1)*100;
VARD:=BARSCOUNT(CLOSE);
底部雷达:(VARB< 20 AND VARC< 25 AND VARD> 50)*0.3,LINETHICK2, COLORFF9933;
DRAWTEXT(CROSS(100,底部雷达) ,0.2,'底 '),LINETHICK1,COLORF00FF0;

通达信胡子MACD指标公式

 

相关文章