在线检测未来函数

大智慧金牛稳箭主图+选股指标公式

来源:Internet,编辑:股旁网,2012-04-24

MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
金牛线:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+16*REF(MID,4)+15
*REF(MID,5)+14*REF(MID,6)+13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+10
*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+7*REF(MID,13)+6*REF(MID,14)+5
*REF(MID,15)+4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED,LINETHICK2;
PARTLINE(金牛线,金牛线>REF(金牛线,1),rgb(250,0,0),金牛线<REF(金牛线,1),rgb(0,250,0)),LINETHICK2,LAYER1;
金马线:MA(金牛线,6),COLORYELLOW;
DRAWICON( FILTER(CROSS(金牛线,金马线),20),金马线+0.02 ,7);
M1:MA(C,9.98),COLORYELLOW,DOTLINE,LAYER1;
突破:=REF(EMA(C,14),1);
A1X:=(EMA(C,14)-突破)/突破*100;
STICKLINE(CROSS(A1X,0),OPEN,CLOSE,7,0),COLORMAGENTA;
{www.gupang.com 股旁网_大智慧股票指标公式}
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));
TJ:=IF((C-REF(C,1))/REF(C,1)>0.025,1,0);
yl:=IF(C>REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),0);
FT:=BARSLAST(yl);
YLX:=REF(yl,FT);
平台突破:=CROSS(C,YLX);
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
主力进场:=VAR8>REF(VAR8,1);
进场:=ref(主力进场,1);
DRAWTEXT(进场 and 平台突破 and L>=支撑位,L * 0.98,'进'),ALIGN1,COLOR0000FF;
DRAWICON(进场 and 平台突破 and L=支撑位,L* 0.98,7),ALIGN1,VALIGN2;
DRAWTEXTREL(10,35,'所属板块:'+BKNAME),COLORFFFFFF;
DRAWTEXTREL(10,150,'总股本【亿】:'+FINANCE2(35)/10000),Color00FF00;
DRAWTEXTREL(190,150,'流通盘【亿】:'+CAPITAL/100/10000),Color00FF00;
DRAWTEXTREL(10,110,'总市值【亿】:'+DYNAINFO(56)/100000000),Color00FF00;
DRAWTEXTREL(190,110,'流通市值【亿】:'+DYNAINFO(57)/100000000),Color00FF00;
DRAWTEXTREL(10,75,'市盈率:' + DYNAINFO(39) + '倍' + ' 每股收益:' + FINANCE2(3) + '元' + ' 每股公积金:' + FINANCE2(7) + '元'),Color00FFFF;
DRAWTEXTREL(10,190,'上涨家数:'+NUMTOSTRN(DYNAINFO(69),0)+' 家'),COLOR0000FF;
DRAWTEXTREL(120,190,'下跌家数:'+NUMTOSTRN(DYNAINFO(70),0)+' 家'),COLOR00FF00;
DRAWTEXTREL(230,190,'平盘家数:'+NUMTOSTRN(DYNAINFO(71),0)+' 家'),COLORFFFFFF;

选股公式:
RSV:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=((3 * K) - (2 * D));
RSV24:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=((3 * K24) - (2 * D24));
支撑位:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24))));
TJ:=IF((C-REF(C,1))/REF(C,1)>0.025,1,0);
yl:=IF(C>REF(O,BARSLAST(TJ =1)),REF(O,BARSLAST(TJ =1)),0);
FT:=BARSLAST(yl);
YLX:=REF(yl,FT);
平台突破:=CROSS(C,YLX);
VAR2:=REF(LOW,1);
VAR3:=SMA(ABS(LOW-VAR2),13,1)/SMA(MAX(LOW-VAR2,0),13,1)*100;
VAR4:=EMA(IF(CLOSE*1.2,VAR3*13,VAR3/13),13);
VAR5:=LLV(LOW,34);
VAR6:=HHV(VAR4,34);
VAR7:=IF(LLV(LOW,56),1,0);
VAR8:=EMA(IF(LOW<=VAR5,(VAR4+VAR6*2)/2,0),3)/618*VAR7;
主力进场:=VAR8>REF(VAR8,1);
进场:=ref(主力进场,1);
进场 and 平台突破 and L=支撑位;

大智慧金牛稳箭主图+选股指标公式

 

相关文章