在线检测未来函数

通达信顶底背离MACD指标公式

来源:Internet,编辑:股旁网,2012-04-25

VAR1:=EMA(SLOPE(C,21)+C,55);
VAR2:=EMA(SLOPE(O,21)+O,55);
VAR3:=EMA(SLOPE(H,21)+H,55);
VAR4:=EMA(SLOPE(L,21)+L,55);
VAR5:=EMA(C,3);
VAR6:=EMA(O,3);
VAR7:=EMA(H,3);
VAR8:=EMA(L,3);
VAR9:=VAR1-VAR5,LINETHICK2;
VAR10:=VAR2-VAR6,LINETHICK2;
VAR11:=VAR3-VAR7,LINETHICK2;
VAR12:=VAR4-VAR8,LINETHICK2;
ZJC:=REVERSE(VAR9);
ZJO:=REVERSE(VAR10);
ZJH:=REVERSE(VAR11);
ZJL:=REVERSE(VAR12);
DIF:EMA(ZJC*5,12)-EMA(ZJC*5,26);
DEA:EMA(DIF,9);
MACD:(DIF-DEA)*2,COLORSTICK;
STICKLINE(MACD>REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORRED;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,0,0),COLORMAGENTA;
STICKLINE(MACD>REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORYELLOW;
STICKLINE(MACD<REF(MACD,1) AND MACD<0,0,MACD,0,0),COLORLIGREEN;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(ZJC> ZJO,ZJH,ZJL,0.0,0),COLORFF66FF;
STICKLINE(ZJC> ZJO,ZJC,ZJO,2.1,0),COLORAA00AA;
STICKLINE(ZJC> ZJO,ZJC,ZJO,1.9,0),COLORCC11CC;
STICKLINE(ZJC> ZJO,ZJC,ZJO,1.6,0),COLORFF22FF;
STICKLINE(ZJC> ZJO,ZJC,ZJO,1.2,0),COLORFF44FF;
STICKLINE(ZJC> ZJO,ZJC,ZJO,0.7,0),COLORFF66FF;
STICKLINE(ZJC> ZJO,ZJC,ZJO,0.2,0),COLORFF99FF;
STICKLINE(ZJC<=ZJO,ZJL,ZJC,0.0,0),COLORGREEN;
STICKLINE(ZJC<=ZJO,ZJO,ZJC,2.1,0),COLOR005500;
STICKLINE(ZJC<=ZJO,ZJO,ZJC,1.9,0),COLOR007700;
STICKLINE(ZJC<=ZJO,ZJO,ZJC,1.6,0),COLOR009900;
STICKLINE(ZJC<=ZJO,ZJO,ZJC,1.2,0),COLOR00BB00;
STICKLINE(ZJC<=ZJO,ZJO,ZJC,0.7,0),COLOR00DD00;
STICKLINE(ZJC<=ZJO,ZJO,ZJC,0.2,0),COLOR44FF00;
ZTB:=(C-REF(C,1))/REF(C,1)*100>9.9;
DRAWTEXT(ZTB,IF(ZJC<0,ZJC*0.9,ZJC*1.1),'涨停板')COLORYELLOW;
STICKLINE(ZTB,ZJC,ZJO,2.1,0),COLOR006666;
STICKLINE(ZTB,ZJC,ZJO,1.9,0),COLOR008888;
STICKLINE(ZTB,ZJC,ZJO,1.6,0),COLOR00AAAA;
STICKLINE(ZTB,ZJC,ZJO,1.2,0),COLOR00CCCC;
STICKLINE(ZTB,ZJC,ZJO,0.7,0),COLOR00EEEE;
STICKLINE(ZTB,ZJC,ZJO,0.2,0),COLOR33FFFF;
DTB:=(C-REF(C,1))/REF(C,1)*100<-9.9;
DRAWTEXT(DTB,IF(ZJC>0,ZJC*0.9,ZJC*1.1),'跌停板')COLORFF8800;
STICKLINE(DTB,ZJO,ZJC,2.1,0),COLORFF0000;{蓝色}
STICKLINE(DTB,ZJO,ZJC,1.9,0),COLORFF2200;
STICKLINE(DTB,ZJO,ZJC,1.6,0),COLORFF4400;
STICKLINE(DTB,ZJO,ZJC,1.2,0),COLORFF6600;
STICKLINE(DTB,ZJO,ZJC,0.7,0),COLORFF8800;
STICKLINE(DTB,ZJO,ZJC,0.2,0),COLORFFAA00;

通达信顶底背离MACD指标公式

 

相关文章