在线检测未来函数

连续2个一字涨停选股公式

来源:Internet,编辑:股旁网,2012-04-03

编写要求:

股旁网解答:

 网友求助:

xg:c>ref(c,1) and l=h;(赵鑫鑫505)编写,请问如何将条件设为连续2个一字涨停选股公式

连续2个一字涨停选股公式:every(c>ref(c,1) and o=c and l=h,2);

连续2个一字涨停带曾开口带下影涨停选股公式(4.95和9.85是调整涨停参数)
ST:=STRFIND(STKNAME,'ST',1)>0;
S:=STRFIND(STKNAME,'S',1)>0;
ZF:=IF(ST OR S,4.95,9.85);
ZT:=(C-REF(C,1))/REF(C,1)*100>=ZF;
XG:EVERY(ZT AND O=C AND L<=H,2);

 
解答如下:
ST:=STRFIND(STKNAME,'ST',1)>0;
S:=STRFIND(STKNAME,'S',1)>0;
ZF:=IF(ST OR S,4.95,9.85);
ZT:=(C-REF(C,1))/REF(C,1)*100>=ZF;
XG:EVERY(ZT AND O=C AND L<=H,2);

 

相关文章