在线检测未来函数

oamv活筹指标

来源:Internet,编辑:股旁网,2012-04-10

编写要求:

股旁网解答:

 网友求助:

请老师把这个主力线指标加到oamv活筹指标中,合到一起用看起来很方便,谢谢
主力线源码:
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
主力:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
IF(主力>=REF(主力,1),主力,DRAWNULL),COLORRED,LINETHICK2;
IF(主力<=REF(主力,1),主力,DRAWNULL),COLORGREEN,LINETHICK2;
oamv活筹源码:
{0AMV活筹指数}
VAR1:=AMOUNT;
VAR2:=SMA(VAR1,10,1);
VAR3:=REF(VAR2,1);
STICKLINE(VAR2>VAR3,VAR2,VAR3,3,0),COLORRED;
STICKLINE(VAR2<VAR3,VAR2,VAR3,3,0),COLORGREEN;
 
解答如下:
MID:=(3*CLOSE+LOW+OPEN+HIGH)/6;
主力:=(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+
10*REF(MID,10)+9*REF(MID,11)+8*REF(MID,12)+
7*REF(MID,13)+6*REF(MID,14)+5*REF(MID,15)+
4*REF(MID,16)+3*REF(MID,17)+2*REF(MID,18)+REF(MID,20))/210,COLORRED;
IF(主力>=REF(主力,1),主力,DRAWNULL),COLORFF00FF,LINETHICK3;
IF(主力<=REF(主力,1),主力,DRAWNULL),COLORFFFF00,LINETHICK3;
{0AMV活筹指数}
VAR1:=AMOUNT;
VAR2:=SMA(VAR1,10,1);
VAR3:=REF(VAR2,1);
STICKLINE(VAR2>VAR3,VAR2,VAR3,3,0),COLORRED;
STICKLINE(VAR2<VAR3,VAR2,VAR3,3,0),COLORGREEN;
 

 

相关文章