在线检测未来函数

通达信涨停榜主图指标公式

来源:Internet,编辑:股旁网,2012-05-04

MA6:=MA(C,6);
MA13:=MA(C,13);
MA18:=MA(C,18);
MA30:MA(C,30);
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
STICKLINE(涨停,H,L,3,0),COLORRED;
跌停:=IF((C2-C)*100/C2>=(10-0.01*100/C2),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
A1:=REF(H,8)=HHV(H,2*8+1);
B1:=FILTER(A1,8);
C1:=BACKSET(B1,8+1);
D1:=FILTER(C1,8);{高点}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1); S11:=R11>REF(R11,1);
DRAWLINE(D1,H,S11,H,1),COLORRED,LINETHICK2;
A2:=REF(L,8)=LLV(L,2*8+1);
B2:=FILTER(A2,8);
CB2:=BACKSET(B2,8+1);
D2:=FILTER(CB2,8);{低点}
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1); U11:=T11>REF(T11,1);
DRAWLINE(D2,L,U11,L,1),COLORRED,LINETHICK2;
M:=INTPART(3*8/5);
A12:=REF(H,M)=HHV(H,2*M+1);
B12:=FILTER(A12,M);
C12:=BACKSET(B12,M+1);
D12:=FILTER(C12,M);{高点}
R112:=BACKSET(ISLASTBAR,BARSLAST(D12)+1); S112:=R112>REF(R112,1);
DRAWLINE(D12,H,S112,H,1),COLORBLUE,LINETHICK2;
A22:=REF(L,M)=LLV(L,2*M+1);
B22:=FILTER(A22,M);
C22:=BACKSET(B22,M+1);
D22:=FILTER(C22,M);{低点}
T112:=BACKSET(ISLASTBAR,BARSLAST(D22)+1); U112:=T112>REF(T112,1);
DRAWLINE(D22,L,U112,L,1),COLORBLUE,LINETHICK2;
Y:=INTPART(5*9/2);
AA1:=REF(H,Y)=HHV(H,2*Y+1);
BA1:=FILTER(AA1,Y);
CA1:=BACKSET(BA1,Y+1);
DA1:=FILTER(CA1,Y);{高点}
RA12:=BACKSET(ISLASTBAR,BARSLAST(DA1)+1); SA12:=RA12>REF(RA12,1);
DRAWLINE(DA1,H,SA12,H,1),COLOR00FFFF;
AA2:=REF(L,Y)=LLV(L,2*Y+1);
BA2:=FILTER(AA2,Y);
CA2:=BACKSET(BA2,Y+1);
DA2:=FILTER(CA2,Y);{低点}
TA12:=BACKSET(ISLASTBAR,BARSLAST(DA2)+1); UA12:=TA12>REF(TA12,1);
DRAWLINE(DA2,L,UA12,L,1),COLOR00FFFF;
主:=(CLOSE+O+HIGH+LOW)/4;
力:=EMA(主,13)-EMA(主,34);
控:=EMA(力,5);
弃:=(-2)*(力-控)*5.8;
盘:=2*(力-控)*5.8;
方向:=CROSS(盘,弃);
DRAWICON(方向,0.99*LOW,1);
向下:=CROSS(弃,盘);
DRAWICON(向下,HIGH*1.01,2);
TY:=C;
HD:=FILTER(BACKSET(FILTER(REF(TY,10)=HHV(TY,2*10+1),10),10+1),10);
LD:=FILTER(BACKSET(FILTER(REF(TY,10)=LLV(TY,2*10+1),10),10+1),10);
A:=REF(C,BARSLAST(HD));
B:=REF(C,BARSLAST(LD));
T1:=BARSLAST(HD)<BARSLAST(LD) AND NOT(HD) ;
T2:=BARSLAST(HD)>BARSLAST(LD) AND NOT(LD);
波浪顶:IF(T1,A,A),COLORFF00FF,POINTDOT,LINETHICK4;
STICKLINE(T1,A,A,9,0),COLORFF00FF;
波浪底:IF(T2,B,B),COLOR80FF00,POINTDOT,LINETHICK4;
STICKLINE(T2,B,B,9,0),COLORGREEN ;
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA60:MA(CLOSE,60),COLORGREEN;
MA120:=MA(CLOSE,120),COLORLIMAGENTA;
{www.gupang.com 股旁网_通达信股票指标公式}
MA240:=MA(CLOSE,240),COLORBLUE,NODRAW;
VOL5:=MA(VOL,5),COLORWHITE;
VOL10:=MA(VOL,10),COLORYELLOW;
VOL40:=MA(VOL,40),COLORFF00FF ;
MA1:=MA(CLOSE,5);
MA2:=MA(CLOSE,10);
MA3:=MA(CLOSE,20);
ZJ:=AMOUNT/10000;{资金}
TM:=V-MA(V,10);{量填满}
{高点:=(C/REF(C,BARSLAST(HD))-1)*100,NODRAW;
STICKLINE((HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667,H,C,0.8,0),COLORBLUE;}
三日不破:=MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(L,3);
三日量缩:=(MAX(MAX(V,REF(V,1)),REF(V,2))<REF(V,3));
三日价涨A:=C>=REF(C,1);
三日价涨B:=C<REF(C,1);
三日价涨C:=MIN(MIN(C,REF(C,1)),REF(C,2))>=REF(L,3);
TIM:=IF(DATE<1140214,1,0);
缩倍柱:=(VOL*1.95<=REF(VOL,1))*TIM;
百日低量:=(VOL=LLV(VOL,100))*TIM;
倍量柱:=C>REF(C,1)*1.04 AND (VOL>=1.9*REF(VOL,1))*TIM;
四日前倍量柱:=(REF(VOL,3)>1.9*REF(VOL,4))*TIM;
四日前高量柱:=(REF(VOL,3)>=REF(VOL,4) AND REF(VOL,3)<1.9*REF(VOL,4) AND 三日量缩)*TIM;
前三引用不成立:=COUNT(REF(四日前倍量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0 AND COUNT(REF(四日前高量柱,1) AND (REF(三日不破,1) OR REF(三日价涨C,1)),3)=0;
倍量黄金柱:=四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量黄金柱:=四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
黄金柱:=倍量黄金柱 OR 高量黄金柱;
次倍量黄金柱:=NOT(黄金柱) AND 四日前倍量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量黄金柱:=NOT(黄金柱) AND 四日前高量柱 AND 三日量缩 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次黄金柱:=次倍量黄金柱 OR 次高量黄金柱;
准倍量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前倍量柱 AND ((三日量缩 AND 三日价涨C) OR (COUNT(倍量柱,3)>=1 AND 三日不破)) AND 前三引用不成立;
准高量黄金柱:=NOT(黄金柱 OR 次黄金柱) AND 四日前高量柱 AND (三日量缩 AND 三日价涨C) AND 前三引用不成立;
准黄金柱:=准倍量黄金柱 OR 准高量黄金柱;
倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨A AND 前三引用不成立;
将军柱:=倍量将军柱 OR 高量将军柱;
次倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前倍量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱) AND 四日前高量柱 AND 三日不破 AND 三日价涨B AND 前三引用不成立;
次将军柱:=次倍量将军柱 OR 次高量将军柱;
准倍量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前倍量柱 AND 三日价涨C AND 前三引用不成立;
准高量将军柱:=NOT(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱) AND 四日前高量柱 AND 三日价涨C AND 前三引用不成立;
准将军柱:=准倍量将军柱 OR 准高量将军柱;
BACKSET100:=BACKSET(黄金柱 OR 次黄金柱 OR 准黄金柱 OR 将军柱 OR 次将军柱 OR 准将军柱,4);
FILTER100:=FILTER(BACKSET100,3),NODRAW;
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
BACKSET102:=BACKSET(次黄金柱,4);
FILTER102:=FILTER(BACKSET102,3);
BACKSET103:=BACKSET(准黄金柱,4);
FILTER103:=FILTER(BACKSET103,3);
BACKSET104:=BACKSET(将军柱,4);
FILTER104:=FILTER(BACKSET104,3);
BACKSET105:=BACKSET(次将军柱,4);
FILTER105:=FILTER(BACKSET105,3);
BACKSET106:=BACKSET(准将军柱,4);
FILTER106:=FILTER(BACKSET106,3);
黄金线下影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=REF(L,3);
黄金线实体下端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<=MIN(REF(C,3),REF(O,3)) AND MIN(MIN(L,REF(L,1)),REF(L,2))>REF(L,3),LINETHICK0;
黄金线上影线:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=REF(H,3);
黄金线实体上端:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>=MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<REF(H,3);
黄金线实体中间:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3));
黄金线实体中间1:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,2)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间2:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND REF(L,1)=MIN(MIN(L,REF(L,1)),REF(L,2));
黄金线实体中间3:=REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))<MAX(REF(C,3),REF(O,3)) AND REF(FILTER100,3)=1 AND MIN(MIN(L,REF(L,1)),REF(L,2))>MIN(REF(C,3),REF(O,3)) AND L=MIN(MIN(L,REF(L,1)),REF(L,2));
BACKSET201:=BACKSET(黄金线下影线,4);
FILTER201:=FILTER(BACKSET201,3),NODRAW;
BACKSET202:=BACKSET(黄金线实体下端,4);
FILTER202:=FILTER(BACKSET202,3),NODRAW;
BACKSET203:=BACKSET(黄金线上影线,4);
FILTER203:=FILTER(BACKSET203,3),NODRAW;
BACKSET204:=BACKSET(黄金线实体上端,4);
FILTER204:=FILTER(BACKSET204,3),NODRAW;
BACKSET205:=BACKSET(黄金线实体中间,4);
FILTER205:=FILTER(BACKSET205,3),NODRAW;
BACKSET2051:=BACKSET(黄金线实体中间1,4);
FILTER2051:=FILTER(BACKSET2051,3),NODRAW;
BACKSET2052:=BACKSET(黄金线实体中间2,4);
FILTER2052:=FILTER(BACKSET2052,3),NODRAW;
BACKSET2053:=BACKSET(黄金线实体中间3,4);
FILTER2053:=FILTER(BACKSET2053,3),NODRAW;
BT201:=IF(BARSLAST(FILTER201)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER201));
BT202:=IF(BARSLAST(FILTER202)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER202));
BT203:=IF(BARSLAST(FILTER203)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER203));
BT204:=IF(BARSLAST(FILTER204)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER204));
BT205:=IF(BARSLAST(FILTER205)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER205));
BT2051:=IF(BARSLAST(FILTER2051)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2051));
BT2052:=IF(BARSLAST(FILTER2052)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2052));
BT2053:=IF(BARSLAST(FILTER2053)=DRAWNULL,BARSCOUNT(CLOSE),BARSLAST(FILTER2053));
最近黄金线:=MIN(MIN(MIN(MIN(MIN(MIN(BT201,BT202),BT203),BT204),BT2051),BT2052),BT2053);
DAY1:=SUMBARS(FILTER100,1),NODRAW;
HJX1_1:=IF(SUMBARS(FILTER201,1)=DAY1,IF(DAY1=1,LOW,REF(LOW,DAY1-1)),0),NODRAW;
HJX1_2:=IF(SUMBARS(FILTER202,1)=DAY1,IF(DAY1=1,MIN(C,O),MIN(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_3:=IF(SUMBARS(FILTER203,1)=DAY1,IF(DAY1=1,HIGH,REF(HIGH,DAY1-1)),0),NODRAW;
HJX1_4:=IF(SUMBARS(FILTER204,1)=DAY1,IF(DAY1=1,MAX(C,O),MAX(REF(C,DAY1-1),REF(OPEN,DAY1-1))),0),NODRAW;
HJX1_51:=IF(SUMBARS(FILTER2051,1)=DAY1,IF(DAY1=2,LOW,IF(DAY1<2,DRAWNULL,REF(LOW,DAY1-2))),0),NODRAW;
HJX1_52:=IF(SUMBARS(FILTER2052,1)=DAY1,IF(DAY1=3,LOW,IF(DAY1<3,DRAWNULL,REF(LOW,DAY1-3))),0),NODRAW;
HJX1_53:=IF(SUMBARS(FILTER2053,1)=DAY1,IF(DAY1=4,LOW,IF(DAY1<4,DRAWNULL,REF(LOW,DAY1-4))),0),NODRAW;
黄金线:=HJX1_1+HJX1_2+HJX1_3+HJX1_4+HJX1_51+HJX1_52+HJX1_53,COLORYELLOW,NODRAW;
立桩量:=VOL=HHV(VOL,40) AND VOL>1.9*REF(VOL,1);
立桩量三日突破:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));
立桩量三日不破:=BARSLAST(立桩量)=3 AND REF(LOW,3)<=MIN(MIN(C,REF(C,1)),REF(C,2));
BACKSET300:=BACKSET(立桩量三日不破,4);
BACKSET301:=BACKSET(立桩量三日突破,4);
立桩量成立:=FILTER(BACKSET300,3) AND BACKSET301 AND 立桩量;
DRAWTEXT(立桩量成立,HIGH*1.01,'↙立桩量'),COLOR00FF00;
DRAWTEXT(FILTER101,LOW*0.986,'↖黄金柱'),COLORYELLOW;
STICKLINE(FILTER101,OPEN,CLOSE,0.5,0),COLORYELLOW;
DRAWTEXT(FILTER102,LOW*0.986,'↖次黄金柱'),COLORYELLOW;
DRAWTEXT(FILTER104,LOW*0.986,'↖将军柱'),COLORYELLOW;
STICKLINE(FILTER104,OPEN,CLOSE,1.5,0),COLORYELLOW;
涨家数:INDEXADV,NODRAW,COLORLIMAGENTA ;
跌家数:INDEXDEC,NODRAW,COLORGREEN;

通达信涨停榜主图指标公式

 

相关文章