在线检测未来函数

大智慧均线流偏离率主图指标公式

来源:Internet,编辑:股旁网,2012-05-08

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA30:MA(CLOSE,30);
MA60:=MA(CLOSE,60);
MA65:MA(CLOSE,65);
MA250:MA(CLOSE,250),colorred;
均线流:=(((((MA5 > MA65) AND (MA10 > MA65)) AND (MA30 > MA65)) AND (MA5 < MA30)) * 0.3);
PL1:=(((CLOSE - MA60) / MA60) < 0.1);
PL2:=(((CLOSE - MA250) / MA250) < 0.3);
偏离率:=(((PL1 = 1) AND (PL2 = 1)) * 0.2);
{www.gupang.com 股旁网_大智慧股票指标公式}
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA :=EMA(DIFF,9);
MACD超跌:=(COUNT((DIFF < DEA),10) = 10);
MACD:=(MACD超跌 * "MACD.MACD"(26,12,9))*(-1);
目标:=if(均线流=0.3 AND macd and 偏离率=0.2 ,0.8,0);
DRAWTEXT(目标 ,l,'▲'),color008fff;
MBSJ:=BARSLAST((目标 = 0.8));
放量上涨:=(((VOL / REF(VOL,1)) >= 1.1) AND ((CLOSE / REF(CLOSE,1)) >= 1.01));
SZSJ:=BARSLAST((放量上涨 = 1));
MACD金叉:=CROSS(DIFF,DEA);
JCSJ:=BARSLAST((MACD金叉 = 1));
关注:=((MACD金叉 AND (REF(MACD,1) < 0)) * -0.1);
DRAWTEXT(关注,l,'◆'),color00ff00;
启动:=((((MBSJ <= 20) AND (SZSJ <= 1)) AND (JCSJ <= 1)) * 1);
DRAWTEXT(启动,l,'●'),coloryellow;
突破:=((((偏离率 = 0) AND (REF(偏离率,1) = 0.2)) AND (REF((COUNT((偏离率 = 0.2),10) = 10),1) = 1)) * -0.1);
DRAWTEXT(突破,l,'★'),coloryellow;

大智慧均线流偏离率主图指标公式

 

相关文章