在线检测未来函数

通达信AA+分价主图指标公式

来源:Internet,编辑:股旁网,2012-05-08

M1:=MA(C,1),COLOR00FFFF,LINETHICK1{,NODRAW};
M3:=MA(C,3),COLOR00FF00,LINETHICK1{,NODRAW};
N1:=13;
X1:=HHV(H,3);
X2:=LLV(L,3);
XC:=C;
XH:=H;
XL:=L;
YCJY:=0;
Y1:=HHV(H,13);
Y2:=IF(Y1>REF(Y1,30),Y1,REF(Y1,8));
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J1:=-(3*K-2*D)+100;
J2:=IF(J1<0 ,0 ,J1);
J:=IF(J2>100,100,J2);
VAR4:=(LOW+HIGH+CLOSE)/3;
操作:=MA(VAR4,2);
拉升:=HHV(操作,N1);
压:HHV(操作,N1),LINETHICK3,COLORFF8080;{压力位}
M5:MA(C,5),COLOR00FFFF;
支:LLV(操作,N1),LINETHICK3,COLORC8C8FF;{支撑位}
JJ:=(CLOSE+HIGH+LOW)/3;
A:EMA(JJ,10),COLOR00FF00,LINETHICK2;
BB:=REF(A,1);
IF(A>BB,A,DRAWNULL),COLOR0000FF,LINETHICK2;
M10:=MA(C,10),COLORFFFFFF;
DRAWKLINE(H,O,L,C);
{涨跌停K}
ZDF:=(C-REF(C,1))/REF(C,1)*100;
STICKLINE(ZDF>=9.7,O,C,5,0),COLORRED;
STICKLINE(ZDF<=-9.7,O,C,5,0),COLOR959595;
KS:=(((CLOSE - EMA(CLOSE,13)) / EMA(CLOSE,13)) * (0 - 100));
趋势线:=EMA(((KS / 10) + EMA(CLOSE,10)),3);
AA:=-100*(趋势线-CLOSE)/趋势线;
AC:=(EMA(AA,5) );
STICKLINE(((((CLOSE>=OPEN)) AND (AA>=0)) AND (AA>=AC)),CLOSE,OPEN,3.8,1),
COLOR0000EC;{上涨途中红色}
{STICKLINE(((((OPEN > CLOSE)) AND (AA>=0)) AND (AA>=AC)),CLOSE,OPEN,3.8,0),
COLORFFFF00;}
STICKLINE(((((CLOSE>=OPEN)) AND (AA>=0)) AND (AA<AC)),CLOSE,OPEN,3.8,1),
COLORFF00FF;{初期 玫瑰红}
STICKLINE(((((OPEN > CLOSE)) AND (AA>= 0)) AND (AA < AC)),CLOSE,OPEN,4.4,0),
COLORFF1E8E;{要跌 雪青 }
STICKLINE((((CLOSE >= OPEN) ) AND (AA< 0)),CLOSE,OPEN,3.8,1),
COLORF77B00;{下跌 蓝色}
STICKLINE((((OPEN > CLOSE)) AND (AA< 0)),CLOSE,OPEN,3.9,0),
COLORF77B00;
AA1:=EMA(C,2);
BB1:=EMA(AA1,2);
AB:=MA(BB1,3);
AA2:=EMA((H+C+O)/3,18);
DD3:=AB>=AA2 AND C>AA2;
DD4:=AB<AA2 ;
DD5:=AB>AA2 ;
STICKLINE((DD4 OR DD5) AND O<=C ,C,O,2,0),COLORA000FF;
STICKLINE((DD3 OR C>AA2) AND O<=C,C,O,2,0),COLORFF80FF;
STICKLINE(MA(C,13)>O AND C>MA(C,13) AND O<C,O,C,2.1,0),COLOR0088FF;
STICKLINE((DD3 OR C>AA2) AND O>=C,C,O,2,0),COLORFFA040;
STICKLINE((DD4 OR DD5) AND O>=C ,C,O,2,0),COLOR008040;
{www.gupang.com 股旁网_通达信股票指标公式}
V2:=(REF(HIGH,1)+REF(LOW,1))/2;
V3:=MA(CLOSE,20)+2*STD(CLOSE,20);
DRAWICON(CROSS(V2,V3),HIGH*1.045,15);
DRAWTEXT(CROSS(V2,V3),HIGH*1.03,'快卖'),COLOR00FF80;
V4:=REF(CLOSE,1);
V5:=SMA(MAX(CLOSE-V4,0),7,1)/SMA(ABS(CLOSE-V4),7,1)*100;
V6:=CROSS(79,V5);
V7:=FILTER(V6,4);
DRAWICON(V7,HIGH*1.025,10);
DRAWTEXT(V7,HIGH*1.01,'绝卖'),COLOR00FF00;

通达信AA+分价主图指标公式

 

相关文章