在线检测未来函数

通达信四线MACD指标公式

来源:Internet,编辑:股旁网,2012-05-08

DIFF:EMA(CLOSE,30)-EMA(CLOSE,60),COLOR0000FF,LINETHICK2;
DEA:EMA(DIFF,15),LINETHICK2,COLOR00FFFF;
差:(DEA-DIFF),COLORFF8000,NODRAW;
MACD:3*(DIFF-DEA),COLOR4080FF,NODRAW;
{www.gupang.com 股旁网_通达信股票指标公式}
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1,0),COLOR4080FF;
STICKLINE(MACD<REF(MACD,1) AND MACD>0,0,MACD,1,0),COLORFF8080;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1,0),COLORFF80FF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,1,0),COLORFFCC66;
DIF:EMA(CLOSE,9)-EMA(CLOSE,18),LINETHICK2,COLORFF00FF;
DEA1:EMA(DIF,7),LINETHICK2,COLOR00FF00;
下穿:=COUNT(DEA<=0,5)=1 AND DEA<=0;
上穿:=COUNT(DEA>=0,5)=1 AND DEA>=0;
DRAWTEXT(下穿,1,'↓'),COLOR00FF00;
DRAWTEXT(上穿,1,'↑'),COLOR0000FF;
日线空头:IF(DEA<0,1,0),COLORFFFFFF;
红箭:CROSS(DIFF,DEA) OR (DIFF-DEA)=0,NODRAW,COLOR7500EA;
B:CROSS(DIF,DEA1),NODRAW,COLOR8080FF;
DRAWICON(B,MACD,7);
DRAWICON(红箭,DEA,1);

通达信四线MACD指标公式

 

相关文章