在线检测未来函数

通达信活筹宝塔指标公式

来源:Internet,编辑:股旁网,2012-05-14

VAR11:=SMA(AMOUNT,15,1)/5670000;
VAR22:=MA(REF(CLOSE,1),5);
VAR2:=VAR11*CLOSE/VAR22;
B0:=REF(VAR2-O,2);
B1:=REF(VAR2,1);
B2:=REF(VAR2,2);
B3:=REF(VAR2,3);
B4:=REF(VAR2,4);
VAR2MAX:=MAX(MAX(MAX(VAR2,B1),B2),B3);
VAR2MIN:=MIN(MIN(MIN(VAR2,B1),B2),B3);
{www.gupang.com 股旁网_通达信股票指标公式}
RS1:=(VAR2=VAR2MAX AND (B1>=B2 OR B1>=B3)) OR (B1=VAR2MAX AND (B2=VAR2MIN OR B3=VAR2MIN) AND VAR2>=B2) OR (B2=VAR2MAX AND B3=VAR2MIN AND VAR2>=B1) OR (B3=VAR2MAX AND VAR2>=B1 AND VAR2>=B2);
RS2:=VAR2=VAR2MAX AND B1=VAR2MIN;
RS3:=(B1=VAR2MAX AND VAR2<B2) OR (B2=VAR2MAX AND B1>B3) OR (B3=VAR2MAX AND B1>B2 AND B2>=B4 AND VAR2<B1);
STICKLINE(RS1,B1,VAR2,2,1),COLORRED;
STICKLINE(RS2,B2,VAR2,2,1),COLORRED;
STICKLINE(RS3,B1,B2,2,1),COLORRED;
GS1:=(VAR2=VAR2MIN AND (B1<B2 OR B1<B3)) OR (B1=VAR2MIN AND (B2=VAR2MAX OR B3=VAR2MAX) AND VAR2<B2) OR (B2=VAR2MIN AND B3=VAR2MAX AND VAR2<B1) OR (B3=VAR2MIN AND VAR2<B1 AND VAR2<B2);
GS2:=B1=VAR2MAX AND VAR2=VAR2MIN;
GS3:=(B1=VAR2MIN AND VAR2>=B2) OR (B2=VAR2MIN AND B1<=B3) OR (B3=VAR2MIN AND B1<=B2 AND B2<B4 AND VAR2>=B1);
STICKLINE(GS1,B1,VAR2,2,0),COLORGREEN;
STICKLINE(GS2,B2,VAR2,2,0),COLORGREEN;
STICKLINE(GS3,B1,B2,2,0),COLORGREEN;

通达信活筹宝塔指标公式

 

相关文章