在线检测未来函数

通达信绝顶财神主图指标公式

来源:Internet,编辑:股旁网,2012-05-30

C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORRED;
跌停:=IF((C3-C)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(跌停,OPEN,CLOSE,2,0),COLORGREEN;
MA4:MA(CLOSE,4),COLORFFFFFF;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORFF00FF;
MA62:MA(CLOSE,62),COLORFFFF00;
VAR1:=SLOPE(MA20,3)>0;
VAR2:=ABS(SLOPE(MA62,3))<0.19;
VAR3:=SLOPE(MA62,3)>REF(SLOPE(MA62,3),1);
VAR4:=REF(MA4,4)>MA20;
VAR5:=REF(MA20<MA62,15)AND MA20>=MA62;
ABSVOL:=(MA4-MA20);
VAR6:=SLOPE(MA4,2)>=REF(SLOPE(MA4,2),1) AND ABSVOL>=REF(ABSVOL,1) AND REF(ABSVOL,2)>=REF(ABSVOL,1);
CON1:=VAR1 AND VAR2 AND VAR3 AND VAR4 AND VAR5 AND VAR6 ;
VAR41:=REF(MA4>MA20,3);
ABSVOL1:=ABS(MA4-MA10);
VAR61:=REF(ABSVOL1,2)>REF(ABSVOL1,1) AND ABSVOL1>REF(ABSVOL1,1) AND SLOPE(MA4,2)<0 AND SLOPE(MA4,2)>REF(SLOPE(MA4,2),1);
CON2:=VAR1 AND VAR2 AND VAR3 AND VAR41 AND VAR5 AND VAR61 ;
CON:=CON1 OR CON2;
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWTEXT(NOT(REF(CON,4))AND NOT(REF(CON,3))AND NOT(REF(CON,1))AND NOT(REF(CON,2)) AND CON,LOW*0.98,'张嘴');
MA120:MA(C,120),COLOR88BBFF;
MA250:MA(C,250),COLOR0000FF;
VAR11:=REF(CLOSE,1);
VAR12:=SMA(MAX(CLOSE-VAR11,0),13,1)/SMA(ABS(CLOSE-VAR11),13,1)*100;
VAR13:=CROSS(69,VAR12);
VARA:=FILTER(VAR13,4);
DRAWICON(VARA,HIGH*1.035,3),COLORGREEN;
DRAWTEXT(VARA,HIGH*1.04,'绝顶'),COLORWHITE;
A5:=EMA(CLOSE,12)-EMA(CLOSE,26);
A6:=EMA(A5,9);
A7:=(A5<-0.1 AND A5>A6);
财神:IF(A7,LLV(L,21),DRAWNULL)COLORRED,CIRCLEDOT;

通达信绝顶财神主图指标公式

 

相关文章