在线检测未来函数

飞狐游子换手指标公式

来源:Internet,编辑:股旁网,2012-05-31

{发行价:FINANCE(51),LINETHICK0,COLORWHITE;
发行量:FINANCE(52)/10000,LINETHICK0,COLORWHITE;}
流通:IF(STKTYPE=0,ESTDATA(1)/10000,CAPITAL/1000000),LINETHICK0,COLORCYAN;{
未流通:(FINANCE(1)-FINANCE(7))/10000,LINETHICK0,COLORWHITE;}
市值:IF(STKTYPE=0,ESTDATA(2)/10000,DYNAINFO(42)/10000),LINETHICK0,COLORGREEN;
量比:DYNAINFO(17),LINETHICK0,COLORMAGENTA;
{加到自用的成交量公式前面}
{⑤%:CAPITAL*5/100,linedot,colorgray;}
交易分钟数:=if(CURRENTTIME>93000 and CURRENTTIME<150000,
if(CURRENTTIME<113000,(TIMETOT0(CURRENTTIME)-34200)/60,
if(CURRENTTIME>130000,(TIMETOT0(CURRENTTIME)-39600)/60,120)),240);
日期差:=DATEDIFF(DATE,CURRENTDATE);
预测:IF(BARSTATUS=2 and 日期差=0,V/CAPITAL*100/交易分钟数*240,V/CAPITAL*100),Color00AAAA,LINETHICK0;
{预测量2:IF(BARSTATUS=2,V/CAPITAL*100*240/OPENMINUTES(CURRENTTIME),V/CAPITAL*100,COLOR00FF00,LINETHICK0;}
STICKLINE(BARSTATUS=2,V/CAPITAL*100,预测,8,1),LINEDOT,Color00AAAA;
换手:IF(STKTYPE=0,V/ESTDATA(1),V/CAPITAL*100),LINETHICK0,COLORRED;//分别计算大盘个股换手率
总额:AMOUNT/100000000,LINETHICK0,COLORGREEN;
获利:WINNER(CLOSE)*100,LINETHICK0,COLORYELLOW;{
市盈:IF(STKTYPE=0,ESTDATA(3),DYNAINFO(39)),LINETHICK0,COLORWHITE;
流动比率:FINANCE(11)/FINANCE(15),LINETHICK0,COLORCYAN;}
{
{波段画线}
A1:=REF(HIGH,3)=HHV(HIGH,2*3+1); B1:=FILTER(A1,3); C1:=BACKSET(B1,3+1); D1:=FILTER(C1,3);{高点}
A2:=REF(LOW,3)=LLV(LOW,2*3+1); B2:=FILTER(A2,3); C2:=BACKSET(B2,3+1); D2:=FILTER(C2,3);{低点}
E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2; E2:=(HIGH+LOW)/2;{高低点出现在同一K线上时可作取舍}
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR barpos=datacount OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);{过滤后低点}
vertline(ld),pointdot,colorgreen;
两低点累计换手:ref(sum(换手,sumbars(ld=1,2)),barslast(ld=1)),linethick0,COLORYELLOW; //两低点累计换手率
}
{
{均线}
MA5:MA(预测,5),COLORWHITE;
MA10:MA(预测,10),COLORYELLOW;
MA20:MA(预测,20),COLORMAGENTA;
MA30:MA(预测,30),COLORGRAY;
MA60:MA(预测,60),COLORGREEN;
MA120:MA(预测,120),COLORCYAN;
MA250:MA(预测,250),COLOR00A5FF;
}
地量小于1:STICKLINE(换手<=1,0,换手 , 8,0 ),coloraaaaCC;//白色柱线
STICKLINE(换手<=1,0,换手 , 6.6,0 ),colorbbbbCC;
STICKLINE(换手<=1,0,换手 , 4.4,0 ),colorccccCC;
STICKLINE(换手<=1,0,换手 , 3.3,0 ),colorddddCC;
STICKLINE(换手<=1,0,换手 , 2.2,0 ),coloreeeeCC;
STICKLINE(换手<=1,0,换手 , 1.1,0 ),colorFFffCC;
低迷1至2:STICKLINE(换手>1 AND 换手<=2,0,换手,8,0),Color00aa00;//绿色柱线
STICKLINE(换手>1 AND 换手<=2,0,换手,6.6,0),Color00bb00;
STICKLINE(换手>1 AND 换手<=2,0,换手,4.4,0),Color00cc00;
STICKLINE(换手>1 AND 换手<=2,0,换手,3.3,0),Color00dd00;
STICKLINE(换手>1 AND 换手<=2,0,换手,2.2,0),Color00ee00;
STICKLINE(换手>1 AND 换手<=2,0,换手,1.1,0),Color00ff00;
温和2至3:STICKLINE(换手>2 AND 换手<=3,0,换手 ,8,0),COLORFFaa00;//青色柱线
STICKLINE(换手>2 AND 换手<=3,0,换手,6.6,0),COLORFFbb00;
STICKLINE(换手>2 AND 换手<=3,0,换手,4.4,0),COLORFFcc00;
STICKLINE(换手>2 AND 换手<=3,0,换手,3.3,0),COLORFFdd00;
STICKLINE(换手>2 AND 换手<=3,0,换手,2.2,0),COLORFFee00;
STICKLINE(换手>2 AND 换手<=3,0,换手,1.1,0),COLORFFff00;
活跃3至5:STICKLINE(换手>3 AND 换手<=5,0,换手,8 ,0 ),COLOR00aaff;//黄色柱线
STICKLINE(换手>3 AND 换手<=5,0,换手,6.6 ,0 ),COLOR00bbff;
STICKLINE(换手>3 AND 换手<=5,0,换手,4.4 ,0 ),COLOR00ccff;
STICKLINE(换手>3 AND 换手<=5,0,换手,3.3 ,0 ),COLOR00ddff;
STICKLINE(换手>3 AND 换手<=5,0,换手,2.2 ,0 ),COLOR00eeff;
STICKLINE(换手>3 AND 换手<=5,0,换手,1.1 ,0 ),COLOR00ffff;
放量5至15:STICKLINE(换手>5 AND 换手<=15,0,换手,8,0),COLOraa00bb;//粉红色柱线
STICKLINE(换手>5 AND 换手<=15,0,换手,6.6,0),COLORbb11bb;
STICKLINE(换手>5 AND 换手<=15,0,换手,4.4,0),COLOrcc22bb;
STICKLINE(换手>5 AND 换手<=15,0,换手,3.3,0),COLORdd33bb;
STICKLINE(换手>5 AND 换手<=15,0,换手,2.2,0),COLORee44bb;
STICKLINE(换手>5 AND 换手<=15,0,换手,1.1,0),COLORff55bb;
巨量大于15:STICKLINE(换手>15 ,0,换手,8,0 ),COLOR0000aa;//红色柱线
STICKLINE(换手>15 ,0,换手,6.6 ,0 ),COLOR0000bb;
STICKLINE(换手>15 ,0,换手,4.4 ,0 ),COLOR0000cc;
STICKLINE(换手>15 ,0,换手,3.3 ,0 ),COLOR0000dd;
STICKLINE(换手>15 ,0,换手,2.2 ,0 ),COLOR0000ee;
STICKLINE(换手>15 ,0,换手,1.1 ,0 ),COLOR0000ff;
{
资金异动:换手/MA(换手,55)*100,COLORYELLOW,LINETHICK0;
STICKLINE(资金异动>100 ,0,换手,0.6,0),COLORBLACK;}
{www.gupang.com 股旁网_飞狐股票指标公式}
hs:=FLOOR(SUM(v,0)/CAPITAL);
a:=IF(hs>0,hs,0);
aa:=IF(a-REF(a,1)>0,a,0);
▲完全换手:DRAWICON(aa>0,0,8),Color0000FF;//计算个股完全换手周期,也就从上一个红三角到下一次红三角之间实现了一次近似100%的换手
b:=DATACOUNT-BARPOS+1;
Wb:=BARSLAST(SYSPARAM(1)=BARPOS)+1;
换手率1:=SUM(换手,Wb);
累计换手:=REFX(换手率1,Wb[DATACOUNT]-1);//倒算累计换手
DRAWTEXT(SYSPARAM(1)=BARPOS,hhv(换手,1),'累计'+NUMTOSTR(b[SYSPARAM(1)],0)+'天'+'换手: '
+NUMTOSTR(累计换手[SYSPARAM(1)],2)+'% '),ALIGN2,{Color00AAAA}COLORYELLOW;//显示倒算累计换手的日线时间和累计换手率
VERTLINE(SYSPARAM(1)=BARPOS),LINEDOT,Color808080;
VERTLINE(SYSPARAM(3)=BARPOS and b),LINEDOT,Color808080;//取点位置,显示为垂直虚线段

飞狐游子换手指标公式

 

相关文章