在线检测未来函数

大智慧OBV正向收阳量指标公式

来源:Internet,编辑:股旁网,2012-05-31

N:=10;
DRAWGBKLAST(CLOSE>0,STRIP(RGB(50,60,120),RGB(0,40,40),0));
OBVV:=MA(SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),-VOL,0)),0)/1000,1);
OBV:=(17*OBVV+14*ref(OBVV,1)+13*ref(OBVV,2)+13*ref(OBVV,3)+13*ref(OBVV,4)
+12*ref(OBVV,5)+11*ref(OBVV,6)+9*ref(OBVV,7)+8*ref(OBVV,8)+7*ref(OBVV,9)+6*ref(OBVV,10)+5*ref(OBVV,11)+4*ref(OBVV,12)
+3*ref(OBVV,13)+2*ref(OBVV,14)+ref(OBVV,15))/712;
收阳量:=REF(obv,1) - REF(obv,2);
收阳量B:(obv - ema(obv,3));
收阳:WMA(收阳量B,1);
收阳DEAB:SMA(收阳,6,4),Color800080;
收阳DEAC :WMA(WMA(收阳量B,3),3),COLORFFAA55;
收阳DEAD :WMA(WMA(收阳量B,45),5);
收阳DEAQ :WMA(WMA(收阳量B,72),5),Color8000FF;
收阳量C:=0.5*(obv - ema(obv,3));
{www.gupang.com 股旁网_大智慧股票指标公式}
STICKLINE(收阳量C>0 AND 收阳量C>REF(收阳量C,1),0,收阳量C,0,0),Color0000FF;
STICKLINE(收阳量C>0 AND 收阳量C<=REF(收阳量C,1),0,收阳量C,0,1),ColorF7007B;
STICKLINE(收阳量C<0 AND 收阳量C<=REF(收阳量C,1),0,收阳量C,0,0),Color80FFFF;
STICKLINE(收阳量C<0 AND 收阳量C>REF(收阳量C,1),0,收阳量C,0,1),Color008000;
UP:0;
当日:=VOL;
量5:=MA(VOL,5);
量10:=MA(VOL,10);
VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),Color0000FF,LINETHICK0;
主动卖盘:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),Color00E521,LINETHICK0;
买卖盘比:=主动买盘/主动卖盘;
partline(收阳,收阳<=收阳DEAB,rgb(255,255,255),收阳>ref(收阳,1),RGB(255,255,0),1,RGB(255,0,0)),linethick1;

大智慧OBV正向收阳量指标公式

 

相关文章