在线检测未来函数

编写30分钟K线选股公式

来源:Internet,编辑:股旁网,2012-05-15

编写要求:

股旁网解答:

 网友求助:

学生不懂公式,现向各位老师求一公式:
1.30分钟K线的macd已经金叉。
2.30分钟K线的K线站在5单位均线上
3.30分钟K线的开盘价大于等于前两个30分钟收盘价
4.30分钟K线的换手率是前一K线的两倍以上,或者成交量是前一K线的两倍以上。
该公式能用于盘中预警最好。先谢谢各位老师(这里的开盘价指每根K线的开出价格)
 
 
解答如下:
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=(DIF-DEA)*2;
AA:=CROSS(DIF,DEA);

MA5:=MA(C,5);
BB:=CROSS(C,MA5);
CC:=O>=REF(C,1) OR C>=REF(C,2);
换手率:=VOL/CAPITAL*100;
DD:=换手率>REF(换手率,1)*2;
AA AND BB AND CC AND DD;
 

 

相关文章