在线检测未来函数

大智慧DDX特别版指标公式

来源:Internet,编辑:股旁网,2012-06-03

N:=20;JJ:=(HIGH+LOW+CLOSE)/3;QJ0:=VOL/IF(HIGH=LOW,4,HIGH-LOW);
QJ1:=IF(CAPITAL=0,QJ0*(JJ-MIN(CLOSE,OPEN)),QJ0*IF(HIGH=LOW,1,(MIN(OPEN,CLOSE)-LOW)));
QJ2:=IF(CAPITAL=0,QJ0*(MIN(OPEN,CLOSE)-LOW),QJ0*IF(HIGH=LOW,1,(JJ-MIN(CLOSE,OPEN))));
QJ3:=IF(CAPITAL=0,QJ0*(HIGH-MAX(OPEN,CLOSE)),QJ0*IF(HIGH=LOW,1,(HIGH-MAX(OPEN,CLOSE))));
QJ4:=IF(CAPITAL=0,QJ0*(MAX(CLOSE,OPEN)-JJ),QJ0*IF(HIGH=LOW,1,(MAX(CLOSE,OPEN)-JJ)));
DDX:((QJ1+QJ2)-(QJ3+QJ4))/IF(CAPITAL=0,1000000,10000),COLOR00AAAA,LINETHICK0;
DX:=MA(DDX,5)*N;
STICKLINE(DDX>0,0,DDX,3,0),COLOR000088;
STICKLINE(DDX>0,0,DDX,2.5,0),COLOR0000AA;
STICKLINE(DDX>0,0,DDX,1.5,0),COLOR0000CC;
STICKLINE(DDX>0,0,DDX,1,0),COLOR0000EE;
STICKLINE(DDX<0,0,DDX,3,0),COLOR008800;
STICKLINE(DDX<0,0,DDX,2.5,0),COLOR00AA00;
STICKLINE(DDX<0,0,DDX,1.5,0),COLOR00CC00;
STICKLINE(DDX<0,0,DDX,1,0),COLOR00EE00;
DDX1:SMA(DX,3,1),COLORFFFFFF;
DDX2:SMA(DDX1,3,1),COLOR00FFFF;
DDX3:EMA(DDX2,5),COLORFF00FF;
预警:if(DDX>0 AND MA(V,5)>MA(MA(V,5),5) AND CROSS(DDX1,DDX2),8,0),COLORRED,LINETHICK1;
天:=COUNT(DDX>0,5);
DRAWTEXT(预警,DDX*1.06,'★'),LINETHICK3,COLORRED;
DRAWTEXT(预警,8,'★买'),LINETHICK0,COLORRED;
{拉升资金}
VAR1D:=EMA(CLOSE,3)-EMA(CLOSE,89);
VAR1E:=EMA(VAR1D,21);
VAR1F:=(VAR1D-VAR1E)*10;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);
拉升资金:=IF(VAR1F>0.015,VAR20,0)/45;
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,55);
VAR27:=EMA(VAR26,13);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
{www.gupang.com 股旁网_大智慧股票指标公式}
拉升:if(CROSS(VAR29,0)AND REF(拉升资金,1)=0,8,0),COLORRED;
DRAWTEXT(拉升>0,8,' ←拉升资金'),COLORRED;
{绝佳}
绝佳:if(OPEN > ref(h, 1) AND OPEN / REF(CLOSE,1) >=1.03 AND C > OPEN
AND ref(h, 1) < LOW AND h / c <= 1.01 AND
(CLOSE-REF(CLOSE,4))/REF(CLOSE,4)<0.3,8,0),COLORWHITE ;
DRAWTEXT(绝佳>0,8,' ←绝佳'),COLORWHITE ;
{cyc粘合}
cyc5:=CYC(5);
cyc13:=cyc(13);
cyc34:=cyc(34);
CYC81:=CYC(80);
A7:=MAX(MAX(cyc5,cyc13),MAX(cyc13,cyc34));
A8:=MIN(MIN(cyc5,cyc13),MIN(cyc34,cyc81));
A9:=MIN(MIN(cyc5,cyc13),cyc34);
A10:=MAX(MAX(cyc5,cyc13),cyc34);
DRAWTEXT(FILTER(CYC81>REF(CYC81,2)AND REF(CYC5,3)<REF(CYC34,3)AND C>O AND(A10-A9)/A9<0.005,5),8,'★cyc粘合'),COLORYELLOW;
cyc粘合:if(FILTER(CYC81>REF(CYC81,2)AND REF(CYC5,3)<REF(CYC34,3)AND C>O AND(A10-A9)/A9<0.005,5),8,0),COLORYELLOW;

大智慧DDX特别版指标公式

 

相关文章