在线检测未来函数

通达信北斗星指标公式

来源:Internet,编辑:股旁网,2012-06-03

VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR2:=SMA(ABS(LOW-VAR1),13,1)/SMA(MAX(LOW-VAR1,0),10,1);
VAR3:=EMA(VAR2,10);
VAR4:=LLV(LOW,33);
VAR5:=EMA(IF(LOW<=VAR4,VAR3,0),3) ;
低进:IF(VAR5>REF(VAR5,1),0,VAR5),COLORRED,NODRAW;
STICKLINE(VAR5>REF(VAR5,1),VAR5,0,3,1 ),COLORRED;
洗盘:IF(VAR5<REF(VAR5,1),VAR5,0),COLORGREEN,NODRAW;
STICKLINE(VAR5<REF(VAR5,1),0,VAR5,3,1),COLORGREEN;
VAR12:=SMA(ABS(VAR1-H),13,1)/SMA(MAX(VAR1-H,0),10,1);
VAR13:=EMA(VAR12,10);
VAR14:=HHV(H,33);
VAR15:=EMA(IF(H>=VAR14,VAR13,0),3);
高出:IF(VAR15<REF(VAR15,1),VAR15,0),COLORYELLOW,POINTDOT,LINETHICK0;
STICKLINE(VAR15<REF(VAR15,1),0,VAR15,3,1),COLORFF9933;
冲顶:IF(VAR15>REF(VAR15,1),VAR15,0),COLORFF00FF,POINTDOT,LINETHICK0;
STICKLINE(VAR15>REF(VAR15,1),0,VAR15,3,1),COLORYELLOW;
A1:=REF(CLOSE,2);
A2:=SMA(MAX(CLOSE-A1,0),7,1)/SMA(ABS(CLOSE-A1),7,1)*100;
波段介入点:=IF(A2<19,19,0)COLORWHITE;
VARC:=SMA(ABS(L-REF(L,1)),3,1)/SMA(MAX(L-REF(L,1),0),3,1);
观注点:=EMA(IF(L<= LLV(L,30),VARC,0),3),COLORLIRED,LINETHICK2;
北斗导航线1: MA(3*SMA((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100,5,1),3,1),5),COLORYELLOW;
北斗导航线2: MA(3*SMA((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100,5,1),3,1),5),COLORYELLOW;
安全云区: 5, , COLORYELLOW;
北斗异动:= IF(北斗导航线2<=5,50,0),COLORGREEN;
北斗星出击: IF(CROSS(北斗导航线2,安全云区),100,0),COLORRED;
北斗星买点: 北斗星出击,COLORRED;
DRAWTEXT(北斗导航线2,50,'北斗星买点'), , COLORRED;
DRAWICON(北斗导航线2,50,1);
IF(北斗导航线2>REF(北斗导航线2,1),北斗导航线2,DRAWNULL),COLORRED;
IF(北斗导航线2<REF(北斗导航线2,1),北斗导航线2,DRAWNULL),COLORBLUE;
{www.gupang.com 股旁网_通达信股票指标公式}
IF(北斗导航线1>REF(北斗导航线1,1),北斗导航线1,DRAWNULL),COLORRED;
IF(北斗导航线1<REF(北斗导航线1,1),北斗导航线1,DRAWNULL),COLORBLUE;
DRAWTEXT(ISLASTBAR,北斗导航线1*1,'1'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,北斗导航线2*1,'2'),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=5,北斗导航线2*1.0,'5');
DRAWTEXT(CURRBARSCOUNT=10,北斗导航线2*1.0,'10');
DRAWTEXT(CURRBARSCOUNT=15,北斗导航线2*1.0,'15');
DRAWTEXT(CURRBARSCOUNT=20,北斗导航线2*1.0,'20');
DRAWTEXT(CURRBARSCOUNT=30,北斗导航线2*1.0,'30');
DRAWTEXT(CURRBARSCOUNT=40,北斗导航线2*1.0,'40');
DRAWTEXT(CURRBARSCOUNT=50,北斗导航线2*1.0,'50');
DRAWTEXT(CURRBARSCOUNT=60,北斗导航线2*1.0,'60');
DRAWTEXT(CURRBARSCOUNT=75,北斗导航线2*1.0,'75');
DRAWTEXT(CURRBARSCOUNT=90,北斗导航线2*1.0,'90');
DRAWTEXT(CURRBARSCOUNT=110,北斗导航线2*1.0,'110');
DRAWTEXT(CURRBARSCOUNT=120,北斗导航线2*1.0,'120');

通达信北斗星指标公式

 

相关文章