在线检测未来函数

同花顺跟着主力走指标公式

来源:Internet,编辑:股旁网,2012-06-04

DRAWGBK(DATE>900101,STRIP(RGB(100,0,0),RGB(30,30,0),1));
Var1:=EMA(HHV(HIGH,500),21);
Var2:=REF(LOW,1);
Var3:=SMA(ABS(LOW-Var2),3,1)/SMA(MAX(LOW-Var2,0),3,1)*100;
Var4:=EMA(IF(CLOSE*1.3,Var3*10,Var3/10),3);
Var5:=LLV(LOW,30);
Var6:=HHV(Var4,30);
Var7:=IF(MA(CLOSE,58),1,0);
Var8:=EMA(IF(LOW<=Var5,(Var4+Var6*2)/2,0),3)/618*Var7;
Var9:=IF(Var8>100,100,Var8);
VarA:=EMA((Var7*3+Var8*2+Var9)/6*1.738,21);
VarB:=REF(LOW,1);
VarC:=SMA(ABS(LOW-VarB),3,1)/SMA(MAX(LOW-VarB,0),3,1)*100;
//{www.gUPaNg.com 股旁网_同花顺股票指标公式}
VarD:=EMA(IF(CLOSE*1.35<=VarA,VarC*10,VarC/10),3);
VarE:=LLV(LOW,30);
VarF:=HHV(VarD,30);
Var10:=IF(MA(CLOSE,58),1,0);
V1:=MA(100*(C-LLV(C,34))/(HHV(H,34)-LLV(L,34)),5)-20;
V2:=2*ABS(V1);
V3:=100-(100-3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,20,1)+2*SMA(SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,20,1),15,1));
V4:=100-(100-3*SMA((O-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,20,1)+2*SMA(SMA((O-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,20,1),15,1));
V5:=(H+L+C)/3;
V6:=(V5-MA(V5,10))/(0.015*AVEDEV(V5,10));
V7:=(V5-MA(V5,30))/(0.015*AVEDEV(V5,30));
V8:=IF(V6>=150 AND V6<200 AND V7>=150 AND V7<200,10,0);
V9:=IF(V6<=-150 AND V6>-200 AND V7<=-150 AND V7>-200,-10,V8);
VA:=(C-MA(C,13))/MA(C,13)*100;
VB:=100-ABS(VA);
VE:=REF(L,1)*0.9;
VF:=L*0.9;
V10:=(VF*V+VE*(CAPITAL-V))/CAPITAL;
V11:=EMA(V10,30);
V12:=V11-C;
V13:=REF(C,1);
V14:=SMA(MAX(C-V13,0),7,1)/SMA(ABS(C-V13),7,1)*100;
V15:=SMA(MAX(C-V13,0),13,1)/SMA(ABS(C-V13),13,1)*100;
V16:=BARSCOUNT(C);
V17:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
V18:=((-100)*(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))+50)*2;
V19:=(C-LLV(L,15))/(HHV(H,15)-LLV(L,15))*100;
V1A:=(SMA(V19,4,1)-50)*2;
V1B:=SMA(V1A,3,1);
V1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
V1D:=SMA(V1C,4,1);
V1E:=SMA(V1D,3,1);
V1F:=(HHV(H,30)-C)/C*100;
V20:=IF(V17<=25 AND V18<-95 AND V1F>20 AND V1B<-30 AND V1E<30
AND V12>=-0.25 AND V14<22 AND V15<28 AND V16>50,80,0);
准备拉升: EMA(IF(LOW<=VarE,(VarD+VarF*2)/2,0),3)/618*Var10;
准备拉升: IF(准备拉升>0,准备拉升,0),STICK,linethick2, COLOR0000ff;
今量: 准备拉升;
A1:IF(准备拉升>0,今量*1.2,0),STICK,linethick5, COLOR0000ff;
A2:IF(准备拉升>0,今量*0.8,0),STICK,linethick5, COLOR0066ff;
A3:IF(准备拉升>0,今量*0.6,0),STICK,linethick5, COLOR0099ff;
A4:IF(准备拉升>0,今量*0.4,0) ,STICK,linethick5,COLOR00ccff;
A5:IF(准备拉升>0,今量*0.2,0) ,STICK,linethick5,COLOR00ffff;
先知: (CLOSE-MA(CLOSE,25))/MA(CLOSE,25)*100, , colorff00ff;
SSS:=(VAR3 AND VAR4 AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)>-0.07 OR VAR5 AND VAR6 AND CROSS(VAR7,79) OR VARC AND CLOSE/COST(8)<=0.8)*100;
抄底王:SSS>0,colorwhite,LINETHICK1;
主力SK1:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), colormagenta,linethick2;
均量SD1:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),colorgreen,linethick2;
生命线:85,linethick1,coloryellow;
生命禁区:75,linethick1,colorred;
预警系统: (IF((V7>=200 AND V6>=150) OR CROSS(65,主力SK1),15,IF(V7<=-200
AND V6<=-150,-15,V9))+65);
T2:=C; T3:=主力SK1>60 AND 预警系统>85 AND 生命线=95;
T4:=主力SK1>48 AND 预警系统>85 AND 生命线<95;
T5:=均量SD1<-38 AND 预警系统<85;
T6:=抄底王>50 AND 生命线<90;
T7:=V3>REF(V4,1) AND V>REF(V,1) AND C>REF(C,1);
DRAWTEXT(CROSS(主力SK1,生命禁区),60,'警惕!! '),colorcyan;
DRAWTEXT(CROSS(主力SK1,生命禁区),85,'减磅'),ColorFF6800;
DRAWTEXT(CROSS(主力SK1,生命禁区),75,'▼注意.SK1向上持有.向下立即卖出'),colorblue ;
DRAWTEXT(T2 AND COUNT(T2,30)=1,55,'下降通道!'),COLOR00FFFF;
DRAWTEXT(T3 AND COUNT(T3,30)=1,55,'上涨过急!'),COLOR00FFFF;
DRAWTEXT(T4 AND COUNT(T4,30)=1,75,'庄家出货!'),COLOR00FFFF;
DRAWTEXT(T5 AND COUNT(T5,30)=1,50,'有小反弹!'),COLOR00FFFF;
DRAWTEXT(T6 AND COUNT(T6,30)=1,30,'抢反弹!'),COLOR00FFFF;
DRAWTEXT(T7 AND COUNT(T7,30)=1,30,'资金进场!'),COLOR00FFFF; DRAWGBK(DATE>900101,STRIP(RGB(100,0,0),RGB(30,30,0),1));
AA1:=AMOUNT/V;BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;DD1:=L<MA(C,5)*0.921;EE1:=V<MA(V,5)*1.5;
FF1:=BB1 AND CC1 AND DD1 AND EE1;DRAWTEXT(FF1,(LOW* 0.99),'老鼠仓'),COLOR4080FF;

同花顺跟着主力走指标公式

 

相关文章