在线检测未来函数

通达信涨跌分离线主图指标公式

来源:Internet,编辑:股旁网,2012-06-04

EMA3:EMA(CLOSE,3);
MA5:EMA(CLOSE,5);
H均线:=(5*H+4*REF(H,1)+3*REF(H,2)+2*REF(H,3)+1*REF(H,4))/(5+4+3+2+1);
L均线:=(5*L+4*REF(L,1)+3*REF(L,2)+2*REF(L,3)+1*REF(L,4))/(5+4+3+2+1);
WHK涨跌分离线:=IF(C>REF(H均线,1),L均线,IF(C<REF(L均线,1),H均线,L均线)),COLORLIBLUE ;
跌线:IF(WHK涨跌分离线<REF(WHK涨跌分离线,1),WHK涨跌分离线,DRAWNULL),COLORLIBLUE,LINETHICK2;
涨线:IF(WHK涨跌分离线>REF(WHK涨跌分离线,1),WHK涨跌分离线,DRAWNULL),COLORMAGENTA,LINETHICK3;
看多就买:C>WHK涨跌分离线,NODRAW,COLOR0000FF;
看空全抛:C<=WHK涨跌分离线,NODRAW,COLOR00FF00;
看空周期:=BARSLAST(看多就买);
看多周期:=BARSLAST(看空全抛);
开始试买:=看多周期1.25,COLOR00FFFF,NODRAW;
全部抛掉:=看空周期0.25,COLORBLUE,NODRAW;
{www.gupang.com 股旁网_通达信股票指标公式}
止损水平线:IF(看多周期>看空周期,REF(C,看多周期),REF(C,看空周期)),COLOR0099FF;
IF(看多就买,止损水平线,DRAWNULL),COLORRED,POINTDOT,LINETHICK4;
IF(看空全抛,止损水平线,DRAWNULL),COLOR00FF00,POINTDOT,LINETHICK4;
STICKLINE(C>WHK涨跌分离线,H,L,0,0),COLORRED;
STICKLINE(C>WHK涨跌分离线,O,C,2.8,0),COLORRED;
STICKLINE(C>WHK涨跌分离线 AND C<O,O,C,2.8,1),COLORRED;
STICKLINE(C<=WHK涨跌分离线,H,L,0,0),COLOR00FF00;
STICKLINE(C<=WHK涨跌分离线,O,C,2.0,-1),COLOR00FF00;
STICKLINE(C<=WHK涨跌分离线 AND C>O,O,C,2.8,1),COLOR00FF00;
STICKLINE(开始试买,O,(C+O)/2,3.0,3),COLORWHITE;
STICKLINE(全部抛掉,O,(C+O)/2,3.0,-1),COLORBLUE;
Y1:=REF(EMA(DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9),3),1);
STICKLINE(CROSS(Y1,CLOSE),H*1.05,H,5,0),COLORWHITE;
{DRAWTEXT(CROSS(Y1,CLOSE),HIGH*1.05,'[卖出]'),COLORWHITE};
VAR1W:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR2W:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));
VAR3W:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
DRAWTEXT(CROSS(VAR2W,MA(VAR3W,6)),LOW -0.6,'(买)'),COLORFF99FF;
{DRAWTEXT(CROSS(MA(VAR3W,6),VAR1W),HIGH +0.9,'(卖)'),COLORCCFF13};
VAR3P:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);
STICKLINE(VAR3P>90,L,L*0.95,5,0),COLORYELLOW;
DRAWTEXT(VAR3P>90,LOW*0.95,'追涨'),COLORFF00FF;
SS:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);
SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;
MR:=SC AND COUNT(SS,2);
买:=MR AND NOT(REF(MR,1));
STICKLINE(买,L,L*0.95,5,0),COLORYELLOW;
DRAWTEXT(买,L*0.95, '必涨'),COLORRED;
多方:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)
-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)
,3,1),2,1);
STICKLINE(CROSS(78.89,多方),H+1.06,H,2,0),COLORBLUE;
DRAWTEXT(CROSS(78.89,多方),H+1.06,'(逃顶)'),COLORRED;
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1);
A2:=(EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*1;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;
DRAWTEXT(CROSS(A1,EMA(A1,5))AND EMA(A1,5)<A5,L*0.98,'(黑马)'),COLORYELLOW;
VAR1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*1;
VAR2:=SMA(VAR1,3,1)*100;
趋势线:=SMA((SMA(VAR2,3,1)*VAR1),3,1)*1;
VAR9:=CROSS(趋势线,(SMA(VAR2,3,1)*VAR1)) AND (SMA(VAR2,3,1)*VAR1)>8;
DRAWTEXT(VAR9 AND COUNT(VAR9,1)=1,H+0.6,'逃'), LINETHICK2,COLORMAGENTA;
DRAWICON(FILTER(CROSS(-"WR.WR1"(14,14),(0 - 81)),10),L-0.2,13);
DRAWICON(FILTER(CROSS((0 -19),-"WR.WR1"(14,14)),10),H,14);

通达信涨跌分离线主图指标公式

 

相关文章