在线检测未来函数

飞狐寻庄RSI指标公式

来源:Internet,编辑:股旁网,2012-06-09

n1:=16;P:=5;
LC := REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),n1/2,1)/SMA(ABS(CLOSE-LC),N1/2,1)*100,COLORWHITE;
RSI1:SMA(MAX(CLOSE-LC,0),n1,1)/SMA(ABS(CLOSE-LC),N1,1)*100,COLORRED,LINETHICK2;
RSI2:=SMA(MAX(CLOSE-LC,0),n1*2,1)/SMA(ABS(CLOSE-LC),N1*2,1)*100,COLORAAAA00;
PARTLINE(RSI1<50,rsi1),COLOR00bb00,LINETHICK2;
趋势:=Ema(RSI,N1/3),COLORYELLOW,LINEDOT;
中趋势:Ema(RSI1,N1/2),COLORAAAA00,COLORMAGENTA,LINEDOT;
A1:=REF(RSI1,P)=HHV(RSI1,2*P+1);
B1:=FILTER(A1,P);
C1:=BACKSET(B1,P+1);
D1:=FILTER(C1,P);{高点}
A2:=REF(RSI1,P)=LLV(RSI1,2*P+1);
B2:=FILTER(A2,P);
C2:=BACKSET(B2,P+1);
D2:=FILTER(C2,P);{低点}
上:REF(RSI1,BARSLAST(D1)),COLORFF00FF,LINETHICK;
下:REF(RSI1,BARSLAST(D2)),COLOR00FF00,LINETHICK;
向上:CROSS(RSI1,上*1.01),LINETHICK;
相对能量:(RSI1-(上+下)/2)/(上+下)/2*100,LINETHICK;
STICKLINE(相对能量>0,50,相对能量+50,2,0),COLORRED;
STICKLINE(相对能量<0,50,相对能量+50,2,0),COLORCYAN;
{www.gupang.com 股旁网_飞狐股票指标公式}
R11:=BACKSET(ISLASTBAR,BARSLAST(D1)+1);
S11:=R11>REF(R11,1);
DRAWLINE(D1,RSI1,S11,RSI1,1),COLORYELLOW;
T11:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
U11:=T11>REF(T11,1);
DRAWLINE(D2,RSI1,U11,RSI1,1),COLOR00FF00;
STICKLINE(C>0,下,下,1,0),COLOR00FF00;
STICKLINE(C>0,上,上,1,0),COLORFF00FF;
DRAWTEXT(CROSS(RSI1,上*1.01),上,'★'),COLORRED,ALIGN0;
DRAWTEXT(CROSS(下*0.99,RSI1),下,'★'),COLORGREEN,ALIGN0;
DRAWICON(D1,RSI1,2);
DRAWICON(D2,RSI1,1);
20;50;80;

飞狐寻庄RSI指标公式

 

相关文章