在线检测未来函数

通达信寻庄MACD指标公式

来源:Internet,编辑:股旁网,2012-06-09

N:=14;
均价:=(2*C+(H-L)/2+L)/3;
价差:=SUM(均价-REF(均价,1),2)/2;
高低:=(均价+价差);
实价:=(高低+均价)/2;
ED1:=(2*C-2*REF(C,2)+REF(C,1));
ED2:=(2*C-0.4*REF(C,4)-0.4*REF(C,3)-1.1*REF(C,2)+0.9*REF(C,1));
操盘线:=SMA(SMA(ED1,3,1),3,1);
AA:=EMA(((SLOPE(实价,N)*20)+实价),N*3),COLORYELLOW;
BB:=EMA(((SLOPE(均价,N)*20)+均价),N*3),COLORYELLOW;
多空线:=(AA+BB)/2,COLORRED;
行情1:=EMA(EMA(EMA((AA+BB)/2,7),21),63),COLORYELLOW,LINETHICK2;
AAA:=EMA(((SLOPE(实价,N*2)*20)+实价),N*6),COLORYELLOW,LINETHICK1;
BBB:=EMA(((SLOPE(均价,N*2)*20)+均价),N*6),COLORYELLOW,LINETHICK1;
{www.gupang.com 股旁网_通达信股票指标公式}
行情2:=(AAA+BBB)/2,COLORWHITE,LINETHICK2;
行情线:=EMA((行情1+行情2)/2,28),COLOR7F00FF,COLORYELLOW,LINETHICK2;
DDIF:多空线-行情线,COLORRED;
DDEA:MA(DDIF,3),COLORAAAA00;
DMACD:5*(DDIF-DDEA),LINETHICK;
STICKLINE(DMACD>=0,0,DMACD,1,1),COLORYELLOW;
STICKLINE(DMACD<0,0,DMACD,1,1),COLORGRAY;
DRAWBAND(DDIF,RGB(120,0,100),DDEA,RGB(0,100,50));
DIF:操盘线-行情线,COLORWHITE;
DEA:MA(DIF,3),COLORGREEN;
MACD:3*(DIF-DEA),COLORSTICK,LINETHICK2;
天:HHV(MA(DIF,1),56/2),COLOR7F00FF;
地:LLV(MA(DIF,1),56/2),COLOR00AA99;
0;

通达信寻庄MACD指标公式

 

相关文章