在线检测未来函数

通达信人工智能指标公式

来源:Internet,编辑:股旁网,2012-06-09

VAR1:=(C-EMA(C,7))/EMA(C,7);
VAR2:=EMA(EMA(VAR1,3),3);
VAR3:=EMA(EMA(VAR1,3),2);
VAR4:=100*( VAR2+ VAR3);
VAR5:=EMA(VAR4,2.5);
BI:=100*(H+L)/2/EMA(C,17)-100;
BUY1:=VAR4>REF(VAR4,1) AND REF(VAR4,1)<REF(VAR4,2) AND REF(VAR4,2)<REF(VAR4,3);
BUY2:=REF(BI,1)>0 AND BUY1 AND VAR4<-2;
BUY3:=REF(BI,1)<0 AND BUY1 AND REF(VAR4,1)<-3;
BUY4:=VAR4<0 AND CROSS(VAR4,VAR5) AND BUY1;
BUY:=(BUY2 OR BUY3 OR BUY4) AND (EMA(INDEXC,5)>REF(EMA(INDEXC,5),1) OR VAR4>=REF(VAR4,1));
DRAWICON(BUY,-130,14);
100;
主力:EMA( (CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2)*5,COLORGREEN,LINETHICK3;
散户:=EMA( (CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7)*5;
BT2:=CROSS(主力,散户) AND 主力<-10;
DRAWICON(CROSS(主力,散户) AND 主力<-10,主力,23);
IF(主力>=REF(主力,1),主力,DRAWNULL),COLORRED,LINETHICK3;
IF(主力<=REF(主力,1),主力,DRAWNULL),COLORGREEN,LINETHICK3;
BB:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主买:主动买/10000,COLORRED,LINETHICK0;
{www.gupang.com 股旁网_通达信股票指标公式}
主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));
主卖:-主动卖/10000,COLORGREEN,LINETHICK0;
参与度:主买/(主买+主卖),LINETHICK0;
单日换手:=100*V/CAPITAL,LINETHICK0;
十日换手:SUM(单日换手,10),LINETHICK0;
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖离:=MA(BIAS,10);
STICKLINE(((CROSS(BIAS,乖离)AND 乖离<-3)),80,98,2,0),COLORRED;
DRAWTEXT((CROSS(BIAS,乖离)AND 乖离<-3),130,'变盘'),COLORWHITE;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
顶部:=CROSS(80,RSI)*35;
逃顶:=顶部;
顶:=IF(逃顶>REF(逃顶,1),35,0);
DRAWTEXT(顶=35,170,'逃顶'),COLOR00FF00;
STICKLINE(顶部,90,0,1,0),COLORGREEN;
VOLUME:=VOL;
主力启动线:=MA(VOLUME,5);
主力洗盘线:=MA(VOLUME,35);
资金异动线:=MA(VOLUME,135);
诱多:STICKLINE(CROSS(主力启动线,资金异动线) OR ((主力洗盘线 > 资金异动线) AND CROSS(主力启动线,主力洗盘线)),100,-3,0.5,0),COLORFFFF00;
DRAWTEXT(诱多,130,'骗钱'),COLORFFFF00;
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),6,1)/SMA(ABS(CLOSE-REF(C,1)),6,1)*100;
{DRAWICON(CROSS(82,VARR1),180,15); }
DRAWTEXT(CROSS(82,VARR1),150,'逃'),COLORYELLOW;
BIASW:=(CLOSE-MA(CLOSE,10))/MA(CLOSE,10)*10;
狗:=(REF(DOWNNDAY(CLOSE,3),1) AND C>REF(C,1) AND BIASW>=REF(BIASW,1));
DRAWTEXT(狗,160,'金牛'),COLORYELLOW;
STICKLINE(狗,100,-5,0.5,0),COLORYELLOW;
MAN:=MA(C,3);MA10:=MA(C,10);MA20:=MA(C,20);MA30:=MA(C,30);MA60:=MA(C,60);
D1:=(MAN-MA10)/MIN(MAN,MA10);
D2:=(MAN-MA20)/MIN(MAN,MA20);
D3:=(MAN-MA30)/MIN(MAN,MA30);
D5:=(MA20-MA10)/MIN(MA20,MA10);
D6:=(MA30-MA10)/MIN(MA30,MA10);
D8:=(MA20-MA30)/MIN(MA20,MA30);
DB:=MA(MIN(MIN(MIN(D1,D2),MIN(D3,D5)),MIN(D6,D8))*100,2);
GJ:=(2*C+H+L)/4;
底:=DB<-10 AND GJ<MA30 AND REF(DB,1)<MIN(REF(DB,2),DB);
DRAWTEXT(底 AND COUNT(底,BARSLAST(NOT(DB<-10 AND GJ<MA30)))=1,160,'抄底'),COLORMAGENTA;
AAWW:=C-MA(C,6);
吗:=0;
DRAWICON(CROSS(AAWW,吗),90,17);
TJ1:=COUNT((C<O),5)>=3;
TJ2:=(MIN(C,O)-L)/(H-L)>=0.5;
TJ3:=L/MIN(C,O)<=0.97;
TJ4:=(C-MA(C,30))/MA(C,30)*100<-10;
长下影买:=TJ1 AND TJ2 AND TJ3 AND TJ4;
STICKLINE(长下影买,-150,0,0.3,0),COLORFF00FF;
DRAWTEXT(长下影买>0,-80,'长下影买'),COLORF8FFFF;
弱转强:=CROSS(CCI,-200) AND CCI>REF(CCI,1);
STICKLINE(弱转强,80,90,2,0),COLORWHITE;
DRAWTEXT(弱转强,110,'出击'),COLORYELLOW;
DIFF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEAP:=EMA(DIFF,9),COLORFFFF00;
MACD:=(DIFF-DEAP)*2;
A1:=BARSLAST(REF(CROSS(DIFF,DEAP),1));
AR1:=REF(CLOSE,1);
AR2:=SMA(MAX(CLOSE-AR1,0),7,1)/SMA(ABS(CLOSE-AR1),7,1)*100;
特准:STICKLINE(FILTER(REF(AR2,1)<20 AND AR2>REF(AR2,1),5),60,0,2,0),COLOR0066FF;
DRAWTEXT(特准,35,'←绝杀'),COLORWHITE;
增减力度:=(MA(CLOSE,34.000) - CLOSE) / MA(CLOSE, 34.000) * 10.000;
STICKLINE(CROSS( 1.700,增减力度), 75,30, 1,0),COLORWHITE;
DRAWTEXT(CROSS( 1.700,增减力度), 100,'底'),COLORWHITE;
STICKLINE(FILTER(CROSS(0.019100,增减力度),21),120,50, 1,0),COLORFFFF00;
DRAWTEXT(FILTER(CROSS(0.019100,增减力度),21), 150,'小心'),COLORGREEN;
RSI1:=SMA(MAX(CLOSE-LC,0),6,1)/SMA(ABS(CLOSE-LC),6,1)*100;
BT1:=CROSS(RSI1,25);
STICKLINE(BT1,30,50,3,0),COLORFF00FF;
DRAWTEXT(BT1,75,'反弹'),COLORYELLOW;
短线获利:STICKLINE(REF("KDJ.J",1)<0 AND "KDJ.J">0,80,-50,0.3,0),COLOR0000FF;
DRAWTEXT(REF("KDJ.J",1)<0 AND "KDJ.J">0,50,'短买'),COLORWHITE;
AA:=EMA(C,5)-EMA(C,13);
BBP:=EMA(AA,3);
X:=AA>REF(AA,1); Y:=REF(AA,3)>=REF(AA,2);Z:=REF(AA,2)>=REF(AA,1);Z1:=AA<BBP;
注意:=X AND Y AND Z AND Z1 ;
DRAWTEXT(注意,1,'启动!'),COLORYELLOW;
DRAWICON(注意,10,1);
OSC:=100*(CLOSE-MA(CLOSE,20));
MAOSC:=EXPMEMA(OSC,6);
BIASWP:=(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100;
BIASMA:=MA(BIASWP,6);
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
LIN:=IF(P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1,1,0);
DRAWICON(LIN,120,5);
SS1:=CROSS(OSC,MAOSC) AND LIN;
DRAWTEXT(SS1,-45,'<=抢反弹'),COLORFFFF22;
STICKLINE(SS1,-70,0,1,1),COLOR00FFFF;
SS:=CROSS(OSC,MAOSC) AND CROSS(BIASWP,BIASMA) AND LIN;
DRAWTEXT(SS,-100,'<=激进淘金'),COLORFF00FF;
STICKLINE(SS,-150,0,0.3,0),COLORRED;
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
STICKLINE(B2>0,-100,-80,2,0),COLORFF00FF;
DRAWTEXT(B2>0,-80,'←启动'),COLORYELLOW;
STICKLINE(B3>0,-80,-60,2,0),COLORYELLOW;
DRAWTEXT(B3>0,-60,'←走强'),COLORYELLOW;
FL:=V>REF(V,1) OR V>MA(V,5);
SZ:=(CROSS(C,MA(C,3)) OR CROSS(C,MA(C,5))) AND C>=O;
放量上涨:=IF(FL AND SZ,1,0);
STICKLINE(放量上涨,-40,-20,2,0),COLOR00FFFF;
DRAWTEXT(放量上涨,-25,'<=放量上涨'),COLORFF00FF;

通达信人工智能指标公式

 

相关文章