在线检测未来函数

通达信短线狙击手主图指标公式

来源:Internet,编辑:股旁网,2012-06-10

A:=(3*C+H+L+O)/6;
XJ:=(A+0.618*REF(A,1)+0.382*REF(A,2)+0.236*REF(A,3)+0.146*REF(A,4))/2.382;
YCZXH:=(MA(HHV(A,2),5)+MA(HHV(A,2),13)+MA(HHV(A,2),21)+MA(HHV(A,2),32))/4;
YCZXL:=(MA(LLV(A,2),5)+MA(LLV(A,2),13)+MA(LLV(A,2),21)+MA(LLV(A,2),32))/4;
PJ:=(10*A+9*REF(A,1)+8*REF(A,2)+7*REF(A,3)+6*REF(A,4)+5*REF(A,5)+4*REF(A,6)+3*REF(A,7)+2*REF(A,8)+REF(A,9))/55;
A1:=EMA(PJ,3),COLOR004000;A2:=EMA(PJ,5),COLOR004000;
A3:=EMA(PJ,7),COLOR004000;A4:=EMA(PJ,9),COLOR004000;
A5:=EMA(PJ,11),COLOR004000;
LX:=REF(XJ,1);
ZD:=(SMA(MAX(XJ-LX,0),5,1)/SMA(ABS(XJ-LX),5,1))*100;
KX1:=(CLOSE>=OPEN) AND ZD>=50;
KX2:=(CLOSE<OPEN) AND ZD>=50;
KX3:=(CLOSE>=OPEN) AND ZD<50;
KX4:=(CLOSE<OPEN) AND ZD<50;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:=(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
{www.gupang.com 股旁网_通达信股票指标公式}
选股:=PMB AND 密码>REF(密码,1) AND 二日比>1 ,COLORRED,NODRAW;
均价线:=AMOUNT/V/100;
均价线2:=MA(均价线,3);
均价线5:=MA(均价线,5);
均价线10:=MA(均价线,10);
均价线30:=MA(均价线,30);
突破:=C>均价线2 AND 均价线2<REF(均价线2,1) AND REF(均价线2,1)<REF(均价线2,2)
AND REF(均价线2,2)<REF(均价线2,3) AND 选股;
STICKLINE(突破,H,L,5,0),LINETHICK1,COLORRED;
STICKLINE(突破,H,L,0.2,0),COLORYELLOW;
STICKLINE(突破,O,C,2,0),LINETHICK1,COLORYELLOW;
STICKLINE(突破,O,C,3,0),LINETHICK1,COLORMAGENTA;
STICKLINE(突破,H,L,0,1),COLORMAGENTA;
MA1201:MA(CLOSE,120),LINETHICK1,COLORFF8888,POINTDOT;
MA60:MA(CLOSE,60)COLORLIGREEN,LINETHICK1,POINTDOT;
AA1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN)),NODRAW;
主买:IF(CLOSE>OPEN,AA1*(HIGH-LOW),IF(CLOSE<OPEN,AA1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),POINTDOT,COLORRED,NODRAW;
买盘比%:主买/VOL*100,POINTDOT,COLORWHITE,NODRAW;
RSV12:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100,NODRAW;
K11:=SMA(RSV12,3,1),NODRAW;
DD1:=SMA(K11,3,1),NODRAW;
KK1:=INTPART(K11),NODRAW;
STICKLINE(买盘比% >= 85 AND K11<50 AND DD1<50,O,C,3,0)COLORMAGENTA;
STICKLINE(买盘比% >= 85 AND K11<50 AND DD1<50,H,L,0,0)COLORWHITE;
MA10:MA(C,10),COLORYELLOW;
MA20:MA(C,20),COLORMAGENTA;
MA40:MA(C,40),COLORRED;
LC:=REF(CLOSE,1);
RSI5:=((SMA(MAX((CLOSE - LC),0),5,1) / SMA(ABS((CLOSE - LC)),5,1)) * 100);
VARR1:=SMA(MAX(CLOSE-REF(C,1),0),12,1)/SMA(ABS(CLOSE-REF(C,1)),15,1)*100;
TR1:=SUM(MAX(MAX((HIGH - LOW),ABS((HIGH - REF(CLOSE,1)))),ABS((LOW - REF(CLOSE,1)))),10);
HD:=(HIGH - REF(HIGH,1));
LD:=(REF(LOW,1) - LOW);
DMP:=SUM(IF(((HD > 0) AND (HD > LD)),HD,0),10);
DMM:=SUM(IF(((LD > 0) AND (LD > HD)),LD,0),10);
PDI:=((DMP * 100) / TR1);
MDI:=((DMM * 100) / TR1);
ADX:=MA(((ABS((MDI - PDI)) / (MDI + PDI)) * 100),5);
AV:=(RSI5 + ADX);
DXR:=(((ADX + REF(ADX,5)) / 2) + RSI5);
WR10:=((100 * (HHV(HIGH,10) - CLOSE)) / (HHV(HIGH,10) - LLV(LOW,10)));
NEWVOL:=(RSI5 - WR10);

通达信短线狙击手主图指标公式

 

相关文章