在线检测未来函数

飞狐创意CCI主图指标公式

来源:Internet,编辑:股旁网,2012-06-12

AAF:=LLV(LOW,34),LINETHICK1,COLORFFFFCC;
BBF:=MA(AAF,4),LINETHICK1,COLORYELLOW;
TYP := (HIGH + LOW + CLOSE)/3;
CCI1:=(TYP-MA(TYP,6))/(0.015*AVEDEV(TYP,5));
差值1:=ABS(REF(CCI1,1)-CCI1),LINETHICK0;
CCI2:=(TYP-MA(TYP,10))/(0.015*AVEDEV(TYP,10));
差值2:=ABS(REF(CCI2,1)-CCI2),LINETHICK0;
CCI3:=(TYP-MA(TYP,20))/(0.015*AVEDEV(TYP,20));
差值3:=ABS(REF(CCI3,1)-CCI3),LINETHICK0;
CCI4:=(TYP-MA(TYP,30))/(0.015*AVEDEV(TYP,30));
差值4:=ABS(REF(CCI4,1)-CCI4),LINETHICK0;
CCI5:=(TYP-MA(TYP,60))/(0.015*AVEDEV(TYP,60));
差值5:=ABS(REF(CCI5,1)-CCI5),LINETHICK0;
CCI:=CCI1+CCI2+CCI3+CCI4+CCI5;
AAA:=(3*C+H+L+O)/6;
VAR1:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)
+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;
VAR2:=(HHV(VAR1,5)+HHV(VAR1,10)+HHV(VAR1,20))/3;
VAR3:=(LLV(VAR1,5)+LLV(VAR1,10)+LLV(VAR1,20))/3;
VAR4:=(HHV(VAR2,5)+HHV(VAR2,10)+HHV(VAR2,20))/3;
VAR5:=(LLV(VAR3,5)+LLV(VAR3,10)+LLV(VAR3,20))/3;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,6))/3;
短线:=VAR1;
中线:=VAR6;
牛熊线:ma(c,25),LINETHICK2,COLORBLUE;
操盘线:ma(c,8)LINETHICK;
PARTLINE(c>VAR1 or c>var6,VAR1),COLORMAGENTA,LINETHICK2;
PARTLINE(VAR1>VAR6,VAR6),COLORYELLOW,LINETHICK2;
PARTLINE(c<VAR6,VAR1),COLORGREEn,LINETHICK2;
PARTLINE(VAR1>操盘线,操盘线),COLORRED;
{www.gupang.com 股旁网_飞狐股票指标公式}
STICKLINE(c>VAR1,o,c,5,0)COLORRED;
STICKLINE(c>VAR6 and c<VAR1,o,c,5,0)COLORGRAY;
STICKLINE(c<VAR6,o,c,5,0)COLORCYAN;
STICKLINE(cross(操盘线,VAR1) and c<VAR6,o,c,8,0)COLORWHITE;
STICKLINE(cross(操盘线,VAR1) and c<VAR6,h,l,1,0)COLORWHITE;
STICKLINE(VAR1>VAR6 and c<操盘线,h,c,3,0)COLORWHITE;
X1:=(C+L+H)/3;
BB13:=ATAN(EMA(X1,13)-REF(EMA(X1,13),1))*3.1416*10;
EMA8:=EMA(C,8);
DRAWTEXT(FILTER(BB13>1 AND EMA(X1,13)>REF(EMA(X1,8),1),10),
EMA8,'∠45'),COLORWHITE;

飞狐创意CCI主图指标公式

 

相关文章