在线检测未来函数

同花顺股市圈钱机指标公式

来源:Internet,编辑:股旁网,2012-06-13

VarTIME:=IF(YEAR>=9999 AND MONTH>=11 AND DAY>=07,0,1);
VarDTIME:=IF(YEAR=9999 AND MONTH=11 AND DAY=06,1,0);
qw1:=(HIGH+LOW+CLOSE*2)/4*VarTIME;
qw3:=EMA(qw1,10)*VarTIME;
qw4:=STD(qw1,10)*VarTIME;
qw5:=(qw1-qw3)*100/qw4*VarTIME;
qw6:=EMA(qw5,5)*VarTIME;
rk7:=EMA(qw6,10)*VarTIME;
涨:EMA(qw6,10)+100/2-5,linethick1,colorred;
跌:EMA(涨,4),linethick1,colorFFFF34;
多线:IF(CROSS(涨,跌) AND 跌<-10,30,0),linethick1,COLORFF00FF;
空线:IF(CROSS(跌,80),70,100),color0099ff,linethick1;
买1:EMA(跌,4)*VarTIME,colorwhite;
买2:EMA(买1,4)*VarTIME,colorgreen;
买m3:=EMA(买2,4)*VarTIME,coloryellow;
买m4:=EMA(买m3,4)*VarTIME,colorcc9900;
-10,POINTDOT,color888888,linethick2;
80,POINTDOT,color888888,linethick2;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),0,0 ),colorwhite;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),8,0 ),COLOR008800;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),7,0 ),COLOR009900;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),6,0 ),COLOR00AA00;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),5,0 ),COLOR00BB00;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),4,0 ),COLOR00CC00;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),3,0 ),COLOR00DD00;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),2,0 ),COLOR00EE00;
STICKLINE(涨<REF(涨,1)*VarTIME,涨,MA(涨,3),1,0 ),COLOR00FF00;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),0,0) ,COLOR00BBFF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),8,0) ,COLOR0011FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),7,0) ,COLOR0022FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),6,0) ,COLOR0044FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),5,0) ,COLOR0066FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),4,0) ,COLOR0088FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),3,0) ,COLOR0099FF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),2,0) ,COLOR00AAFF;
STICKLINE(涨> REF(涨,1),涨,EMA(涨,3),1,0) ,COLOR00BBFF;
DRAWICON(多线,30,1),COLORFF00FF;
DRAWICON(CROSS(跌,80),70,2),colorgreen;
DRAWTEXT(CROSS(涨,跌) AND 跌<20 AND 跌>-10,40,'买入'),colorccff99;
DRAWTEXT(多线>0,-20,'看涨'),color0000ff;
Var822:=DMA(EMA(CLOSE,12),SUM(VOL,5)/3/CAPITAL)*VarTIME;
Var883:=(CLOSE-Var822)/Var822*100*VarTIME;
Var1:=MA(CLOSE,152);
Var2:=MA(CLOSE,194);
Var3:=Var2+2*STD(CLOSE,170);
Var4:=Var1+2*STD(CLOSE,170);
顶:(CLOSE>Var3)*13*10,colorblue,linethick2;
Var6:=EMA(HHV(HIGH,500),21);
Var7:=EMA(HHV(HIGH,250),21);
Var8:=EMA(HHV(HIGH,90),21);
Var9:=EMA(LLV(LOW,500),21);
VarA:=EMA(LLV(LOW,250),21);
VarB:=EMA(LLV(LOW,90),21);
VarC:=EMA((Var9*0.96+VarA*0.96+VarB*0.96+Var6*0.558+Var7*0.558+Var8*0.558)/6,21);
VarD:=EMA((Var9*1.25+VarA*1.23+VarB*1.2+Var6*0.55+Var7*0.55+Var8*0.65)/6,21);
VarE:=EMA((Var9*1.3+VarA*1.3+VarB*1.3+Var6*0.68+Var7*0.68+Var8*0.68)/6,21);
VarF:=EMA((VarC*3+VarD*2+VarE)/6*1.738,21);
Var10:=REF(LOW,1);
Var11:=SMA(ABS(LOW-Var10),3,1)/SMA(MAX(LOW-Var10,0),3,1)*100;
Var12:=EMA(IF(CLOSE*1.35<=VarF,Var11*10,Var11/10),3);
Var13:=LLV(LOW,30);
Var14:=HHV(Var12,30);
Var15:=IF(MA(CLOSE,58),1,0);
Var16:=EMA(IF(LOW<=Var13,(Var12+Var14*2)/2,0),3)/618*Var15;
Var17:=IF(Var16>50,50,Var16)/3.82*6;
Var18:=HHV(HIGH,30);
Var19:=LLV(LOW,30);
NL:=EMA((CLOSE-Var19)/(Var18-Var19)*100,5)/8*10,coloryellow,linethick2;
Var1A:=(EMA(AMOUNT,5)/EMA(VOL,5)/100-EMA(AMOUNT,125)/EMA(VOL,125)/100)/(EMA(AMOUNT,5)/EMA(VOL,5)/100)<-0.4;
Var1B:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
Var1C:=SMA(Var1B,3,1);
Var1D:=SMA(Var1C,3,1);
Var1E:=(-100)*(HHV(HIGH,52)-CLOSE)/(HHV(HIGH,52)-LLV(LOW,52));
Var1F:=COUNT(Var1A,5)>=1 AND (Var1E<-99.9 OR Var1D<15 AND Var1C<12);
Var21:=100*WINNER(CLOSE);
Var22:=MA(Var21,3);
Var25:=SUM(IF(CLOSE>REF(CLOSE,1),1,0),0);
Var26:=SUMBARS(VOL,CAPITAL);
Var27:=IF(CLOSE>LLV(CLOSE,Var26),1,-1)*IF(Var25>LLV(Var25,Var26),1,-1);
Var28:=COUNT(IF(Var27=-1,1,0)=1,8)>2;
Var29:=(CLOSE-DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100)))/DMA((3*HIGH+LOW+OPEN+2*CLOSE)/7,VOL/(SUM(AMOUNT,13)/(AMOUNT/VOL/100)/100))*100<-18;
Var2A:=(CLOSE-MIN(REF(CLOSE,5)*0.865,REF(CLOSE,21)*0.772))/CLOSE<0.01;
Var2B:=Var28 AND Var29 AND Var2A;
Var2C:=VOL/CAPITAL>=0.02 AND VOL/CAPITAL<=0.2 AND OPEN=1.105;
Var2D:=Var2C AND COUNT(Var2C,5)=1;
Var2E:=Var2B OR Var2C;
Var2F:=REF(CLOSE,1);
Var30:=SMA(MAX(CLOSE-Var2F,0),7,1)/SMA(ABS(CLOSE-Var2F),7,1)*100;
Var31:=SMA(MAX(CLOSE-Var2F,0),13,1)/SMA(ABS(CLOSE-Var2F),13,1)*100;
Var32:=Var30<20 AND Var31<25;
Var33:=Var32;
Var34:=SUM(IF(CLOSE>REF(CLOSE,1),VOL,IF(CLOSE<REF(CLOSE,1),0-VOL,0)),0);
Var35:=IF(CLOSE>LLV(CLOSE,Var26),1,-1);
Var36:=IF(Var34>LLV(Var34,Var26),1,-1);
Var37:=Var35*Var36;
Var38:=IF(Var37=-1,1,0);
Var3B:=(CLOSE-LLV(LOW,36))/(HHV(HIGH,36)-LLV(LOW,36))*100;
Var3C:=SMA(Var3B,3,1);
Var3D:=SMA(Var3C,3,1);
Var3E:=SMA(Var3D,3,1);
Var3F:=CROSS(Var3D,Var3E) AND Var3D<20;
Var40:=CROSS(Var3E,Var3D) AND Var3D>80;
Var41:=5;
DRAWTEXT(CROSS(Var41,NL),30,'★做底'),colorwhite;
Var44:=REF(CLOSE,1);
Var45:=SMA(MAX(CLOSE-Var44,0),6,1)/SMA(ABS(CLOSE-Var44),6,1)*100;
STICKLINE(CROSS(84,Var45),0,Var2*15+3,5,1),colorgreen;
DRAWTEXT(CROSS(84,Var45),80,'防空警报'),colorgreen ,;
Var47:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5);
Var48:=(CLOSE-LLV(CLOSE,126))/(HHV(CLOSE,126)-LLV(CLOSE,126))*100;
Var49:=EMA(CLOSE,2)-EMA(CLOSE,150);
Var4A:=EMA(Var49,100);
Var4B:=2*(Var49-Var4A);
Var4C:=POW(Var4B,3)*0.1+POW(Var4B,1);
Var4D:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Var4E:=EMA(Var4D*0.97,3);
Var4F:=(HIGH+LOW+CLOSE)/3;
Var50:=(Var4F-MA(Var4F,14))/(0.015*AVEDEV(Var4F,14));
Var51:=IF(Var4B>0.1,Var4C,0)*5;
Var52:=LLV(HIGH,240);
Var53:=100*(CLOSE-Var52)/Var52;
Var54:=AMOUNT/VOL;
Var55:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,5);
Var56:=INDEXC;
Var57:=MA(Var56,5);
Var58:=MA(Var56,20);
Var59:=MA(Var56,30);
Var5A:=Var59>Var57*1.08 AND Var58>Var57*1.055;
Var5B:=Var57>Var56*1.03 AND Var58>Var56*1.13;
Var5C:=Var5B;
Var5D:=IF(FILTER(Var55<6,5)=1,1,0);
Var5E:=(Var5D AND Var53<-2.5 AND Var47<5 AND Var48=0)*60;
Var5F:=Var55<6 AND Var5C;
Var60:=IF(FILTER(Var5F,1)=1,1,0)*80;
Var61:=Var5F AND Var5D*80;
Var62:=CROSS(Var51,2);
Var63:=CROSS(Var51,4);
Var64:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
Var65:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
Var66:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
Var67:=REF(CLOSE,1);
Var68:=SMA(MAX(CLOSE-Var67,0),5,1)/SMA(ABS(CLOSE-Var67),5,1)*100;
Var69:=(HIGH+LOW+CLOSE)/3;
Var6A:=(Var69-MA(Var69,14))/(0.015*AVEDEV(Var69,14));
Var6B:=(Var64>=-15.8 AND Var64<=-12.2 AND Var65<=-20.8 AND Var66<=-27.5 AND Var68<=11.7 AND Var6A<=-145)*100;
Var6C:=Var48=0;
Var6D:=Var48=100;
Var6E:=LLV(HIGH,240);
Var6F:=100*(CLOSE-Var6E)/Var6E;
Var70:=(CLOSE-LLV(LOW,528))/(HHV(HIGH,528)-LLV(LOW,528))*100;
Var71:=(CLOSE-LLV(CLOSE,530))/(HHV(CLOSE,530)-LLV(CLOSE,530))*100;
Var72:=0;
Var73:=SMA(MAX(CLOSE-REF(CLOSE,1),0),34,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),7,1)*100;
Var74:=SMA(MAX(CLOSE-REF(CLOSE,1),0),13,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),13,1)*100;
Var75:=BARSCOUNT(CLOSE);
Var76:=Var73<20 AND Var74<23 AND Var75>35;
Var77:=Var76 AND COUNT(Var76,1)=1;
Var78:=EMA(CLOSE,21)-EMA(CLOSE,8);
Var79:=EMA(Var78,5);
Var7A:=TROUGHBARS(3,6,1)<4 AND CROSS(Var78,Var79);
Var7B:=IF(TROUGHBARS(3,16,1)=0 AND HIGH>LOW+0.04,4,0);
Var7C:=IF(EMA(CLOSE,5)/EMA(EMA(CLOSE,9),16)<=0.85 AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
Var7D:=(-100)*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100;
Var7E:=(-100)*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
Var7F:=(-100)*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100;
Var80:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
Var81:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
Var82:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
Var83:=(Var7D+Var7E+Var7F+Var80+Var81+Var82)/6;
Var84:=EMA(Var83,3);
Var85:=ABS(Var80-Var82);
Var86:=(Var83+Var85)/2;
Var87:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
Var88:=Var87+Var86;
Var89:=IF(Var7C>0 AND Var88<0,200,0);
Var8A:=IF(Var86<0 AND CLOSE=LLV(CLOSE,5) AND CLOSE/REF(CLOSE,1)>0.905 AND CLOSE/REF(CLOSE,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
Var8B:=IF(Var88<0 AND Var8A=-50,100,0);
Var8C:=MA(CLOSE,3);
Var8D:=REF(CLOSE,2)*0.865;
Var8E:=REF(CLOSE,13)*0.772;
Var8F:=MIN(Var8D,Var8E);
Var90:=100*VOL/CAPITAL;
Var91:=MA(CLOSE,13);
Var92:=IF((CLOSE-Var8F)/CLOSE<0.03 AND SUM(Var90,5)/5<1.8,1,0);
Var93:=IF(Var92>0 AND (Var8A<0 OR Var7C>0),100,0);
Var94:=Var93;
Var95:=IF(Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902 OR (Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0) AND (Var8A<0 OR Var7C>0) AND Var93<10,50,0);
Var96:=(Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0) AND (Var8A<0 OR Var7C>0);
Var97:=Var89>0 AND Var8B>0 AND SUM(VOL/CAPITAL*100,5)/5<1 OR Var92>0 AND REF(CLOSE,1)/REF(CLOSE,2)>0.902;
Var98:=Var96 OR Var97;
Var99:=SMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14,1);
Var9A:=HIGH-REF(HIGH,1);
Var9B:=REF(LOW,1)-LOW;
Var9C:=SMA(IF(Var9A>0 AND Var9A>Var9B,Var9A,0),12,1);
Var9D:=SMA(IF(Var9B>0 AND Var9B>Var9A,Var9B,0),12,1);
Var9E:=Var9C*100/Var99;
Var9F:=Var9D*100/Var99;
VarA0:=SMA(ABS(Var9F-Var9E)/(Var9F+Var9E)*100,12,1);
VarA1:=(VarA0+REF(VarA0,5))/2;
VarA2:=SUM(HIGH-OPEN,12)/SUM(OPEN-LOW,12)*100;
VarA3:=SUM(MAX(0,HIGH-REF(CLOSE,1)),12)/SUM(MAX(0,REF(CLOSE,1)-LOW),12)*100;
VarA4:=AMOUNT/VOL/100;
VarA5:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
VarA6:=SUM(AMOUNT,5)/VarA4/100;
VarA7:=SUM(AMOUNT,13)/VarA4/100;
VarA8:=SUM(AMOUNT,34)/VarA4/100;
VarA9:=SUM(AMOUNT,209)/VarA4/100;
VarAA:=REF(VOL,1)+REF(VOL,2)+REF(VOL,3)+REF(VOL,4);
VarAB:=VarAA/CAPITAL;
VarAC:=VOL/CAPITAL*VarA5+VarAB*REF(VarA4,1);
VarAD:=DMA(VarA5,VOL/VarA6);
VarAE:=DMA(VarA5,VOL/VarA7);
VarAF:=DMA(VarA5,VOL/VarA8);
VarB0:=DMA(VarA5,VOL/CAPITAL);
VarB1:=MA(HHV(HIGH,488),18);
VarB2:=MA(HHV(HIGH,220),18);
VarB3:=MA(HHV(HIGH,98),18);
VarB4:=MA(LLV(LOW,488),18);
VarB5:=MA(LLV(LOW,220),18);
VarB6:=MA(LLV(LOW,98),18);
VarB7:=MA((VarB4*0.96+VarB5*0.96+VarB6*0.96+VarB1*0.558+VarB2*0.558+VarB3*0.558)/6,18);
VarB8:=MA((VarB4*1.25+VarB5*1.23+VarB6*1.2+VarB1*0.55+VarB2*0.55+VarB3*0.65)/6,18);
VarB9:=MA((VarB4*1.3+VarB5*1.3+VarB6*1.3+VarB1*0.68+VarB2*0.68+VarB3*0.68)/6,18);
VarBA:=MA((VarB7*3+VarB8*2+VarB9)/6*1.738,18);
VarBB:=IF(DATE<=1021231,VarBA,VarBA*DAY);
VarBC:=LOW;
VarBD:=REF(LOW,1);
VarBE:=SMA(ABS(VarBC-VarBD),3,1)/SMA(MAX(VarBC-VarBD,0),3,1)*100;
VarBF:=MA(IF(CLOSE*1.35<=VarBB,VarBE*10,VarBE/10),3);
VarC0:=LLV(LOW,30);
VarC1:=HHV(VarBF,30);
VarC2:=IF(LOW<=VarC0,(VarBF+VarC1*2)/2,0);
WXBM:(MA(VarC2 AND CLOSE<COST(1),3) AND (CLOSE-VarAE)/VarAE*100<-11)*118,colorred,linethick2;
STICKLINE(Var7B>0,0,120,2,0),colorwhite;
STICKLINE(Var60>0,0,80,8,0),colorred;
DRAWTEXT(Var61 OR Var98,70,'★大黑马'),coloryellow;
DRAWTEXT(Var60>0,40,'★黑马'),coloryellow;
DRAWTEXT(Var7B>0,60,'★探底'),colorwhite;
DRAWTEXT(WXBM,100,'BM'),colorred , ;
STICKLINE(Var61,0,120,8,0),colorwhite;
STICKLINE(Var98,0,90,8,0),coloryellow , ;
X:=C-REF(MA(C,20),11);
lgl:=IF(EMA(C,5)/EMA(EMA(C,9),16)<=0.85 AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,50,0);
wr1:=-100*(HHV(HIGH,34)-CLOSE)/(HHV(HIGH,34)-LLV(LOW,34))+100*X;
wr2:=-100*(HHV(HIGH,50)-CLOSE)/(HHV(HIGH,50)-LLV(LOW,50))+100;
wr3:=-100*(HHV(HIGH,70)-CLOSE)/(HHV(HIGH,70)-LLV(LOW,70))+100*X;
BIAS1:=((CLOSE-MA(CLOSE,34))/MA(CLOSE,34)*100+10)*5;
BIAS2:=((CLOSE-MA(CLOSE,50))/MA(CLOSE,50)*100+10)*5;
BIAS3:=((CLOSE-MA(CLOSE,70))/MA(CLOSE,70)*100+10)*5;
s1:=(wr1+wr2+wr3+bias1+bias2+bias3)/6*X;
s2:=EMA(s1,3);
s3:=ABS(bias1-bias3);
sx:=(s1+s3)/2;
xc1:=(-1)*(EMA(100*(1-WINNER(CLOSE)),1)-50)+50;
ccc:=xc1+sx;
zjz:=IF( lgl>0 AND ccc<0,200,0)*X;
lxl:=IF(sx<0 AND C=LLV(C,5) AND C/REF(C,1)>0.905 AND C/REF(C,1)<1.05 AND VOL/CAPITAL*100<5,-50,0);
jbj:=IF(ccc<0 AND lxl=-50,100,0)*X;
ma3:= MA(C,3);
c0:=REF(C,2)*0.865;
c1:=REF(C,13)*0.772;
bot:=MIN(c0,c1);
hsl:=100*VOL/CAPITAL*X;
ma13:=MA(C,13)*X;
cxc:=IF((C-bot)/C<3/100 AND SUM(hsl,5)/5<1.8,1,0);
vmc:=IF(cxc>0 AND (lxl<0 OR lgl>0),10,0);
满仓:IF((vmc>0),120,0),colorred,linethick3;
DRAWTEXT(满仓>0 AND REF(满仓,1)=0,100,'满仓'),colorred;
半仓:IF(((zjz>0 AND jbj>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (cxc>0 AND REF(C,1)/REF(C,2)>0.902)) OR (((zjz>0 AND jbj>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR cxc>0) AND (lxl<0 OR lgl>0)) AND vmc<10 ,100,0),colormagenta,linethick2;
v93:=(((zjz>0 AND jbj>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR cxc>0) AND (lxl<0 OR lgl>0)) ;
v90:=((zjz>0 AND jbj>0 AND SUM(VOL/CAPITAL*100,5)/5<1) OR (cxc>0 AND REF(C,1)/REF(C,2)>0.902));
买11:IF((v93 OR v90),80,0),coloryellow,linethick2;
Var2q:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线:= MA((CLOSE-Var2q)/Var2q,2);
买12:IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012 AND ((C-REF(C,2))/C)>0.06,100,0),colormagenta,linethick2;
yy:=SMA(SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,18,1),12,1);
yt:=SMA((CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100,12,1);
st:=IF(CROSS(yt,yy),30,0);
Var5pt:=(HIGH+LOW+CLOSE)/3;
Var6pt:=(Var5pt-MA(Var5pt,14))/(0.015*AVEDEV(Var5pt,14));
Var7pt:=(Var5pt-MA(Var5pt,85))/(0.015*AVEDEV(Var5pt,85));
sa:=IF(Var7pt>=200 AND Var6pt>=150,10,0);
Var3qq:=REF(CLOSE,1);
Var4qq:=SMA(MAX(CLOSE-Var3qq,0),6,1)/SMA(ABS(CLOSE-Var3qq),6,1)*100;
sm:=IF(CROSS(80,Var4qq),100,0);
卖11:IF((sm AND (sa OR st)),120,0),colorCCCC33,linethick2;
DRAWTEXT( 卖11>0,110,'卖'),COLORCCCC33;
Varg3:=LLV(HIGH,240);
Varg4:=100*(CLOSE-Varg3)/Var3;
Varg5:=REF(LLV(CLOSE,480),1);
Varg6:=REF(HHV(CLOSE,480),1);
Varg7:=100*(CLOSE-Varg5)/(Varg6-Varg5);
Varg8:=(CLOSE-LLV(CLOSE,981))/(HHV(CLOSE,981)-LLV(CLOSE,981))*100;
Varg9:=(CLOSE-LLV(CLOSE,393))/(HHV(CLOSE,393)-LLV(CLOSE,393))*100;
VargA:=(CLOSE-LLV(LOW,981))/(HHV(HIGH,981)-LLV(LOW,981))*100;
VargB:=(CLOSE-LLV(LOW,393))/(HHV(HIGH,393)-LLV(LOW,393))*100;
VargC:=EMA(100*(CLOSE-LLV(LOW,100))/(HHV(HIGH,100)-LLV(LOW,100)),5)/4;
VargD:=IF(DATE<120981231,IF(VarC>23.16,VarC,0),0);
VargE:=VargC<1;
VargF:=VargD;
Varg10:=IF(FILTER(Varg8=0 AND VargA<1 AND Varg4<0,5)=1,1,0);
Varg11:=IF(FILTER(Varg8=100 AND VargA=100,5)=1,1,0);
Varg12:=IF(FILTER(Varg9=0 AND VargB<1 AND Varg7<0,5)=1,1,0);
Varg13:=IF(FILTER(Varg9=100 AND VargB=100,5)=1,1,0);
Varg14:=IF(FILTER(Varg4<1 AND Varg7<1,30)=1,1,0);
Varg15:=Varg10 AND Varg12;
Varg16:=Varg11 AND Varg13;
Varg17:=Varg8=0 AND VargE AND Varg14;
Varg18:=Varg15 AND VargE AND Varg14;
Varg19:=Varg8=100 AND VargF;
Varg1A:=Varg16 AND VargF;
获利:=Varg4;
操盘手:=(CLOSE-LLV(CLOSE,153))/(HHV(CLOSE,153)-LLV(CLOSE,153))*100;
Varg1B:=EMA(CLOSE,2)-EMA(CLOSE,89);
Varg1C:=EMA(Varg1B,30);
Varg1D:=2*(Varg1B-Varg1C)*10;
Varg1E:=POW(Varg1D,3)*0.1+POW(Varg1D,2);
Varg1F:=SQRT(SQRT(LOW*HIGH*OPEN*CLOSE));
Varg20:=EMA(Varg1F*0.97,3);
Varg21:=(HIGH+LOW+CLOSE)/3;
Varg22:=(Varg21-MA(Varg21,14))/(0.015*AVEDEV(Varg21,14));
Varg23:=IF(YEAR<2098 AND Varg1D>0.015,Varg1E,0)/4500;
庄线:=Varg23;
Varg24:=MAX(MAX(HIGH-LOW,ABS(REF(CLOSE,1)-HIGH)),ABS(REF(CLOSE,1)-LOW));
Varg25:=MA(Varg24,48);
Varg26:=CROSS(Varg24,Varg25);
Varg27:=IF(FILTER(Varg26,126)=1,70,0);
Varg28:=REF(CLOSE,1);
Varg29:=SMA(MAX(CLOSE-Varg28,0),6,1)/SMA(ABS(CLOSE-Varg28),6,1)*100;
Varg2A:=SMA(MAX(CLOSE-Varg28,0),12,1)/SMA(ABS(CLOSE-Varg28),12,1)*100;
Varg2B:=SMA(MAX(CLOSE-Varg28,0),24,1)/SMA(ABS(CLOSE-Varg28),24,1)*100;
Varg2C:=IF(FILTER(CROSS(Varg29,Varg2A) AND CROSS(Varg2A,Varg2B) AND CROSS(Varg29,Varg2B),5)=1,50,0);
Varg2D:=(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;
Varg2E:=SMA(Varg2D,3,1);
Varg2F:=SMA(Varg2E,3,1);
Varg30:=3*Varg2E-2*Varg2F;
Varg31:=CROSS(Varg30,Varg2E) AND CROSS(Varg30,Varg2F) AND CROSS(Varg2E,Varg2F);
//{www.gUPaNg.com 股旁网_同花顺股票指标公式}
Varg32:=IF(FILTER(Varg31 AND Varg30<25 AND Varg2F<20,5)=1,80,0);
Varg33:=IF(FILTER(Varg17 OR Varg18,1)=1,100,0);
Varg36:=IF(FILTER(Varg19 AND Varg16 AND VargF,2)=1,100,0);
Varg37:=IF(FILTER(Varg2C AND Varg29<60 AND Varg2B<40,15)=1,80,0);
Varg38:=IF(FILTER(Varg37 AND Varg32,5)=1,10,0);
Varg39:=IF(FILTER(Varg37 AND Varg32 AND Varg27,5)=1,80,0);
Varr2:=CLOSE-REF(CLOSE,1);
Varr3:=IF(CLOSE-REF(CLOSE,1)>=0,Varr2,0);
Varr4:=REF(CLOSE,1)-CLOSE;
Varr5:=IF(CLOSE-REF(CLOSE,1)<=0,Varr4,0);
Varr6:=SUM(Varr3,16)/SUM(Varr5,16);
Varr7:=100-100/(1+Varr6);
Varr8:=EMA(Varr7,16);
Varr9:=EMA(Varr8,8);
VarrA:=EMA(Varr8,45);
VarrB:=Varr8-VarrA;
ADVC:=AMOUNT/VOL;
ASR:=EMA((WINNER(C*1.1)-WINNER(C*0.9))*80,5);
DPA:="1a0001$VOL"*"1a0001$CLOSE";
DPMA:=EMA(DPA,5)/EMA("1a0001$VOL",5);
CYS:=("1a0001$CLOSE"-DPMA)/DPMA*100;
A1:=INDEXC;
A2:=MA(A1,5);
A3:=MA(A1,20);
A4:=MA(A1,30);
B1:=A4>A2*1.08 AND A3>A2*1.055;
B2:=A2>A1*1.03 AND a3>a1*1.13;
ADVC0:=CYS<=-2 AND b2;
刀:IF(ASR<6 AND CYS< -2 AND ADVC0,100,0),colorred,linethick2;
DRAWICON( 刀,90, 5),colorred;
龙:IF(ASR<6 ,110,0),COLOR66FFCC,linethick2;
DRAWTEXT(CROSS(龙,2.6) OR CROSS(2.6,龙),90, '龙') ,COLOR66FFCC ;
Varbb4:=MA(CLOSE,5);
Varbb5:=MA(CLOSE,10);
Varbb6:=MA(CLOSE,30);
Varbb7:=MA(CLOSE,60);
Varbb8:=EMA(COST(85),7);
Varbb9:=EMA(COST(15),7);
VarbbA:=SUM(CLOSE*VOL*100,4)/SUM(VOL*100,4);
VarbbB:=INTPART(VarbbA*100)/100;
VarbbC:=SUM(CLOSE*VOL*100,7)/SUM(VOL*100,7);
VarbbD:=INTPART(VarbbC*100)/100;
VarbbE:=SUM(CLOSE*VOL*100,28)/SUM(VOL*100,28);
VarbbF:=INTPART(VarbbE*100)/100;
DCS:=(EMA(CLOSE,5)-EMA(CLOSE,10))*100,linethick2;
ZCS:=EMA(DCS,9),linethick2;
Varbb10:=-100*(HHV(CLOSE,5)-CLOSE)/(HHV(CLOSE,5)-LLV(LOW,5))+100;
Varbb11:=-100*(HHV(CLOSE,10)-CLOSE)/(HHV(CLOSE,10)-LLV(LOW,10))+100;
Varbb12:=-100*(HHV(CLOSE,20)-CLOSE)/(HHV(CLOSE,20)-LLV(LOW,20))+100;
Varbb13:=-100*(HHV(CLOSE,30)-CLOSE)/(HHV(CLOSE,30)-LLV(LOW,30))+100;
Varbb14:=REF(ZCS,1);
Varbb15:=ZCS;
Varbb16:=(Varbb15-Varbb14)/3;
Varbb17:=REF(DCS,1);
Varbb18:=DCS;
Varbb19:=Varbb18-Varbb17;
Varbb1A:=OPEN;
Varbb1B:=CLOSE;
DHM:IF(Varbb1A<=Varbb4 AND Varbb1A<=Varbb5 AND Varbb1A<=Varbb6 AND Varbb1B>=Varbb4 AND Varbb1B>=VarbbF AND Varbb16>0 AND Varbb19>0,120,0),colormagenta,linethick2;
DRAWTEXT(DHM,80,'"DHM"'),colormagenta;
XX2:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
SQX:=MA((CLOSE-XX2)/XX2,10)*0.01;
买3:IF(CROSS(SQX,0) AND LOW/REF(HIGH,1)<1.012,60,0), STICK,colorwhite,LINETHICK2;
稳赚:IF(COUNT(SQX>REF(SQX,1),3)=3 AND COUNT(SQX<0,10)=10 AND REF(SQX,3)=LLV(SQX,10),60,0),COLOR9999FF;
买4: IF(REF(SQX,2)=LLV(SQX,20) AND REF(SQX,2)<0.071 AND REF(SQX,2)<REF(SQX,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF(HIGH,1)) AND CLOSE>REF(CLOSE,1),60,0),COLORFF00FF,LINETHICK2;
DRAWTEXT( 买3>0,40 ,' 买3'),colorwhite;
DRAWTEXT( 稳赚>0,40 ,'稳赚'),COLOR9999FF;
DRAWTEXT( 买4>0,40 , '买4'),COLORFF00FF;
Varj1:=INDEXC;
Varj2:=MA(Varj1,6);
Varj3:=MA(Varj1,24);
Varj4:=MA(Varj1,32);
Varj5:=MA(Varj1,62);
Varj6:=MA(Varj1,105);
Varj7:=Varj5<REF(Varj5,1) AND Varj6<REF(Varj6,1) AND Varj5<Varj6*0.98;
Varj8:=Varj4>Varj2*1.11 AND Varj3>Varj2*1.095;
Varj9:=Varj2>Varj1*0.95;
BF:=Varj7 AND Varj8 AND Varj9 AND CLOSE/COST(8)<=0.8 AND (CLOSE>OPEN OR CLOSE<OPEN) AND (REF(CLOSE,1)>REF(OPEN,1) OR REF(CLOSE,1)<REF(OPEN,1)) OR CLOSE>0.1,colorgreen;

同花顺股市圈钱机指标公式

 

相关文章