在线检测未来函数

通达信高原红牛主图指标公式

来源:Internet,编辑:股旁网,2012-06-13

C3:=REF(C,1);
涨停:=IF((C-C3)*100/C3>=(10-0.01*100/C3),1,0);
STICKLINE(涨停,OPEN,CLOSE,2,0),COLORFF00FF;
VAR1:=MA(CLOSE,5),COLOR00FFFF;
VAR6:=MA(CLOSE,54),COLORFF9900;
VAR8:= DMA(EMA(CLOSE,12),SUM(VOL/CAPITAL,5)/3),LINETHICK2;
VARA:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA,0),6,1)/SMA(ABS(CLOSE-VARA),6,1)*100;
VARF:=(2*CLOSE+HIGH+LOW)/4;
VAR10:=LLV(LOW,23);
VAR11:=HHV(HIGH,23);
VAR12:=EMA((VARF-VAR10)/(VAR11-VAR10)*100,6);
VAR13:=EMA(0.667*REF(VAR12,1)+0.333*VAR12,4);
RSV:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D;
RSV24:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
K24:=SMA(RSV24,3,1);
D24:=SMA(K24,3,1);
J24:=3*K24-2*D24;
支撑价:=IF(CROSS(J,J24),LOW,REF(LOW,BARSLAST(CROSS(J,J24)))),COLORWHITE;
压力位:=IF(CROSS(J24,J),H,REF(H,BARSLAST(CROSS(J24,J)))),COLOR00FF33,LINETHICK1;
支撑位:=IF(CROSS(J,J24),L,REF(L,BARSLAST(CROSS(J,J24)))),COLORCC33CC,LINETHICK1;
支撑:=LLV(LOW,34) ,COLOR7FFF00,LINETHICK2;
阻力价:=HHV(HIGH,19),COLORFF9900, LINETHICK2;
观望:MA(CLOSE,7),LINETHICK2,COLORYELLOW;
十:=MA(C,7),COLOR00FFFF,LINETHICK2;
持股:IF(MA(CLOSE,7)>REF(MA(CLOSE,7),1),MA(CLOSE,7),DRAWNULL),COLORFF00FF,LINETHICK2;
YYY:=IF(MA(CLOSE,7)=REF(MA(CLOSE,7),1),MA(CLOSE,7),DRAWNULL),COLORYELLOW,LINETHICK3;
空仓:IF(MA(CLOSE,7)<REF(MA(CLOSE,7),1),MA(CLOSE,7),DRAWNULL),COLORGREEN,LINETHICK2;
【流通盘】:FINANCE(7)/100000000,NODRAW,NODRAW,COLORRED;
【市盈率】:DYNAINFO(39),NODRAW,COLORGREEN;
【净资产】:FINANCE(34),NODRAW,COLORYELLOW;
【每股收益】:FINANCE(30)/FINANCE(1),NODRAW,COLORFF00FF;
{www.gupang.com 股旁网_通达信股票指标公式}
JJ:=(OPEN+CLOSE)/2;
WW:=BETWEEN(C,JJ,L) AND CLOSE>REF(CLOSE,1);
AA:=IF(BETWEEN(C,JJ,H) OR WW OR C=O, VOL,0);
BB:=IF(BETWEEN(C,JJ,L) AND CLOSE<REF(CLOSE,1),VOL,0);
CC:=IF(AA AND BB,0,VOL/3);
DDX:=10*(AA-(BB+CC))/IF(CAPITAL<1,SUM(VOL,13),CAPITAL);
DDX1:=EMA(DDX,60)*60;
E:=MA(DDX1,7);
F:=MA(E,11);
G:=REF(E,1);
U:=REF(E,3);
I:=REF(E,4);
W:=REF(E,6);
S:=REF(E,2);
Y:=REF(F,2);
A:=MA(CLOSE,7);
B:=REF(MA(CLOSE,7),1);
ZZ:=CLOSE;
KK:=REF(CLOSE,5);
QQ:=REF(CLOSE,1);
YY:=(ZZ/KK)<1.22 ;
VAR101:=1;
VAR102:=(2*CLOSE+HIGH+LOW)/4;
VAR103:=IF(YEAR>=2099 AND MONTH>2,0,1);
VAR104:=LLV(LOW,5);
VAR105:=HHV(HIGH,4);
散户:=EMA((VAR102-VAR104)/(VAR105-VAR104)*100,4)*VAR103*VAR101;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR103*VAR101;
VAR106:=(HHV(HIGH,4)-VAR102)/(HHV(HIGH,4)-LLV(LOW,4))*100-72;
VAR107:=(VAR102-LLV(LOW,4))/(HHV(HIGH,4)-LLV(LOW,4))*100;
VAR108:=SMA(VAR107,2,1);
DDDD:=SMA(VAR108,2,1)*VAR101;
VAR9:=CLOSE-REF(CLOSE,5);
AAAA:= EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR103*VAR101;
BBBB:= EMA((VAR102-VAR104)/(VAR105-VAR104)*100,4)*VAR103*VAR101;
EEEE:=DDDD>REF(DDDD,1);
FFFF:=AAAA>REF(AAAA,1);
RRRR:=BBBB>REF(BBBB,1);
QQQQ:=REF(BBBB,1)>REF(AAAA,1);
WWWW:=REF(BBBB,2)>REF(AAAA,2);
VAR19:=EVERY(E>F,2) AND EVERY((DDX>=0),6) AND YY AND ZZ>QQ AND
BBBB>AAAA AND BBBB<90 AND EEEE AND FFFF AND QQQQ AND RRRR AND A>B;
STICKLINE(VAR19,OPEN,(OPEN+(CLOSE-OPEN)/2),2,0),COLORYELLOW;
DRAWTEXT(VAR19,(LOW)*(0.97),'红牛'),COLOR00FFFF;
今日上涨家数:INDEXADV,COLOR0000EE,NODRAW;

通达信高原红牛主图指标公式

 

相关文章