在线检测未来函数

通达信强弱MACD指标公式

来源:Internet,编辑:股旁网,2012-06-13

DIF:(EMA(CLOSE,12)-EMA(CLOSE,26))/EMA(CLOSE,26)*100,COLOR2222FF;
DEA:EMA(DIF,9),COLOR22FF22;
DRAWBAND(DIF,RGB(228,0,0),DEA,RGB(0,228,0));
MACD:2*(DIF-DEA),COLORFF8800,NODRAW;
STICKLINE(MACD>0,0,MACD,1.5,-1),COLOR55DDDD;
STICKLINE(MACD<0,0,MACD,1.5,-1),COLORFF5500;
LC:=REF(CLOSE,1);
RSI:=SMA(MAX(CLOSE-LC,0),12,1)/SMA(ABS(CLOSE-LC),12,1)*100;
RDIF:(EMA(RSI,12)-EMA(RSI,26))/EMA(RSI,26)*100,COLORFFFFFF;
RDEA:EMA(RDIF,9),COLOR00FFFF;
阻力位:REF(HHV(RDIF,21),1),COLORFF8800,,DOTLINE;{N日内DIF的最高值}
支撑位:REF(LLV(RDIF,21),1),COLORFF0088,,DOTLINE;{N日内DIF的最低值}
RMACD:2*(RDIF-RDEA),COLORSTICK,COLORFFFF88;
MARDEA:EMA(RDIF,120),COLOR333333;{参数N1可自己定义,60--250之间}
MTM:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);
YXF:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
加仓:IF(FILTER(YXF=1,5),1,0),COLORFF00FF,NODRAW;
STICKLINE(加仓=1,0,RMACD,0.001,0),COLORFF00FF;
{绝佳买点}
快DIF:=(2*EMA(CLOSE, 12)-EMA(EMA(CLOSE,12),12))-(2*EMA(CLOSE, 26)-EMA(EMA(CLOSE, 26),26));
{www.gupang.com 股旁网_通达信股票指标公式}
慢DEA:=2*EMA(快DIF, 9) - EMA(EMA(快DIF, 9),9);
动能MACD:=3*(快DIF-慢DEA);
VARF1:=MA(HHV(HIGH,485),17);
VARF2:=MA(HHV(HIGH,222),17);
VARF3:=MA(HHV(HIGH,96),17);
VARF4:=MA(LLV(LOW,485),17);
VARF5:=MA(LLV(LOW,222),17);
VARF6:=MA(LLV(LOW,96),17);
VARF7:=MA((VARF4*0.96+VARF5*0.96+VARF6*0.96+VARF1*0.558+VARF2*0.558+VARF3*0.558)/6,17);
VARF8:=MA((VARF4*1.25+VARF5*1.23+VARF6*1.2+VARF1*0.55+VARF2*0.55+VARF3*0.65)/6,17);
VARF9:=MA((VARF4*1.3+VARF5*1.3+VARF6*1.3+VARF1*0.68+VARF2*0.68+VARF3*0.68)/6,17);
VARFA:=MA((VARF7*3+VARF8*2+VARF9)/6*1.738,17);
VARFB:=IF(C=C,VARFA,VARFA*DAY);
VARFC:=LOW;
VARFD:=REF(LOW,1);
VARFE:=SMA(ABS(VARFC-VARFD),3,1)/SMA(MAX(VARFC-VARFD,0),3,1)*100;
VARFF:=MA(IF(CLOSE*1.35<=VARFB,VARFE*10,VARFE/10),3);
VARF10:=LLV(LOW,30);
VARF11:=HHV(VARFF,30);
买点:=IF(C=C,MA(IF(LOW<=VARF10,(VARFF+VARF11*2)/2,0),3),100000000)/(200);
STICKLINE(买点>0 AND 动能MACD>0, 0, -RMACD, 0,-1),COLOR00FFFF;
绝佳买点:IF(买点>0 AND 动能MACD>0, 1, 0),COLOR88FFFF,NODRAW;
DRAWICON(买点>0 AND 动能MACD>0 AND MACD>0,0,1);

通达信强弱MACD指标公式

 

相关文章