在线检测未来函数

飞狐动能MACD指标公式

来源:Internet,编辑:股旁网,2012-06-17

OSC:=C-REF(MA(C,13),5);
分界:=MA(OSC,8);
DIFF:= EMA(OSC,12) - EMA(OSC,26);
DEA := EMA(DIFF,9);
MACD:= 2*(DIFF-DEA);
{===================== 【解模板】===================== }
{柱线}
STICKLINE(MACD<ref(MACD,1) and MACD<0,0,MACD*4,1,0),LINEDOT,ColorFFCF78,LINETHICK1;
STICKLINE(MACD<ref(MACD,1) and MACD>0,0,MACD*4,1,0),LINEDOT,COLORYELLOW,LINETHICK1;
{www.gupang.com 股旁网_飞狐股票指标公式}
STICKLINE(MACD>ref(MACD,1) and MACD<0,0,MACD*4,1,0),LINEDOT,COLORMAGENTA,LINETHICK1;
STICKLINE(MACD>ref(MACD,1) and MACD>0,0,MACD*4,1,0),LINEDOT,COLORRED,LINETHICK1;
{K柱}
STICKLINE(OSC<REF(OSC,1)||(AMOUNT/REF(AMOUNT,1)<0.97),OSC,REF(OSC,1),4,0),LINETHICK2,COLORWHITE;//离场
STICKLINE(CROSS(ref(MACD,1),MACD) and MACD<ref(MACD,1),OSC,REF(OSC,1),4,0),LINETHICK2,COLORYELLOW;//逃顶
STICKLINE(OSC>=REF(OSC,1),OSC,REF(OSC,1),4,0),LINETHICK2,COLORRED;//持股
STICKLINE(OSC<分界,OSC,REF(OSC,1),4,0),LINETHICK2,COLORBLUE;//空仓
动能线:FORCAST(OSC,6),Colorred,LINETHICK3;
加速线:(DEA-DIFF)*9.8,COLORGREEN,LINETHICK3;
0,colorwhite;

飞狐动能MACD指标公式

 

相关文章