在线检测未来函数

通达信H超级KMACD指标公式

来源:Internet,编辑:股旁网,2012-06-17

H0:=0.25;
L0:=(H+L+C)/3;
L1:=H0*(L0-MA(L0,21))/(AVEDEV(L0,21));
超级K:SMA(L1,3,1);
超级D:SMA(超级K,3,1);
超级J:超级K*3-超级D*2,COLORCC66BB;
H1:=3.809*H0+REVERSE(EMA(超级J,1));
H2:=-2.809*H0+REVERSE(EMA(超级J,1));
IF(超级J>H1,超级J,DRAWNULL),COLORAAAA33,LINETHICK3;
做顶:IF(超级J>H1,1,0),COLORCYAN,NODRAW;
IF(超级J<H2,1,0),COLOR880088,NODRAW;
筑底:IF(超级J<H2,超级J,DRAWNULL),COLORDD00DD,LINETHICK3;
H3:=CROSS(超级K,超级D);
{www.gupang.com 股旁网_通达信股票指标公式}
H4:=超级J<REF(超级J,1) AND REF(超级J,1)>REF(超级D,1) AND 超级J<=超级D;
H5:=超级J>H1 AND NOT(REF(超级J>H1,1));
拉升为1:IF(H5,1,0),COLORFFFFCC,NODRAW;
金叉:IF(H3,1,0),COLORRED,NODRAW;
死叉:IF(H4,1,0),COLORGREEN,NODRAW;
选股基准线】:CONST(HHV(MAX(MAX(超级K,超级D),超级J),0))*1.1,COLORLIRED;
DIF0:=EMA(DCLOSE,8)-EMA(DCLOSE,22);
DEA0:=EMA(DIF0,7);
MACD:=2*(DIF0-DEA0);
D0:=HHV(ABS(MACD),100);
M0:=COUNT(CROSS(DIF0,DEA0),BARSLAST(DEA0>=0));
M1:=BARSLAST(REF(CROSS(MACD,0),1));
M2:=BARSLAST(REF(CROSS(DEA0,DIF0),1));
M3:=LLV(MACD,4)>0 AND MACD<REF(MACD,1) AND REF(MACD,1)>REF(MACD,2)
AND REF(MACD,2)>REF(MACD,3);
M4:=HHV(MACD,4)<0 AND MACD>REF(MACD,1) AND REF(MACD,1)<REF(MACD,2)
AND REF(MACD,2)<REF(MACD,3);
低位金叉:IF(CROSS(DIF0,DEA0) AND DIF0<-0.1,D0*0.4+【选股基准线】,0+【选股基准线】),COLORFF00FF;
二次金叉:IF(CROSS(DIF0,DEA0) AND DEA0<0 AND COUNT(M0=2,21)=1,D0*0.8+【选股基准线】,
0+【选股基准线】),COLORFFFF00;
启点:IF(FILTER(MACD>0 AND MACD>5*REF(MACD,1),2),D0+【选股基准线】,0+【选股基准线】),COLOR0044FF;
背离:=REF(CLOSE,M1+1)>CLOSE AND MACD>REF(MACD,M1+1),COLORGREEN;
D1:=7;D2:=30;D3:=6;
DIF1:=EMA(C,D1)-EMA(C,D2),COLORFFFFFF;
DEA1:=EMA(DIF1,D3),COLORFF6666;
MACD1:=(DIF1-DEA1)*2,COLORSTICK,COLORRED;
F0:=V*(O+C+H+L)/4;
F1:=IF(V>0,F0/V,(O+C+H+L)/4);
F2:=(F1-LLV(F1,5))/(HHV(F1,5)-LLV(F1,5));
F3:=SMA(F2,13,1);
F4:=SMA(F3,13,1);
F5:=3*F3-2*F4;
F6:=2*F5-0.5;
F7:=F1*(1-(F6-F4)/40);
F8:=CROSS(F1,F7) AND C/REF(C,1)<1.03 AND SUM(DYNAINFO(23),5)>=3000;
MACD拉升:IF(FILTER(F8,10) AND MACD1>0,D0*1.2+【选股基准线】,0+【选股基准线】),COLOR6600FF;
MACD选长:=IF(CROSS(DIF1,DEA1),HHV(ABS(MACD1),100)+【选股基准线】,0),COLORLIRED;
DIF:DIF0+【选股基准线】,COLORFFFFFF;
DEA:DEA0+【选股基准线】,COLOR00AAAA;
0,COLOR888888,POINTDOT;
DRAWTEXT(FILTER(F8,10) AND MACD1>0,D0*1.1+【选股基准线】,'拉'),COLOR6600FF;
STICKLINE(H5,超级J*1.2,超级J*0.8,0,-1),COLORFFFFCC;
DRAWTEXT(H5,超级J*1.25,'拉'),COLORFFFFCC;
DRAWICON(H4,超级K*1.3,2);
DRAWICON(H3,超级K*0.7,1);
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),0+【选股基准线】,MACD+【选股基准线】,1,0),COLOR6699FF;
STICKLINE(MACD>=0 AND MACD<=REF(MACD,1),0+【选股基准线】,MACD+【选股基准线】,1,-1),COLOR008800;
STICKLINE(MACD<=0 AND MACD>=REF(MACD,1),0+【选股基准线】,MACD/2+【选股基准线】,1,0),COLORAAAAAA;
STICKLINE(MACD<=0 AND MACD<=REF(MACD,1),0+【选股基准线】,MACD/2+【选股基准线】,1,-1),COLORCC6600;
DRAWTEXT(FILTER(M3,3),-0.15+【选股基准线】,'转空'),COLOR00FF00;
DRAWTEXT(FILTER(M4,3),D0*0.5+【选股基准线】,'转多'),COLORFFFFBB;
DRAWTEXT(CROSS(DIF0,DEA0) AND DIF0<-0.1,D0*0.3+【选股基准线】,'低位X'),COLORFF00FF;
DRAWTEXT(CROSS(DIF0,DEA0) AND DEA0<0 AND COUNT(M0=2,21)=1,D0*0.7+【选股基准线】,
'二次X'),COLORFFFF00;
DRAWTEXT(FILTER(MACD>0 AND MACD>5*REF(MACD,1),2),D0*0.9+【选股基准线】,'启'),COLOR0044FF;

通达信H超级KMACD指标公式

 

相关文章