在线检测未来函数

飞狐量能饱和度指标公式

来源:Internet,编辑:股旁网,2012-06-22

input:N(20,1,100);
{量能饱和度}
{时间}
BB:=BARPOS=SYSPARAM(1);
variable:wday[7]='星期六';
wday[1]:='星期日';
wday[2]:='星期一';
wday[3]:='星期二';
wday[4]:='星期三';
wday[5]:='星期四';
wday[6]:='星期五';
fy:=YEAR;
fm:=MONTH;
fd:=DAY;
wd:=WEEKDAY;
p:=SYSPARAM(1);
str1:=' '+'今日: '+NUMTOSTR(fy[p],0)+'年'+NUMTOSTR(fm[p],0)+'月'+NUMTOSTR(fd[p],0)+'日 '+wday[wd[p]+1];
drawtext(barpos=sysparam(2),c,str1),ALIGN4,COLORGREEN,PXDN10;
{www.gupang.com 股旁网_飞狐股票指标公式}
DRAWTEXT(barpos=p,H,'\n \n \n \n \n' ),ALIGN4,COLOR0088FF,PXDN2;
DRAWTEXT(barpos=p,H,'\n \n \n \n \n' ),ALIGN4,COLOR0088FF,PXDN1;
SAT:IF((AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,N)/HHV(C,N))*100),color0000ff;
STICKLINE(((CLOSE > 0) AND BARpos=sysparam(1)),20,121,{40}10,1),colorFFFFFF;
STICKLINE(((SAT <= 5) AND BARpos=sysparam(1)),21,(20 + SAT),{35}8,0),color0000FF;
STICKLINE((((SAT > 5) AND (SAT <= 20)) AND BARpos=sysparam(1)),21,(20 + SAT),{35}8,0),colorCCFF88;
STICKLINE((((SAT > 20) AND (SAT <= 40)) AND BARpos=sysparam(1)),21,(20 + SAT),{35}8,0),colorFF00FF;
STICKLINE(((SAT > 40) AND BARpos=sysparam(1)),21,(20 + SAT),{35}8,0),color0000FF;
ma(SAT,4);
100;
量能饱和度:SAT=100;
drawicon(量能饱和度,SAT*1.025,12);

飞狐量能饱和度指标公式

 

相关文章