在线检测未来函数

通达信新新KDJ指标公式

来源:Internet,编辑:股旁网,2012-06-25

STICKLINE(10,120,0,5,0),COLORCC0033; VAR130:=IF(YEAR>=2005 AND MONTH>=11 AND DAY>=1,0,1);
EE:=REF(C,1);
VAR160:=SMA(MAX(C-EE,0),6,1)/SMA(ABS(C-EE),6,1)*100;
STICKLINE(CROSS(84,VAR160) AND VAR130,125,90,16,1),COLOR0099FF;
DRAWICON(CROSS(84,VAR160) AND VAR130,95,15); 股价趋势:=((3 * SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1)) - (2 * SMA(SMA((((CLOSE - LLV(LOW,27)) / (HHV(HIGH,27) - LLV(LOW,27))) * 100),5,1),3,1)));
顶部警戒:=95;
止损出局:STICKLINE(CROSS(顶部警戒,股价趋势),110,20,2,0),LINETHICK2,COLORCYAN; RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
RSV1:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV1,3,1);
D:SMA(K,3,1);
J:3*K-2*D,LINETHICK2;
IF(J>=REF(J,1),J,DRAWNULL),COLORRED,LINETHICK2;
IF(J<REF(J,1),J,DRAWNULL),COLORFFFF11,LINETHICK2;
IF(J<0,J,DRAWNULL),COLORYELLOW,LINETHICK2;
IF(K>90,K,DRAWNULL),COLORGREEN,LINETHICK2;
IF(D>85,D,DRAWNULL),COLORGREEN,LINETHICK2;
高安全区:0,COLORRED;
安全区:20,COLORCYAN;
风险区:100,COLORGREEN;底警戒:10,COLORCYAN;
顶警戒: 90, COLORRED; LC:=REF(CLOSE,1);
{www.gupang.com 股旁网_通达信股票指标公式}
VAR21:=(CLOSE-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR22:=((SMA(MAX((CLOSE - VAR21),0),6,1) / SMA(ABS((CLOSE - VAR21)),6,1) * 100));
VAR13:=(CLOSE-LLV(LOW,13))/(HHV(HIGH,13)-LLV(LOW,13))*100;
DD:=-10; X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT(X9,(HIGH *3.12),'◤卖'),COLORGREEN; VAR10A:=(CLOSE-LLV(LOW,45))/(HHV(HIGH,45)-LLV(LOW,45))*100;
VAR2A:=SMA(VAR10A,3,1);
VAR3A:=SMA(VAR2A,3,1);
VAR4A:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
V11:=LLV(LOW,10); V21:=HHV(H,25);
价位线1:=EMA((C-V11)/(V21-V11)*4,4);
VARA11:=3;
VARA21:=(3)*(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1)) - (2)*(SMA(SMA(((CLOSE - LLV(LOW,27))/(HHV(HIGH,27) - LLV(LOW,27)))*(100),5,1),3,1));
DRAWTEXT(CROSS(3.5,价位线1),105,'◤逃顶'),COLORWHITE;趋势1: 5*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1),2,1),LINETHICK0,COLOR7F52AF;
底部1:6,LINETHICK0,COLOR00FFFF;
抄底: IF(CROSS(趋势1,底部1),1,0),,STICK,COLOR00FFFF;
DRAWTEXT(抄底,-2,'抄底'),COLORYELLOW;

通达信新新KDJ指标公式

 

相关文章