在线检测未来函数

通达信九散人成交量指标公式

来源:Internet,编辑:股旁网,2012-06-28

预量:IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,VOL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,预量,0,-1,-1),COLOR00C0C0;
实量:VOL,VOLSTICK,COLORLIGREEN;
STICKLINE(C=REF(C,1),0,V,0,0),COLORWHITE;
STICKLINE(C>REF(C,1) AND C<O,0,V,0,0),COLORRED;
STICKLINE(C<REF(C,1) AND C>O,0,V,0,0),COLORGREEN;
BASED:=VOL/((H-L)*2-ABS(C-O));
{www.gupang.com 股旁网_通达信股票指标公式}
BUY:=IF(C>O,BASED*(H-L),IF(C<O,BASED*((H-O)+(C-L)),IF(H=L AND C>REF(C,1),VOL,IF(H=L AND C<REF(C,1),0, VOL/2)))),COLORRED,NODRAW;
SALE:=IF(C>O,BASED*((H-C)+(O-L)),IF(C<O,BASED*(H-L),IF(H=L AND C<REF(C,1),VOL,IF(H=L AND C>REF(C,1),0, VOL/2)))),COLOR00FF00,NODRAW;
买入净值%:IF(BUY>=SALE,(BUY-SALE)/VOL*100,DRAWNULL),NODRAW;
卖出净值%:IF(BUY<=SALE,(SALE-BUY)/VOL*100,DRAWNULL),NODRAW;
STICKLINE(BUY>SALE,0,BUY-SALE,0.1,0),COLOR00F7F7;
STICKLINE(BUY<SALE,0,SALE-BUY,0.1,0),COLORFF1717;
DDX:=BUY-SALE;
MADDX:=MA(DDX,5)*5;
DDX1:SMA(MADDX,3,1),COLORFFFFFF,LINETHICK1;
DDX2:SMA(DDX1,3,1),COLORF100F1,LINETHICK1;
DDX3:SMA(DDX2,3,1),COLOR00D900,LINETHICK1;

通达信九散人成交量指标公式

 

相关文章