在线检测未来函数

通达信江恩斜率指标公式

来源:Internet,编辑:股旁网,2012-07-01

GLL:=-6;P:=20;
VAR1E:=(C-LLV(L,P))/(HHV(H,P)-LLV(L,P))*100;
VAR2E:=SMA(SMA(VAR1E,3,1),3,1);
VAR3E:=EMA(VAR2E,5);
BB:=VAR3E;
GZ:=3*VAR2E-2*VAR3E;
F:=EMA(GZ,3);
DRAWICON(CROSS(GZ,F) AND COUNT(GZ<20,5)>=1,-5,1);
DRAWICON(CROSS(GZ,F) AND COUNT(GLL<-6,3)>=1,-13,1);
VAR1:=MA(AMOUNT/100*V,5);
VAR2:=MA(AMOUNT/100*V,13);
VAR3:=MA(AMOUNT/100*V,34);
VAR4:=DMA(C,V/CAPITAL);
CYS13:=(C-VAR2)/VAR2*70;
ABS(WINNER(C)-WINNER(O))*100+5,VOLSTICK;
STICKLINE(CYS13>0,3,-3,2,0),COLORWHITE;
STICKLINE(CYS13<=0,-3,1,2,0),COLOR4D9CFF;
STICKLINE(CYS13<=-5,-20,-3,3,0),COLORBLUE;
DRAWICON(CYS13<=0 AND GLL<GLL AND C>REF(C,1),-8,4);
{www.gupang.com 股旁网_通达信股票指标公式}
DRAWICON(CYS13<=0 AND GLL<GLL AND C>REF(C,1),-8,1);
低:5,POINTDOT,LINETHICK2;
吸:20,POINTDOT,COLORC8A6AB;
45;
强:70,COLORC8D9AB;
顶:95,POINTDOT,COLORF830EA;
C0:=(H+L+C)/3;
A1:=HHV(C0,15);
A2:=LLV(C0,15);
A3:=A1-A2;
江恩斜率:EMA((C0-A2)/A3,2)*100,COLORFFFF00;
IF(江恩斜率>REF(江恩斜率,1),江恩斜率,DRAWNULL),LINETHICK4,COLORFFFFFF;
IF(江恩斜率>20 AND 江恩斜率>REF(江恩斜率,1),江恩斜率,DRAWNULL),LINETHICK4,COLORFFFF00;
STICKLINE(江恩斜率<45,45,江恩斜率,1,0),POINTDOT,COLORFF0000;
DRAWICON(CROSS(45,江恩斜率),60,2);
VAR2X:=(C-LLV(L,8))/(HHV(H,8)-LLV(L,8))*100;
讯雷测庄:=(EMA(VAR2X,3)-50)*2;
DRAWICON(CROSS(讯雷测庄,-50),-10,4);
DRAWICON(CROSS(讯雷测庄,-50),-10,1);
BIAS1W:=(C-MA(C,6))/MA(C,6)*100;
BIAS2W:=(C-MA(C,12))/MA(C,12)*100;
BIAS3W:=(C-MA(C,24))/MA(C,24)*100;
MM:=(BIAS1W+2*BIAS2W+3*BIAS3W)/6;
MN:=MA(MM,3);
STICKLINE(MN<GLL,50,60,3,0),COLORFF00F0;
STICKLINE(MN<-9,50,60,2,0),COLORFF0000;
STICKLINE(MN<-12,50,60,2,0),COLORFFFFFF;
MAV:=(C*2+H+L)/4;
SK:=EMA(MAV,1)-EMA(MAV,40);
SD:=EMA(SK,5);
B:=(SK-SD)*100;
T:=(C-LLV(1.02*L,20))/(HHV(H,20)-LLV(L,20))*100;
Q1:=(HHV(H,13)-C)/(HHV(H,13)-LLV(L,13))*120;
短线阻力:=IF(A1>100,100,IF(A1<-5,-5,A1));
短线能量:=IF(B<-20,-20,IF(B>100,100,B));
趋势线:=1.06*(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1)-50)+50;
VAR2A:=(2*C+H+L+O)/5;
VAR3A:=LLV(L,34);
VAR4A:=HHV(H,34);
SKA:=EMA((VAR2A-VAR3A)/(VAR4A-VAR3A)*100,13);
SDA:=EMA(SKA,3);
STICKLINE(CROSS(趋势线,8.5),20,45,1.5,0),COLORFF00FF;
STICKLINE(CROSS(87,趋势线),40,100,1,0),COLORFFFFFF;
VAR1K:=(L+H+2*C)/4;
VAR2K:=REF(VAR1K,1);
VAR3K:=SMA(VAR1K-VAR2K,6,1)/SMA(ABS(VAR1K-VAR2K),6,1)*100;
MMS:=MA(VAR3K,1)+50;
MMM:=EMA(MMS,8);
MML:=EMA(MMS,24);
MMC:=EMA(MMM,40);
STICKLINE(MMS>=100,110,105,8,0),COLORYELLOW;
STICKLINE(MMS<0,50,40,2,0),COLORGREEN;
RSI1:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
DRAWICON(CROSS(80,RSI1),110,6);
DRAWICON(CROSS(80,RSI1),110,2);
DRAWICON(CROSS(RSI1,20),-10,1);

通达信江恩斜率指标公式

 

相关文章